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Welcome to SportsCode – The Ultimate Game Plan

This manual will help you find your way around SportsCode. The manual includes descriptions for 
SportsCode Elite, SportsCode Pro, SportsCode Review, and SportsCode Player. 

SportsCode Elite* only features are noted by an asterisk next to the feature description. 

This manual assumes you have already seen a demonstration or been trained in using SportsCode 
and therefore have some knowledge base of how it works. If you are unfamiliar with the SportsCode 
suite of products, or require more information, please email Sportstec at support@sportstec.com.

Overview of SportsCode

SportsCode is very user friendly– just follow some simple steps and you’ll be on your way.

Here’s a quick guide how the SportsCode process works for a new movie. You’ll find step by step 
instructions in the following pages.

1.	 Click on the SportsCode icon in the dock or on your desktop.  

2.	 Create a new Code window. This is the window where you begin the analysis process.

3.	 Decide which actions in the performance you want to categorize (code) for analysis. Create and 
name code buttons for all the actions. eg. a player, a move, or each time a goal is scored. Each 
button will code instances for the actions in the timeline.

4.	 Capture the movie and code the information you need using the code window.

5.	 You now have the event captured and coded. The movie and the timeline are linked together.

6.	 You can now review and analyze the performance. If you want to change the information, add to 
it or delete from it, it’s easy. SportsCode is completely flexible to fit your needs.

			   SportsCode – Unlock Potential !
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SportsCode Set-up Requirements

The minimum recommended computer requirements for SportsCode are:

•	 Greater than 2.4 GHz Intel Core i5

•	 Mac OS X 10.8 or greater

We strongly recommend :

•	 A minimum of 8GB of RAM 

•	 An SSD Hard Disk of suitable size (Never begin a Capture if there is less than 200GB of space 
available).

•	 An external Hard Drive that is interfaced to the computer using a single or double Thunderbolt 
interface cable, or a Firewire 800 9pin cable. (A USB connection is not suitable).

 to any computer using SportsCode.

Current SportsCode Version

The current version which this manual relates to is SportsCode Version 10.0

To check which version of SportsCode you are operating, click on SportsCode in the Main Menu.  The 
first item in the drop down menu “About SportsCode n.nn.nn displays the SportsCode version you 
have.
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Registration of SportsCode V10

SportsCode Version 10 will only run if you have  registered a registration code over the internet. 
Make sure you close all other applications while you’re registering SportsCode.

To register online you will be presented with a registration process dialogue box. You must have your 
computer connected to the internet before you do this and must have admin operator privileges for 
the computer.

This is the initial registration window displayed :

Put the registration code that you received with the software into the registration code box of the 
window. If you input the code correctly you will see a green tick at the end of the text box. (for 
demonstration purposes a false code has been entered here so there is no green tick.)

This is the same window with a reg number inserted into the registration field. 
(Note that the button at the bottom right has changed from “Demo” to “Register”)

Clicking  will connect your computer to the Sportstec internet registration server and carry out the 
registration process.

Successful registration is indicated by:   

In OSX 10.9 Mavericks it is also necessary to allow SportsCode to make changes to the system (the 
registration is locked to the computer) by providing an admin name and password.
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SportsCode Preferences

The Preferences Windows provide you with a series of settings for SportsCode, enabling you to set 
up SportsCode for yur particular needs.

Following is an explanation of the function of each of these Preference settings. An explanation of 
the specific setting options is also contained in the sections of the manual which relate to those 
settings.

There are 3 buttons at the base of each of the windows. These allow you to accept the system default 
settings for the Preferences, cancel any preference settings you may have just input or to accept and 
save ( OK ) the preference settings you have just input.

General

•	 The screen that will be used to display full screen movies can be set by selecting the screen in 
the Output to full screen drop down menu.

•	 By selecting the Auto load files option, any files that are open when SportsCode is quit, will 
be reopened on the next launch of SportsCode. We recommend doing this on match day. Turn 
this option on, open all the windows that will be used such as code windows, matrices and 
statistical windows, then quit SportsCode. The next time you launch, they open again in the 
last used positions. 
 
NB: If you have set your computer preferences to close all windows at shutdown, this feature cannot 
be enabled.

•	 Tick Automatically check for updates if you want your system to always check for updates on 
startup
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Capture

The box at the top of the Capture Preference window provides for either Quicktime Capture or 
AV Foundation Capture. The varying Capture Window presentations are described in the Capture 
section of this manual.
•	 Allow code mode during capture -  Code mode can be used in the code window to code 

instances at the location of the playhead in the timeline during capture. This allows you to 
code an event that has already happened and still continue to capture.Note: Remember to 
switch back to capture mode in the code window to code instances in real time.

•	 Close code buttons when pausing or resuming capture
•	 Show timeline movie during capture - When selected, the timeline movie window will appear 

along with the capture window.
•	 Show timeline during capture -  Employ this feature if the user wishes to show the timeline, 

during capture.
•	 Zoom timeline during capture - The capturing timeline will automatically zoom in towards 

twice the default movie segment duration.
•	 Update timeline regularly during capture -  This allows the timeline movie to be played in a 

state of delay behind the capture movie without bumping into the end of the timeline.
•	 Close window when capture stopped - When this option is selected, the capture window will 
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be closed when capture has been ended.
•	 Create single movie file after capture - This option will create a standalone movie from the 

timeline movie next to the capture package.
•	 Use timecode produced from capturing device - Timecode generated from the capture device 

will be saved in the timeline timecode track.
•	 Default movie segment duration - This preference sets this default duration. It is strongly 

recommended that you use a default setting of 1 minute unless timeline share updating is 
paramount. We recommend saving captured movie packages as standalone packages after 
capture. 

•	 Minimum movie segment duration -  This is important for timeline sharing as it is readied for 
access by the timeline share process as quickly as possible. When a code button has ended, it 
signals the capture window to end the current movie part that is being captured in order to 
allow access to the latest captured video part in the timeline. So, if the setting of a code button 
was ended after 5 seconds of a movie part starting and this setting is set to 1 minute, it will 
take another 55 seconds for the movie part to be ended and ready for viewing in the timeline. 
We recommend using 30 seconds for default duration and 10 seconds for minimum duration 
settings when using timeline share. Otherwise, use the default settings.

Note: Choosing Never and None for the above 2 options will create one movie part for the entire 
duration of the capture session.
•	 Quick Recording Folder - This is the default folder where the capture package will be saved 

automatically when the Quickstart capture feature is used
Resolve Blackmagic PAL Input
•	 This is a unique setting required to support PAL composite video inputs for Blackmagic devices. 

Use this setting only when capturing standard definition PAL composite video feeds.
•	 Force audio delay by  NN seconds - If selected, an audio delay can be included in the capture 

process that nudges the audio track positive or negative once capture is complete. The nudge 
occurs in the timeline reference movie, the native movie parts are not adjusted.

Movies
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•	 Auto play movies created - When an instance is created from any source, it will open and 
begin to play.

•	 Full screen presentation mode - 
•	 Synchronise source movie with full screen movie
•	 Adjust display resolution for full screen movies - This option reduces the screen resolution 

when presenting movies full screen.  It can help smooth out playback when viewing movies 
full screen, particularly on older computers. This is helpful when presenting H.264 compressed 
movies. Note: the screen will go through a black transition period when a movie is presented, 
this is normal.

•	 Use single field for interlaced movies- Only one field is shown of an interlaced movie. This 
helps clean up jagged edges when the video is paused.

•	 Deinterlace interlaced movies- This option blends both fields of interlaced video to help 
reduce the jagged appearance in interlaced video.

•	 Duration of static text for instances - This sets the duration of static text and titles for instance 
movies created from the timeline, matrix, and movie organizer.

•	 Maximum number of pictures in Movie Organiser title - This sets how many pictures will be 
used in the title as a background effect. Setting this zero will create a black with row text only. 
Using large number settings can cause the movie organiser movie creation time to be very 
long especially if there are a large amount of rows in the organiser.

•	 Limit chapter track text to  nnnn  characters - When there are a lot of labels for an instance, 
the instance movie cannot display them in the chapter menu of the instance movie window. 
The chapter menu is removed in this situation. To retain the chapter menu, set an amount of 
text to be displayed in this setting, only that amount of characters will be displayed and the 
rest will be truncated. This allows enough room for the timeline in the instance movie to be 
displayed and used properly.

•	 No sound if movie playback speed is greater than nnn percent - Setting this option helps 
using the playback speed slider in the Movie floating toolbar. In some cases, the default 
playback speed may be greatly increased to allow for faster coding. Cutting out the sound 
playback makes this process smoother.

•	 Lead time for stack switch in timeline movie - The default for this setting is 10, this means 
when one angle of the stack is being played and the view is switched, the playhead will jump 
back 10 seconds, so the new view can be easily replayed without rewinding. This jump only 
occurs when the movie is playing. If the movie is paused, the angles will switch without the 
playhead moving.

•	 Stack Switch Hotkeys - Turn on the Stack Switch hotkeys by selecting the check box, then click 
on the boxes next to Movie 1, Movie 2, etc. Choose a hotkey by pressing a key on the keyboard. 
Movie 1 will be the top right angle, Movie 2 will be the next one to the right and so on. If there 
are 4 or more angles, the numbering will flow from right to left and down. Note: These hotkeys 
will override any other hotkeys in the application, so it is recommended that code windows are 
checked for clashing hotkeys.
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Timelines
•	 Auto save Timelines  When selected, any opened timeline will be saved automatically as the 

timeline is updated.
•	 Save timeline as XML - This will convert and save timelines in an XML format. 
NOTE :   Versions of SportsCode prior to version 8.5.2 cannot open XML timelines.

•	 To make moving timelines and their movies around a little easier, select the “Group timeline 
and movie windows” option. The timeline and its movie window will be locked together and 
can be dragged around together as one. To move them independently, hold down SHIFT and 
click and drag on the window to reposition it.

•	 Open timelines with playhead set to start if not in ‘Open recent’  moves the playhead to the 
beginning of the movie if the timeline is not in the opened recent list. If the timeline is in the 
open recent list, then the last playhead location is set.

•	 Try to combine timelines into one video and one audio track - when selected, will create a 
timeline movie reference file that works better with the Final Cut XML export. Final Cut does 
not like movies that are made up multiple tracks, especially if they overlap or are otherwise 

“strange”.
•	 Alphabetize rows during coding 

Automatically organises the Timeline rows in A - Z alphabetical order from the top down.

Overlay Text *

Movie Overlay Text

The overlay text preferences can be set live, so we recommend opening a movie with overlay text, 
then make changes to the preferences. This will save some time getting the settings perfect.

•	 Overlay text Font size is set by inputting the desired font size in the numerical field.

•	 Showing or hiding the Background, Code, Label and Instance Notes components of overlay 
text is done by ticking the boxes next to each component. Changing colors of overlay text 
components is done by clicking on the colorwell beside the component and choosing a color.

* SportsCode Elite Only
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•	 Background and Text overlay opacity of the overlay text can be set by dragging the slider or 
manually inputting an opacity value. The lower the value, the more invisible the background 
will be. The background opacity sets the opacity for the background of the text that is 
displayed where the text overlay opacity sets the opacity for the overall text display of all 
components.

•	 Vertical Text position is changed by moving the slider. The text can be moved to the absolute 
top and bottom boundaries of the movie frame.

Full Screen Movie Time

•	 When “Enabled” is selected, a time counter will be shown in a floating window over the movie 
when presented in full screen. The floating window position can be changed by clicking and 
dragging on the window.

•	 The “Font Size” of the time text can be changed using the slider or manually inputted.

•	 The “Background” can be switched on or off by ticking the box. The “Background Color” can 
be set by clicking on the color well and selecting a color.

•	 The “Background opacity” can be set using the slider or manually inputted.

•	 The “Foreground opacity” slider sets the overall opacity for the time display. This is set by 
dragging the slider or manually inputted a value.
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There are 3 time display options:

1.	 “Movie time” displays the actual movie time from 00:00:00.00 to its end as it relates to its total 
play length.

2.	 “Relative movie time” displays the time for which the instances are found in a timeline. This is 
convenient for finding its position in the timeline. When this is selected, the time display is not 
continuous, it can appear to jump from 01:03:15 to 00:03:25. This depends on how the movie 
was created.

3.	 “TimeCode” displays the timecode track information which is time of day for when the movie 
was captured or for what time the movie timecode was set.

•	 “Display whole seconds” removes the hundredths place from the counter. This makes the 
window less wide hiding the higher precision data.

Flagging *

•	 Enable Flagging - This turns on and off the flagging feature. See the Flagging section of this 
manual to learn more.

Flag properties window - This is area where the flag label, color and hotkey are set.  To set up a new 
flag, click on the plus button near the bottom of the window, this will add a new row. Click in the cell 
of the Flag column and type in a name for the flag, then choose a color by clicking on the color chip 
in the Color column and finally click in the cell of the Hotkey column to input a hotkey for the flag. 
NOTE: The flag hotkeys, like the multiview hotkeys, are global hotkeys and will interrupt code 
window hotkeys if they are like hotkeys.

By checking “Notes” for a flag, a Note window will open when you activate  that flag to allow you to 
insert a note into the flagged instance. Check “Organiser” and/or “Sorter” to automatically add the 
flagged instance to the Movie Organiser and/or the Sorter.

Delete a flag by selecting a row and clicking on the minus button.

* SportsCode Elite Only
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Communications

The “Stop all communications” checkbox  option is a universal network security option. This 
preference is checked by default so when you access the Preference Window for the first time the 
Preference window will be unavailable. You will be required to uncheck the box and then either 
enter a password chosen for the network, (for a completely new network,) or enter the password of 
the existing network.  You will now be able to set the remainder of the preferences for your network 
to operate. See the explanation below regarding this function, but we recommend that this 
checkbox be activated when the network is inactive.

Name

Provide the computer with a name for the network. This is the name that will appear in the 
Communications window of other computers connected to the network, to indicate whether 
or not you are connected. Use a name that best describes how the computer will be used eg. 
Client computer 1  or Server computer.  This will make it easier to identify computers in the list.

Change Password

Set the password and verification field for the computer for this network.  NB. This is not a 
“system password” - it is a password for this SportsCode network only.  It is common practice to 
set all computers in the network to the same password, so        the auto connection feature can 
be used.

Use same password for auto connection to clients

Ticking the box  will try to connect with clients using the same password that is set above for the 
computer. A very convenient option to use when there are multiple clients to connect.

Disable automatic connection to clients 

When selected, the autoconnection process will not take place in the Remote Communications 
window. The connection process will have to be undertaken manually.
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Do not connect with clients

Tick this box when the computer will be acting only as a client. The computer will not act as a server 
and send any commands to any clients. Commonly used when computer is acting as a client only.

Stop servers connecting to this computer

Tick the box to stop all servers from connecting to the computer. The computer cannot be a client 
when this ticked. Commonly used when the computer is acting as a server only.

Allow servers to Start and Stop Capture

Tick this box to allow connected servers to start/stop capture on the computer.

Allow servers to Pause and Resume Capture

Tick this box to allow connected servers to pause/resume capture on the computer.

Allow servers to Update Capture

Tick this box to allow connected servers to update capture on the computer.

Port Settings

Port settings can be changed here. SportsCode uses 9093 which is a port left undefined by 
networking standards. When setting up for Internet remote communications, this may be changed 
to suit firewall rules. Be careful when changing this setting even on a local area network. Changing 
this could cause serious problems for a network where other services may be running over the same 
ports. Consult the IT department before changing this number.

Do Not Show Errors As They Occur

Tick this box to stop the error log from popping up during remote communications. Keep this option 
ticked unless trouble shooting is required.
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Share

•	 Users public web site folder - This option sets up the default web sharing folder for a user.
•	 Computers public web site folder - This option sets up the default web sharing folder for the 

system. 

Edit List
The edit list preferences enable or disable live edit list exports or imports during capture and coding 
sessions. 

Exports
XML
•	 “Export Sportstec XML” turns on automatic SportsCode XML export during capture and coding.
•	 “To Folder” sets the folder for where the file is saved.
•	 Use Package name - This option creates the edit list using the same name as the package.
•	 “Use name” sets the default name for the XML file.
•	 Save with capture package - This saves the edit list next to the capture package making it 

easier for users to use Excel or other third party reporting solutions.
Excel
•	 “Export Excel Spreadsheet” turns on automatic traditional Excel edit list export during capture 

and coding.
•	 “To Folder” sets the folder for where the file is saved.
•	 Use package name - This creates the edit list using the same name as the package.
•	 Save with capture package - This saves the edit list next to the capture package making it 

easier for users to use Excel or other third party reporting solutions.
Either format can be exported singularly or simulatenously. The file formats are described at length 
in the Export section of this manual.
•	 “Update edit list every NN seconds” sets the frequency at which new data is written to the file. 

It can be used to help with timing of third party data presentation work flows.  - Use this option 
to increase or decrease the frequency of which the edit list is updated. This applies to both 
exports and helps with timing when scripting is used to pick up the data from the file.

NOTE: Be careful not to set this number too low, in some situations trying to update a file too quickly 
will actually take the process longer overall and can also interrupt other processes.

Choose the target file directory by clicking the popup menu below the Directory for timeline text.  
The default is the capture package and generally this option should always be used.  Only change 
this setting if these data files will be used in an alternate workflow like for updating a web site . We 
recommend always using the XML format.
NOTE: Another added benefit of enabling these options, is they provide another form of backup for 
the timeline data.

Imports
•	 “Enable auto XML Import copying” initiates a procedure that copies the XML file from a remote 

folder to import into the timeline. This preference helps in areas where network connectivity is 
weak.
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Scripts 

•	 “Auto execute scripts” - When using the statistical function live during coding, it is very 
desirable to have this option selected. As changes in the timeline are made, this triggers the 
statistical window to automatically execute. While building and testing a statistical window 
we recommend turning it off for those occasions. This will save a little time by not throwing up 
errors every time a change is made.

•	 Include instances outside of the viewable range of the Timeline - By ticking this preference, 
instances that exist beyond the start and end time of the timeline will be used in the script 
execution process. Outlying instances are often created when using imported data.

Windows

•	 There are times when a lot of windows from various applications might be open at the same 
time, selecting “All windows forward when a window is clicked” will make sure that all the 
open SportsCode windows come to the front and will not be obscured by another application’s 
window.

•	 While working with SportsCode, windows get pushed all over the place especially timelines, 
to help create some consistency in where a timeline will open select “Default timeline and 
movie arrangement”. This option sets the timeline movie in the upper left corner of the screen 
and does a best effort to maximize the timeline window to display the most data that it can on 
the screen.

•	 “Maximum number of instance movies” Set how many instance movies can be open at one 
time. Once the maximum is reached the oldest movie made will be closed to allow the new 
one to be created. The default maximim is set to 100.

The Edit instance movie Sorter options are:

1.	 “Stop at end of instance”   The edit instance movie will play through once unless movie looping 
is turned on and remain in the current row of the sorter.
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2.	 ”Go to next instance”  The edit instance movie will play through to the end, then the sorter 
window will drop down a row from the current selected row and the movie for the new row 
will be paused at the start.

3.	 “Go to next instance and play”. While this option is selected, the edit instance movie will play 
through to the end, then the sorter window will drop down a row from the current selected 
row and the movie for the new row will be start to play automatically.

Matrix

•	 New matrix columns sorted by group - When a matrix is made from the timeline or code 
window, the labels will be sorted by their respective groups.

•	 Ignore groups for new matrix - This option will cause the matrix not to show the label groups 
for the labels.

•	 Row totals are all instances in timeline’s row - Displays the row totals as number of instances 
as opposed to displaying the total number of labels.

•	 Remove unused movies when web exporting - When the matrix is exporting live, many 
movies are created because the cells are constantly updating during the coding process. 
Enabling this option will clean these movies up during the process. This should remain enabled 
in most situations,  there are a few workflows where the extra movies are desired.  

•	 Export continuous update interval - Sets the interval for which the matrix will export html and 
movie data, this is useful when exporting only html data.

Spreadsheet

•	 Auto save spreadsheet This will auto save spreadsheets: sorters and statistical windows. The 
file will be saved every 10 seconds as changes are made. Also, backup files are made inside in 
the spreadsheet package. The backup files will have a date stamp in the name and are able to 
be dragged out of the package and used.

•	 Number of backups. This preference is the number of backup files that created. The default is 
10, when 10 backup files are made, the oldest one will be removed.
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Apple Remote

This preference is used to set up the Apple Remote options. Click on the different drop down menus 
to set the options. Refer to the description in the “Using a Remote Control” for more details.

Commando

This preference is used to set up the Commando Remote options. Click on the different drop down 
menus to set the options. Refer to the description in the “Using a Remote Control” for more details.

SportsCode Terms

Many terms in this manual are specific to SportsCode. Here’s a brief explanation of the most 
common terms.

Capture
	 To record a movie to a file.

Code
	� A category for information in your movie. When you want to keep a piece of action from a 

movie for later reference/analysis you code that snippet with a code button.

Code Button
	� Code buttons are used to define an action by its name and time when it occurred in a 

movie. For example you may name a code button “X Cut” to mark every time an opponent 
executes a certain play. Code buttons are toggle buttons, up or down, except when you 
have a lag time programmed which creates a fixed-length instance.

Code Matrix

	 The code matrix is a grid representation of code rows and labels in a timeline.

Code Window
	 The window for creating and using code buttons to categorize events in a timeline.

Database
	� A database is a timeline created by exporting selected instances from one or multiple 

timelines. The database process only exports the specified code and movie data.

Inactive
	� An Inactive button is used to title a set of buttons that do not perform any actions.

Instance
	� An instance is a coded segment of a movie. An instance becomes part of the timeline for 

that movie (also see code).
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Label
A Label is text inserted into an instance to describe an event or a consequence of an 
event marked by a code button

Lag Time
	� Lag time automatically adds a specific time to the end of an instance when it is being 

coded. When you click on the code button to code the instance, SportsCode automati-
cally adds the lag time to its end. Lag time creates a button that only needs to be pressed 
once. The beginning of the instance is marked when the button is pressed down and the 
end is marked when the lag time runs out.

Lead Time
	� Lead time automatically adds a specific time to the beginning of an instance when it is 

being coded. When you click on the code button to code the instance SportsCode adds 
the time to its beginning.

Movie
	 The performance you are using as the source of your information.

Package
	 A special type of folder that contains a timeline and movie.

Timeline
	� The window that displays a timeline showing each instance of all code buttons chrono-

logically recorded.
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The SportsCode Movie Controller

The movie controller is a “floating” toolbar which will appear whenever a movie is set up ready to 
play and by default will disappear when the cursor is removed from the window or has been inactive 
for 1.5 secs. It will reappear once the cursor is returned to the window The controller may be moved 
to wherever you find it most convenient. You are able to access the Drawing Tools, the Overlay Text 
fuction and the List of Chapters in the movie directly from the controller.

Loop Mode

Sets the playback mode for play once (Off) or repeat (On).

Movie Chapters List

Open this list to view a list of the chapter markers in the movie and 
where they are.

Playback Rate Control

This control sets the playback speed for all 
movies. Double click on the icon to reset it to the 
default speed of 1x.

Frame Fwd / Frame Rew
Hover the cursor over the bars close to and to the right of the Play/Pause 
symbol on the wheel. Click to frame forward.

Hover the cursor over the bars close to and to the left of the Play/Pause 
symbol on the wheel. Click to frame rewind.

Fast Fwd / Fast Rew
Hover the cursor over the bars at the extreme right of the Play/Pause 
symbol on the wheel. Click to fast forward.

Hover the cursor over the bars at the extreme left of the Play/Pause symbol 
on the wheel. Click to fast rewind.
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Play / Pause Button
Click the Play button to play.

Click the Pause button to pause.

Speaker Volume Controller

Move the volume control slider to vary the movie sound volume. Move to 
the left to decrease volume and move to the right to increase volume.

Overlay Text

Click this button to open “Overlay Text” to display the labels in each of the 
instances comprising the movie.

Drawing Toolbar

Click this button to show or hide the Drawing Window
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Keyboard Shortcuts

NOTE :  Any keyboard shortcut which is set in the Operating System preferences is likely to over-
ride the same SportsCode software keyboard shortcut. If you experience a SportsCode keyboard 
shortcut which does not perform in the manner described in this manual, you should try the 
alternative(s) described or you can disable the operating system keyboard shortcut.

MENU ITEM - FUNCTION KEYSTROKE

COMMAND ⌘
CONTROL ⌃
OPTION ⌥
SHIFT ⇧
LEFT  RIGHT  UP  DOWN ARROWS ← → ↑ ↓
PAGE UP  PAGE  DOWN fn↑   fn↓
DELETE ⌫
CLICK �
FILE

Open ⌘O

Combine timeline movies ⌘L

Save ⌘S

Save as ⇧⌘S

Print ⌘P

Quit ⌘Q

EDIT

Undo ⌘Z

Cut ⌘X

Copy ⌘C

Paste ⌘V

Select all ⌘A

Redo ⇧⌘Z

 Copy movie frame ⇧⌘C

 Paste selected instances in Movie Organizer ⌥⌘V

 Paste selected instances in Sorter ⇧⌘V

Instance edit ⌃E

Instance trim ⌃T
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EDIT

Nudge all instances left ⇧⌘L

Nudge all instances right ⇧⌘R

Nudge all instances on the right of the 
playhead to the right in the timeline

⌥⇧⌘R

Remove unused instance time to the right of 
the playhead

⌥⇧⌘L

Nudge sound track left ⌃⌥⌘L

Nudge sound track right ⌃⌥⌘R

Expand sound track ⌥⌘R

Contract sound track ⌥⌘L

Find ⌘F

Split instance edit ⌥⇧S
Split instance edit + new drawing row ⌃⌥⇧S
Mark start time ⌃I
Mark end time ⌃O
Extend start time ⌃⇧I
Extend end time ⌃⇧O
Play backwards ⌃J
Stop movie ⌃K
Play movie ⌃L
Instance labels ⌘E
Instance note ⌃N
WINDOWS

Present movie (Full screen) ⌘M

Make movie ⌥⌘M

Full screen coding ⇧⌘F

Live notes ⌃=
Cycle through windows ⌘`
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Show labels tree ⌃⌥E
Stack instance movies ⌘Y

Overlay instance movies ⌥⌘Y

Reduce movie size ⌘< (Use ⇧, for <)

Increase movie size ⌘> (Use ⇧, for >)

Reduce transparency ⌃⌥9

Increase transparency ⌃⌥0

Close all instance movies ⌘I

Close window ⌘W

Hide drawing tools ⇧⌥D

ROWS

Add row ⌘N

CAPTURE

Open capture window ⌘R

Quickstart capture ⌃⌘R

Stop capture ⌘/
Pause / Resume capture ⌘K

MOVIE WINDOW & PLAYBACK

Play / Stop ↑  ↓
Play / Stop Space Bar

Slow motion forward play Hold down →
Smooth rewind play Hold down ←
Fast forward play (1/10 sec steps) ⌘→

Fast rewind play (1/10 sec steps) ⌘←

Faster forward play (1/4 sec steps) ⇧→
Faster rewind play (1/4 sec steps) ⇧←
Fastest forward play (1 sec steps) ⌥→
Fastest rewind play (1 sec steps) ⌥←

Turbo forward play (10 sec steps) ⌃→
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Turbo rewind play (10 sec steps) ⌃←
Play stack movie angle in full window ⌥⌘ � � on movie angle

Move movie angle in stack ⌘ � & Drag

Select segment of instance movie ⇧ � & Drag instance movie playhead

TIMELINE WINDOW

Create an instance in selected row ⌥⌘ � & Drag instance movie playhead

Extend or shorten instance ⌥⌘ � & Drag on leading or trailing edge of instance

Duplicate instance ⌥ � & Drag from instance to other row

CODE WINDOW

Duplicate button ⌥ � & Drag from the button

Move selected button ← → ↑ ↓
Edit button window, apply button property to 
selected buttons

� on button property text

Move group of buttons �  & drag selected buttons

Move selected button to top layer ⌃↑
Move selected button to bottom layer ⌃↓
Move selected button up 1 layer ⌃→
Move selected button down 1 layer ⌃←
Toggle through Code/Label/Report/Edit mode ⌘↑ or ⌘↓
Stop (deactivate) all code buttons TAB

Deactivate last code button pressed ESC

GENERAL

Preferences ⌘,

Hide SportsCode ⌘H

Hide Others ⌥⌘H

MAC OS X

Screen snap shot to file ⇧⌘3

Selection snap shot to file ⇧⌘4

Screen snap shot to memory ⇧⌃⌘3    ⌘V to paste to another window

Selection snap shot to memory ⇧⌃⌘4    ⌘V to paste to another window

Enable display zoom ⌘⌥8

Zoom out display ⌘⌥-

Zoom in display ⌘⌥=
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Launch  SportsCode

Click on the icon in the Dock; double click on the SportsCode icon on your desktop or in the 
Applications folder.

The Startup Screen will open for you to choose which key SportsCode function you wish to access. 
Clicking on the function will prompt relevant dropdown menus to navigate to the file you wish 
to use.  Click on the “+” to open a new file.  On the right side of the panel will be a list of recently 
opened items. If the system cannot locate the file listed, a warning symbol inside a yellow triangle 
will be displayed alongside the file name.

•	 To create a new Timeline, Drawing Window or Code Window project, click on the relevant 
item in the top row.  When an item is chosen the startup window disappears and file opens.

•	 Open... When clicked an open file dialog appears and the startup window disappears.

•	 Import XML... When clicked an import file dialog appears and the startup window dissappears. 
After the XML file is selected, a timeline is created with the imported data.

•	 Capture... When clicked the capture window opens and the window disappears.

•	 Recent Files... This displays the Open Recent file list found under the File menu. The section is 
scrollable. If the system cannot locate the file listed, a warning symbol inside a yellow triangle 
will be displayed alongside the file name.

The Startup Screen will open by default when SportsCode is launched. The Startup Screen may be 
hidden by ticking the appropriate box in the General Preferences. 
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The Code Window

The SportsCode code window is the starting point for coding your movies. It will contain all the 
categories (buttons) you want to analyze such as set pieces in a field hockey game. Code buttons are 
used to categorize and mark the time of events in your movie. These events, or instances, become 
your own personal study of performance-specific information. You can save time by coding instances 
as you capture your movie. Then if you want to change, add or delete information, it’s easy to go 
back and do so later.

Create a New Code Window

 �Choose File > New > Code 
window from the main menu 
bar.

 
 

The Code Window Toolbar

Customize the Toolbar

The Code Window Toolbar is customizable.  Control click (right click) in a blank part of the Toolbar to 
open the Customize window. You may design your Toolbar using this window.

The Code Window Toolbar contains icons which have 4 distinct functions :

	 1. Coding Functions - (Actions; Links; Hotkeys) 
	 2. Analysis - (Matrix) 
	 3. Operating Mode Functions - (Capture ; Code ; Label ; Report; Edit) 
	 4. Display Functions - (Full Screen ; Transparency) 

Note: In Window Operating Modes, ( 3. above,) the active mode will be indicated by a darkened 
background. Only one of these modes can be active at any point in time.

A convenient shortcut is OPTION+UP ARROW or OPTION+DOWN ARROW to change modes.

Code Window Transparency

 This is used mainly while coding in full screen. To increase the transparency of the 
code window, (make the code window MORE transparent,) click on the Up arrow in 
the top left hand corner of the window next to the capture button. To decrease the 
transparency of the code window, click on the Down arrow.
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Capture

This will open the capture window.

Code

Use Code mode to code the timeline with your events at any time.  
NB. Codingis at the point of the playhead in the timeline

Label *

Use Label mode to add labels into instances in an existing timeline. ie. 
after the capture has taken place.

Report *
Report mode with code windows is designed for reporting information 
using button scripting. In this mode, code and label buttons do not insert 
data into the timeline.

Edit
Edit mode builds your Code Window by creating buttons and labels 
and also to change button properties. 

Inspector

Use the Inspector function to edit and manipulate the appearance and behaviour of 
buttons in the Code Window.

Matrix

With a Timeline open, clicking this button in the Code Window allows you to quickly 
display a Matrix of selected buttons and Labels. Click and holding down the mouse 
button over the arrowhead symbol will reveal a drop down menu of functional 
options.

Actions Panel

Enter

Pressing the Enter button in Code or Capture mode will end all active code buttons. 
The short cut for this is the TAB key. This is a very convenient feature while live coding 
especially when multiple code buttons are active.

Clear

Pressing the Clear button in Code or Capture mode will stop the marking of an instance. 
The short cut for this in the ESC key. This is mostly used when accidently hitting a code 
button during live coding.

* SportsCode Elite Only

http://support.sportstec.com/entries/21424733-Capture-Code-Mode
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Reset

Pressing the Reset button in Code or Capture mode will remove the last instance that 
was ended.

Code Button

In Edit mode, clicking and dragging from this button into the Code Window will 
create a new code button.

Label Button *

In Edit mode, clicking and dragging from this button into the Code Window below 
will create a new label button. In Code mode, mouse over a label button to display the 
group (if any) which the label belongs to.

Keys

Pressing the keys button will reveal all the hotkeys that are set for each button when show 
keys option is unselected for the button and the hotkeys are not visible.

Links

Pressing the left links button will hide the links between buttons.  
Pressing the middle button will portray the links below the 
buttons (this is the option illustrated.)  Pressing the right button 
will portray the links above the buttons

Settings

Clicking on the Settings button will reveal the Setting panel. Three options can be 
selected in the panel: Background image or color for the code window and Merge 
overlapping instances. When the ‘Merge overlapping Instances’ is selected, instances 
that overlap due to lead time will be merged into one instance.

Share

Click this button to export an html webpage representation of the Code Window.

* SportsCode Elite Only
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Execute

Clicking on the Execute will manually trigger all scripts in the buttons to be executed. 
This is useful when editing and testing scripting within the buttons.

Label Tree *

The Label Tree button will generate a labels tree based on the all the label buttons 
found in the code window.

Batch Rename *

If a button or group of buttons have been assigned a Button ID, then this button 
may be renamed individually or if a group, renamed en masse using a CSV file.

Code Button History

A record of the buttons you’ve used, will be displayed in the history line which is located 
immediately below the toolbar.  The most recent button activation is shown to the right of the line. A 
triangle pointing down indicates a code button being activated. A triangle pointing up indicates that 
code button being turned off.

Button Information Bar

The Button Information Bar is located in the baseline of the Code Input Window. When you hover the 
cursor over a button, it’s name and the button ID will be displayed in this bar.

* SportsCode Elite Only
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SportsCode Button Types
Code Button 

Code buttons are identified as having a blue background by default and a white 
diamond symbol in the top left corner. 

•	 Name a code button to define an event which will become an instance in the timeline, for 
example you may name a code button “Slam dunk” for a basketball game.

•	 When you have captured a movie and used a code button, the button creates a row in 
the left column of the timeline. 

•	 The code button identifier symbol, a diamond, will be either white or green. A white 
diamond means it has a toggle action that must be clicked on to start coding an instance 
and click on it again to stop coding. A green diamond means the button has a lag time 
and will stop coding at the predefined lag time after it has been clicked.

Label Button * 

 Label buttons are identified as having a yellow background by default and a white 
circle symbol in the top left corner. 

•	 Name a label button with a description or a consequence of an event marked by a code 
button. This label is attached to the last open coded instance on the timeline or all active 
code buttons pressed down. For example, you may name a label button “Three Point” for 
a “Shot on Goal” code button.

•	 Labels in an instance can be quickly viewed by mousing over an instance in the timeline. 
The labels will appear above the playhead strip.

Inactive Button

Inactive Buttons are identified with a white square. 

•	 An Inactive button does not perform any coding action, it is only used to put headings, 
comments or graphics within the code window. 

Action Button *

Action Buttons are identified with a white triangle symbol. Action buttons are used 
in conjunction with scripting. There are two types of action buttons: Make movie and 

Toggle.

The Make movie Action button will read a SHOW INSTANCES command in the script when the 
button is clicked on in Capture, Code or Report mode and then make a movie.

A Toggle button is generally used in scripting with BUTTON STATE commands.  For instance, a script 
can read the state of the button and change its name based on whether the toggle button is up 
or down. They do not create an instance or a label so it will not have any effect on the Timeline or 
Matrix.
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* SportsCode Elite Only

Edit Mode

Edit Mode is used to edit a Code Window and to edit buttons within a Code window.  In Edit Mode, 
buttons are placed into the Code Window and their Appearance and Behaviour is specified to 
determine how the use of these buttons during coding will affect the information inserted into the 
Timeline.

Create/Add New Code Button

 �To create a code button, click and drag the code button icon in the tool bar to the body of the 
code window.

Create or Add a New Label Button, Inactive or Active Button

To create or add a Label Button to the Code Window, click and drag the label button icon in the 
tool bar to the body of the code window. or create a Code button and then use the Inspector Panel 
to change it to a Label button, an Inactive button or an Active button.

Create an Inactive or Action Button

Create a code button, then use the Inspector to change it to an Inactive button or an Action button.

Move a Button 

�Click on the button and drag it to the required location in the window or use the arrow keys to move 
more precisely.

Move a Group of Buttons

1.	 Hold down the COMMAND key and select the buttons you want to move, or click and drag over 
the group using the lasso bounding box to make the selections. 

2.	 Click and drag the buttons to the required position.

Duplicate a Button

1.	 To duplicate a button and its properties, select the button by clicking on it once.

2.	 Press the OPTION key and click and drag the duplicate to another location within the Code 
window.

3.	 Name the new button. All the properties will be the same as the original except for the Hot Key 
and the linking. A Hot key can only be allocated once per code window.

4.	 To duplicate a button from one code window to another, press the OPTION key and click and 
drag the duplicate to the new window.

Duplicate a Group of Buttons

To duplicate a group of selected buttons from one code window to another, press and hold the 
COMMAND key and click on each button in the group, next press the OPTION key and click and drag 
the group to the new window.
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Button Layers

Every button created in the code window is on a separate layer. These layers are not visible, and 
this architecture can be used to your advantage if required.  It is sometimes useful to overlap 
buttons or hide them. 

1.	 To move a button to the top layer, highlight the button, press CONTROL and the RIGHT ARROW 
key.

2.	 To move a button to the bottom layer, highlight the button, press CONTROL and the LEFT 
ARROW key.

3.	 To move one layer at a time, press the CONTROL key and press ARROW UP to move the layer up 
1 level at a time or press CONTROL key and press ARROW DOWN to shift the layer down 1 level 
at a time.

Alternatively, right click (CONTROL+CLICK) on the button and select the action 
from the drop down menu.

Note: In a Code Window you may select multiple buttons either by using the Apple “lasso” function 
or by holding down the Command key and individually clicking the desired buttons.

Resize a Button

1.	 Click and drag on a resizing knob on any side or corner of the button. 

2.	 Drag the button to the desired size.

Delete a Button 

Click on the button and press DELETE on the keyboard.

Edit a Button

To edit the properties of a button, open the Inspector . Refer to page 35 or:

Edit a button during any mode by selecting a contextual menu accessed by right clicking on the 
button.

Select a Background for the Code Window

You may select a colour or an image as a background for your Code Window.

In Edit Mode, click the Settings button at the right of the Code Window Toolbar.

To select a colour for the background, click on the “Background Colour” box to open a palette.

To select an image, click on the Image box to open a file list menu, or click on an image and drag and 
drop it into the box. Use the dropdown menu attached to the box to manipulate the image.
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* SportsCode Elite Only

The Inspector Panel

With Edit mode selected in the toolbar, click on any button to select it. A selected 
button will be surrounded by 8 resizing knobs. Open the Inspector panel by clicking 
on the Inspector icon in the toolbar or by double clicking on the selected button.:

By default the Inspector panel will open with the Edit properties view open.  This panel contains 4 
sections :

Button Coding Behaviors and Links

Appearance and Geometry

Alternate Names *

Script 

In the Inspector Panel any box or radio button which can be activated or deactivated is referred to as 
a “property” because such action will change the property of the button.

To speed up the editing process, leave the Inspector Panel open and click on another button in the 
code window. This saves the previous button properties and switches to the selected button.

Button Behaviour
Button Type - Code / Inactive / Label / Action

Your choice will open the panel below it for the button type 
selected. You may change a button type and with it the 
function of the selected button with this panel.

Code 

You may change the Button Name in this panel

Custom Lead Time

Custom lead time allows you to program a specific lead time 
to individual buttons. Check the custom lead time box and 
enter the number of seconds of lead time you need.  
Note: If no Custom Lead Time is specified, the default lead 
time will apply.

 Lag Time

Lag Time automatically adds a specific time to the end of an 
instance when it is being coded. When you click on the code 
button to code the instance, SportsCode adds the lag time to 
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the end of the Instance. Check the Lag time box and enter the required lag time.

Code Buttons that use a lag time have a green diamond identifier. 

For example; You are coding a movie and have a six-second lead time and a two-second lag time for 
a code button named “Goal”. When you see the “Goal” and click on the button, the instance in the 
timeline will be eight seconds.

This becomes a fixed Iength instance and requires that you only click on the button once (to activate 
it) which makes the coding process faster and easier.

Re-activate Lag Time

When this option is ticked, the lag time of the button will be re-activated to extend the length of 
the instance if the button is pressed again before the lag time has expired. This is to make provision 
for more accurate statistical counting of instances when ticked instances are extended, so 2 events 
of the same type will merge into one event. If this is not ticked, an activated Code Button which is 
counting down lag time when clicked on again will stop coding the current instance . You will be 
required to click the button again and create a new instance with the new lag time count down 
intitiated.

While coding, you will find that you may want to block labels from inserting into certain codes, so 
the labels do not end up in the wrong code. There are two options to help with this.

Populate Codes in Timeline

Check the populate box to automatically populate the timeline with code rows upon code or capture 
mode activation.

Block de-activate all

During Code Mode , when the TAB key (or the Enter button in the Toolbar) is pressed, it de-activates 
all code buttons that are currently active. When this option is ticked, the code button will not 
respond to the TAB key or the Enter button.

Block all labels 

Stops the code button from accepting any label. The instance will never have any labels inserted in it.

Block labels unless last down

Stops a label from inserting into an instance unless it was the last code button pressed down. To 
effectively use this property, the coding process must be done sequentially to guarantee that the 
label inserts into the correct code.

Notes

Tick the Notes checkbox to activate the Instance Note dialogue 
feature, then choose whether the feature will appear when the 
code button is activated or when it is deactivated.
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Button ID 

The button ID for a button is an alternate way of calling on the button other than using its name, 
this feature has far reaching implications for statistical commands.  Button IDs should be unique, but 
do not have to be. We recommend using some type of naming convention like player01, player02, 
player03, etc.  Within stat commands, we can change code names according to certain conditions 
and then push the button down to code it

Customized Hotkeys

To speed up your coding, instead of using your mouse to press (activate) your code or label 
buttons, you can assign a hotkey to a button. Using hotkeys will be considerably faster when 
you are coding, than moving and clicking your mouse or mouse pad.

Assign Hotkeys

Click on the Hotkeys box  
Press the key or key combination you want to use. Combinations can be configured using the 
modifier keys COMMAND, OPTION, CONTROL, and SHIFT. 
Press the modifier keys first, then the character you want to assign.

Note: You can use up to three modifier keys at once plus one character. This allows for over one thousand individual hot 
key combinations. There are some combinations reserved for the system, most of these use the COMMAND key.

Tool Tip

This is a box for entering free text as a description or information about the button. When you hover 
the cursor over the button the Tool Tip description will be displayed. The text entered here will have 
no effect on the timeline.

Button type - Label 

Label Group

Label group information can be added to a label by clicking on 
the Group field below the Label name for a label button. Adding 
a group to a label is recommended as it makes organizing and 
sorting in the sorter and matrix easier and more powerful. An 
example of group might be “PLAYER”. If “PLAYER” is added as a group to a number of player label 
buttons, these labels will be grouped in the matrix together or in the sorter, the labels can be sorted 
by frequency.  When you mouse over a label in the Code Window, the group to which the label 
belongs is displayed.

Apply 
The label insertion sequence can be altered to either insert the label after an activation link is fired 
off or before a deactivation link is fired off.  This can help determine to which instance a label is or is 
not inserted into.
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Button Appearance

Use an Image as a Button Fill

At the top of the Appearance Panel is a box which 
represents the button in the coding form which is 
highlighted if that button has an image in it. Any 
image can be used to fill any button in the Code 
Window. To place an image into a button, (or replace 
the image in a button,) just select the image and 
drag it to the box in the Appearance Panel and drop 
it. By default the image will be resized to fit the size 
and shape of the box and therefore the button.  You 
may reset the image dimensions to the original image 
size and shape by clicking the button below the box, 
this will resize the button in the Code Window to fit 
the original image size. Or, use COMMAND + CNTRL 
+ SHIFT + 3 to copy an image to the clipboard and 
then COMMAND + V to paste the image directly into 
the target button in the Code Window. In this case, by 
default the image will assume the size of the original 
image. If an image is copied directly into a Code 
Window it will by default create a Code button.

Change A Button Color

�Click on the “Background color” pane and drag your 
cursor to the color chip in the color palette to select a 
color. Code rows can be sorted by color.

Set or Change the Color of a Button Border

You may set or change a colored border around a button. Click on this pane and drag your cursor to 
the color chip in the color palette.

Border Width

The width of the border around a button can be increased or decreased by clicking the up or down 
arrows. The border is contained within the existing size boundaries of the button.

Lock a Button Position 

Check the Lock position check box to lock the button in place in the Code Window. 
This will also prevent the button from being deleted accidently.
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Show Identifiers

This box is ticked by default. It displays the button identifier symbol. Uncheck this box if you do not 
want the symbol displayed.

Wrap Text

If this box is ticked, text will be wrapped within the horizontal confines of the button. If the box is 
not ticked, text will display on one line and extend beyond the horizontal borders of the button.

Display Button Name, Hotkey or Statistical Output

�Tick the check boxes adjacent to the identifier to display the button name, Hotkey or cell information 
from a statistical window. If the box is not ticked, these properties will not be displayed.

Edit a Button Font

The Font properties of the Button Name, Hotkey and Statistical 
Output which may be displayed (font family, typeface, size, color 
etc) can be edited by clicking the “Edit Form” button adjacent to 
the checkbox and identifier for each of these. This can also be 
accessed by highlighting the button in the Code Window and 
selecting the Font icon from the Toolbar. Make your selection 
from the drop down panel. You may choose to edit any number 
of these from the Edit Font panel, by specifying your selection(s) 
from the boxes at the base of the panel

Change the Position of a Button Name, Hotkey and Statistical Output

1.	 Click on the points of the text positioning tool.

2.	 Click in the center box to reset the position to the center of the button.

Default Output Text

If the “Show Output” box is ticked to display the output of a statistical script to the button, by default 
a ? will be displayed. You may display any other character or set of characters as the 
default by specifying this here.  The default will be overridden by any statistical output.

Button Opacity

You may set or alter the opacity (transparency) of a button in the Code Window by dragging the 
slider - left for more transparent (less visible) and right for less transparent (more visible.)
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Button Geometry

The Button Geometry panel provides the facility 
to precisely position your button within the Code 
window and to precisely determine the size of a 
button.  Each display has an up and down arrow to 
increase or decrease the value in the display.

The X displays the position of the button from the left side of the Code window. Increasing the value 
will move the entire button to the right, decreasing the value will move the button to the left.  The Y 
displays the position of the button from the top of the Code window. Increasing the value will move 
the entire button Down in the window, decreasing the value will move the button Up.

The Width displays the size of the button from left to right. Increasing the value will move the right 
side of the button to the right, decreasing the value will move the right side of the button to the 
left.  The Height displays the of the button from top to bottom. Increasing the value will move the 
bottom of the button Down , decreasing the value will move the bottom of the button Up.

Button Links

In order to simplify the coding process, buttons may be linked to activate or deactivate other 
buttons in the code window.

Select and highlight your Initiator button, then click on the 
arrow box alongside the required linking property and select 
your Target button.

Activation Links - Button to Button

A button (initiator button) can be linked to another button (the target button) to activate it. When 
the initiator button is pressed down, it activates any linked target buttons. An Activation Link line is 
colored green and the arrow indicates the direction in which the activation will occur. Any type of 
button can activate another button. Chains of activation can extend to activate multiple buttons.

Hotkeys

1.	 To keep a tidy window, uncheck the “Show hotkey” box in the Inspector panel. Then press 
the keys button in the code window to show them when you need them. 

2.	 Use USB devices such as remote controls or number keypads to make it easier, especially if 
you are filming and trying to code at the same time.
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De-activation Links - Button to Button

A button (initiator button) can be linked to another button (the target button) to de-activate the 
target button when the initiator button is pressed down. A De-activation Link line is colored red and 
the arrow indicates the direction in which the de-activation will occur. Any type of button can de-
activate another button. Chains of de-activation can extend to de-activate multiple buttons.

Exclusive Links -  Code Button to Code Button

Two or more Code buttons can be exclusively linked. This means when one button is active and 
a linked button is pressed, the first button will be de-activated (stop coding) and the second be 
activated (start coding). The coding properties of these linked buttons will be mutually exclusive. 
This feature is great for rapid change of direction, one click to stop one button and start another. 
Very commonly used for coding offense and defense possessions.

An Exclusive Link line is colored purple and has no directional arrow.

You may override the properties of an exclusive link and activate a button while a button to which it 
is linked is still active, by holding down the function key while pressing the new code button.

Exclusive Links - Label to Code Button

A label can be exclusively linked to a code button, so when it is pressed it can only be inserted into 
the linked code button.

Remove a Link

1.	 Click on the Link which is to be removed. It will assume a blue border to indicate that it is 
selected.  Press the Delete Key or: 

2.	 Select and highlight your Initiator button, then click on the arrow box alongside the required 
linking property to display the list of available buttons and deselect the Target button.

Live Coding

Coding can be done during capture, press the capture icon in the code window tool bar to open 
the Capture window, then press the Capture button to start the process. You can code using the 
mouse or using hot keys. To save time, we suggest using hot keys because you can type while 
watching the performance, whereas if you are mousing you will have to look where you are 
clicking.

Pausing the movie capture during breaks (such as advertisement breaks) will save your computer 
disk space. Click on the pause button in the capture window or press COMMAND+K. Click on the 
resume button or COMMAND+K to continue capture. Use the pause option if you need to fast 
forward dvds/tapes or interrupt the video signal during the movie capture.
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Alternate Names

Button Renaming

Buttons can be renamed using the context menu (right-click on the button) or en masse using the 
Batch Rename feature.

Settings File

This feature works off of a CSV file located in ~/Documents/SportsCode User Data/code_window/
batch_rename.csv. The csv file is a simple mapping table that can be created in Excel, Numbers or 
any plain text editor. In a plain text editor the file looks like this:

,Buffalo Sabres
player01,Luke Adam
player02,Paul Gaustad
player03,Derek Roy

NOTE - If your names have quotes or commas you will need to place quotes (or double quotes) 
around all names that are separated by the commas. I would recommend keeping the names free of 
punctuation. Keep it simple.

Let’s look at the first row in the example above. The first 
column is ignored, this can have any text you like. I have left 
it blank. The next column is the Group name for the column. 
Groups are used to organize sets of names. In this case, I 
have used “Buffalo Sabres”, so this will be the group name 
that appears in SportsCode.

The second row and all following rows are where the “mapping” takes place. The first column is the 
button ID, the second column is the name that relates to the ID. This can be extended to include 
multiple groups for a button also. The names.csv can look like this too.

Single Button Rename

A button can be renamed by right clicking on the button and if that buttons ID exists within the 
Alternate Names tab or in a properly formatted .csv file, the context menu will have an item called 

“Rename”.  The “Rename” menu item will contain the alternate names from all groups. Select the 
name from the list and the button will be renamed.
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Multiple Button Rename

To rename a group of buttons, click on the “Batch Rename” and a popup sheet will appear and ask 
which group you want to use for the rename operation. Select the group and it will show you the 
buttons that will be renamed.

The CSV file is cached after the first time you use this feature. If you want to reload the CSV file from 
the disk, hold down OPTION when clicking on the “Batch Rename” button. This is handy when you 
are testing or adding items to the CSV file as you go.

Statistical Scripting for Buttons in the Code Window

Under the Help menu, a link is provided to the statistical command help.

http://statistics.sporstec.com/documentation
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Modes of the Code Window

Capture Mode

When in Capture mode, activating buttons in the Code Window 
will create instances in the Timeline in Current Time. (refer to the 
definition  of Current Time on page 86.) 

During capture any of the 4 modes in the Code window can be used without affecting the capture.

Code Mode

Code Mode will insert instances at the position of the playhead on 
the timeline. When a code button is clicked to start marking an 
instance, the instance will start at the playhead if no lead time is set 

for the button. 

After the movie is captured and available in a timeline, coding can be done by dragging the 
playhead to any location or using the movie controls such as fast forward, even the playback speed 
can be set faster in the floating toolbar.

During capture, this can be used to code behind the capturing movie, a great option for live coding. 
Instances can be coded very accurately and precisely. There is a small time gap between the capture 
and the timeline movie that cannot be coded during capture.

Coding Instances

a. From a movie already linked to a Timeline 
Open a code window and movie linked to a timeline, then press the Code mode button and the 
movie will play. When you see an event in your movie that you want to code, click on the relevant 
code button or use your preset hot key. The button highlights while it is actively marking and, 
(unless a lag time has been specified for the button,) it will need to be clicked again for it to mark the 
end of the Instance.  It will have a red frame if it was the last button closed.

If the button has been customized with a specified lag time, you will see a grey bar fill the button 
until the lag time runs out.

Note : the video must be playing in order for the grey bar to activate. ie. If you are coding with the 
movie paused, and click on a button with a lag function, you will not get the grey bar.
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b. From a movie not linked to a Timeline

Open a new Timeline , File > New > Timeline 
Select the movie file you wish to code/link to the Timeline - Click Open 
Answer “YES” to question “Do you wish to place the movie inside a movie package?”

Proceed per (a) above.

Stop Coding

To stop coding your movie, (halt Code mode,) click on the Edit Button in the Code Window Toolbar. 
This will also stop the movie.

Pause / Restart Coding

To pause the coding (and pause the movie,) of the Timeline and then to restart the coding press the 
Space bar on the keyboard.
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Label Mode *

Label Mode is designed to add or remove labels to and from existing 
instances in a timeline. While label mode is active, code buttons 
cannot be used. It is possible to have a code window purely made up 
of label buttons only. Some events might be coded using code 

buttons only, providing the skeleton of the events that occurred in the movie. A second pass during 
the analysis process, labels can be added while reviewing the instances in a looping mode.

Using Label Mode

1.	 Select a row of instances in the timeline by clicking on the row number or name. This will 
highlight all the instances in the row.

2.	 Set the playhead prior to the first instance for which you want to start labeling.
3.	 Activate Label Mode by clicking on the Label icon in the code window toolbar. 
4.	 Press the TAB key start the process. The playhead will jump to the instance and start playing the 

movie. The playhead will continually loop in the instance.

5.	 Press the label buttons in the body of the code window to add to the instance. To remove a label, 
hold down SHIFT+OPTION+COMMAND and click on the label button.

6.	 Press the TAB again to advance to the next instance. Pressing SHIFT+TAB will return to the 
previous instance.

7.	 To stop Label Mode, change modes in the code window.

We suggest opening the Edit Instance Labels window (COMMAND+E) to make viewing the labels 
contained in an instance easier to view. This will update according to the selected instance with the 
added bonus of being able to easily remove labels.

Once label is active, there are several clever ways to use the feature.

* SportsCode Elite Only
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Click and add labels

Select an instance and click on the label buttons to add labels. Select another instance any where in 
the timeline and repeat the process.

Adding a label to a group of selected instances

Select a group of instances or all instances (COMMAND+A) and click on the label button in the code 
window. This will add the label to all the selected instances, convenient for adding metadata such as 
event name or date to a bunch of instances.

Removing a label from a group of selected instances

Select a group of instances or all instances (COMMAND+A), hold down SHIFT+OPTION+COMMAND 
and click on the label button in the code window. The label will be removed from the instances. 
If there are duplicate labels, press the label button down multiple times while holding down 
SHIFT+OPTION+COMMAND, each click will remove the label from the selected instances.

Report Mode *      

In Report mode, code and label buttons are deactivated and will 
not code data into the timeline. The purpose of Report mode is 
to provide a mechanism to observe output results of the coding 
process. These results are generated by  code outputs as a 
consequence of statistical scripting.

Analysis from the Code Window - Matrix Function

Clicking on this icon will take you to a matrix of the open Timeline or of the front 
Timeline if more than one Timeline is open. If you Shift + Control + Click) on the 
icon you will be offered :

1.	 A matrix consisting of  the codes and labels in the Timeline with the matrix cells 
populated or ...

2.	 A matrix consisting only of the code buttons and label buttons in the Code window.

A full Code window linked to a Timeline could potentially produce a very large matrix.  An 
analyst may quickly construct a simple Code window with a selection of codes and labels 
related to a Timeline, then choose option 2 above to select a matrix consisting only of those 
components in the simplified window.

* SportsCode Elite Only
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Create a New Code Window Using an Existing One 

1.	  Open the code window you want to use as a template.

2.	  �Make the required button name changes for the new code window.

3.	  �Choose File > Save as (COMMAND+SHIFT+S) and give the code window a new name.

Code windows can be moved from computer to computer without any problems just like any other 
type of file. You can share your work and have everyone using the same terminology and coding 
schemes.

Saving Code Windows

Once you have created all your coding buttons, save the code window. You can use this as a 
template for other windows or use it to code any movie. This saves time as you will not have to 
create all the buttons again and you can have as many code windows as you like.

1. Choose File > Save from the main menu bar (COMMAND+S) 
2. Name the code window. 
3. Target where to save the file. 
4. If you have saved the code window to your desktop, it becomes    
an icon. 
5. Double click on the icon to open it.

Print the Code Window

Use the normal system print function to print the code window.
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The Timeline
IMPORTANT : Refer to the Preferences Section on Page 9  of this manual for your preferred 
settings for this function. It is important that your settings are correctly configured if this 
function is to deliver optimum results.

When your timeline and movie are open, the movie is 
generally displayed in the top of the screen and the 
attached timeline below it.

Components of the Timeline
•	 A timeline of your movie represented in hours, minutes, seconds and hundredths of seconds. 

The movie will play from the location of the playhead in this timeline. The playhead is the small 
triangle pointing in a downward direction.

Code Rows that are populated from code buttons (during coding from the 
Code Window) or created manually.   Code Rows are created in the 
chronological order in which they are first pressed down.

The “boxes” in the timeline rows display Instances and where they 
happen within your movie.

A tool bar to conveniently access all the tools for editing and 
presenting your instances.

The Playhead which can be dragged right or left to move through time in the movie
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The Timeline Toolbar

Make Movie 

Makes movie out of selected instances.  Refer to pages 106  
 

Find

Selecting this icon takes you to the Find Window. Refer to page 127

 
Database

Saves an instance or group of instances to a pre-created database.  Refer to page 126

Matrix
Single click to open a Code Matrix window from this Timeline (default setting) or click 
and hold to open a selection of matrices which have been customized and saved for 
this Timeline.  Refer to pages 134

Note

Opens the Edit instance window. Instance notes will also be displayed here. Refer to 
page 162

New Timeline

 Opens a new timeline of selected instances  Refer to page 125

New Row 

Adds a new blank row to the Timeline.  Refer to page121

 
New Merged Row 

Creates a new row from selected instances in the Timeline.  Refer to page 121

Organizer

Opens a Movie organizer window from this Timeline. Refer to page 149 

Sorter

Opens a Sorter window from this Timeline.  Refer to page 153 
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Labels

Takes you to the Labels Tree window.  Refer to page 56

Edit
Highlight an instance in the timeline and click the Edit icon. A movie of the instance will 
open containing the tools to edit the instance in precise detail.

Reports

Exports the selected instances as a .codereport package for viewing with Sportstec 
Player.

Settings

Clicking the Settings button will display the following drop down panel :

Merge Rows plays instance movies in chronological order regardless of the row the instance is in.

Sequential Rows plays instance movies from row A then row B etc.

Selection Order plays instance movies in the order that the instances were selected. Select instances 
by holding Command and clicking the instances in the order required.

When Append slow is ticked, the instance movie you make will play in real speed first followed 
immediately in slow motion, (default speed is 50% real speed.)

By checking the Static text box, each instances associated text descriptors will be displayed in a 
static title before each instance.

By selecting Instance notes, the text track will be displayed at the bottom of the instance movie 
screen. Instance notes and Append Slow cannot be used together.
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By selecting Overlay text, the row name, instance number and labels will be displayed over the 
movie as it plays

The Lines field allows you to specify the number of lines of text displayed at a time in the instance 
movie. 

When you right click (Control + Click) on an instance in the Timeline, the Labels Tree for that Timeline 
will be displayed in a drop down panel. The labels and label groups which are available will be 
displayed. The groups will be indicated by an arrow marker, hover the cursor over the group name to 
display the labels in that group.

Create a New Timeline

Timelines are always created during capture. However, there are times when you will want to link a 
new timeline to the movie so you can code a different aspect, or multiple users are coding the same 
movie and you want to keep the data separated.

1.	 Choose File > New > Timeline from the main menu bar.
2.	 Select the movie you wish to link the new timeline to.
3.	 Save the new timeline by pressing COMMAND+S or choose File > Save from the main menu bar.
4.	 OPen a Code window to code the movie.

You can now press the Code mode button  in the code window toolbar to code the movie. 
Alternatively you can create and modify instances manually.
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Movie Packaging

We recommend always packaging movies. A package is a folder with files inside, Mac OS X simply 
recognizes it as a single file. This makes it very convenient to move around and not lose any 
necessary files.

A definite trend is users are acquiring video files over the internet. While this is a great convenience, 
the quality and creation process is largely unknown. What you download is what you get, in 
most situations there is no knowledge on how the video was created and what tools were used 
to compress, etc. Some of these movies will have different movie data containers that may be 
corrupted by Quicktime when there are attempts to write data back into the file. This is why it is 
best to always package the movies. The packaging process places the source movie in a movie data 
folder, then creates a reference movie that points to the source movie. Any changes to aspect ratio 
or text track information of the movie is saved in the reference movie and we never have to touch 
the actual source movie.

If a new timeline is linked to a free standing movie, a prompt will appear asking whether or not you 
wish to place the movie inside a movie package. We highly recommend answering yes to this 
question. The process is very quick, it simply wraps up the movie and timeline inside a package. It 
does not copy any data like the Save as standalone package does.

Place front movie and timeline inside a movie package

In previous versions of SportsCode, it was common practice to have a free standing movie and 
timeline file. If you have this situation, package them. Open the timeline and choose File > Place 
front movie and timeline inside a movie package. It will package them up together.

Note: Timeline files can still be free standing as long as the movie is packaged. You can have as many timelines pointing 
at a single package as you wish.

Timeline Backup Folder

To replace an existing timeline with a backup timeline. Open the package, navigate into the BACKUP 
folder, then drag and drop the backup timeline next to the existing one in the folder above and 
delete the existing timeline. When you double click on the package, the backup timeline will open as 
the default timeline. The file name can be changed if desired.
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The Timeline Timecode

This function is to help integrate specific time based imports, (such as GPSports and NHL EVS.) into a 
SportsCode Timeline.

There is a preference in the Capture Preferences, “Use Timecode produced from capturing device”. 
When this is ticked, a Timecode track will be created in the movie from the data that the device is 
outputting. Remember to set the correct time on the camera or device that is being used to capture 
from. The Timeline timecode can be altered by right clicking (Control + Click) on the Timeline 
timecode counter situated above the row column in the Timeline window. Right clicking on the 
counter will reveal a Pop up menu, these are the options:

•	 Use movie time, this option displays standard movie time hh:mm:ss:hshs. The “hs” is 
hundredths of seconds.

•	 Use Timecode, this option displays the timecode in terms of 24 hour time as in the time of 
day. The numbers will be displayed in blue. This is useful for setting the time of day of an event. 
NOTE: Changing the counter to display this might show the time at which the capture was done. 
This can be read from the camera or capture hardware that is connected.  Be sure to set the 
camera time, so the correct time is captured. Breaking the timecode into segments along the 
timeline is not possible. The timecode will roll over to 00:00:00.00 when the playhead is dragged 
past 23:59:59.99. This means the playhead was dragged past midnight.

•	 Set movie time to zero, this option resets the movie time to 00:00:00.00 according to the 
location of the playhead. The time will be displayed in red when the numbers are “negative” or 
the playhead is set before the new zero point.

•	 Set TimeCode, this option reveals a menu from the timeline title bar. The time can be set here

•	 Delete TimeCode track, this option removes the Timecode track. It can be readded by using the 
Set TimeCode function, but the original one that may have been done during capture cannot be 
brought back.

•	 Use frames for TimeCode, this option will display the hundredths of seconds in frames.

•	 Use seconds for TimeCode, this option will display the Timecode to the hundredths of seconds.
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Flagging

IMPORTANT : Refer to the Preferences Section on Page 11 of this manual for your preferred 
settings for this function. It is important that your settings are correctly configured if this 
function is to deliver optimum results.

Instance movies created from Timelines, Movie Organizers and Sorter windows may be labeled with 
customized Flag labels using global Hotkeys.  The purpose of this function is to make the process 
of identifying specific  Instances faster and more convenient. Instances can be quickly categorized, 
sorted or searched for, then organized for rapid recall and presentation.

User defined Flag names, colours and Hotkeys are set in the Flagging Preferences.  When the “Notes” 
checkbox is selected, a Note window will open to allow you to insert a note into the flagged instance. 
When the “Organizer” or “Sorter” checkbox is selected and the flag hotkey is pressed, the instance 
will be inserted into that feature. 

When the checkbox in the preferences called “Organizer” and/or “Sorter”is selected and the flag 
hotkey is pressed, the instance will be:
•	 Inserted at the bottom of frontmost movie organizer and/or Sorter window, similar to pressing 

OPTION+COMMAND+V for the Movie Organiser when working with timeline instances, or 
pressing SHIFT+COMMAND+V for the Sorter window when working with timeline instances.

•	 If a movie organizer and/or Sorter window is not open, a new window must be created.
•	 If the instance movie being flagged was generated from a movie organizer and/or Sorter, 

then a new window will be created on top of the current one to help avoid inserting into its 
originator.

•	 The movie organizer and/or Sorter row name will be the row name from its originator.
•	 All labels, notes and flags will be carried across to the organizer and/or Sorter including the flag 

that engaged the insertion process.

If the flag is removed, the instance in the movie organizer and/or Sorter is not removed.

A flag label can only exist in an instance once, although an instance may contain more than 1 flag 
label. When a flag is added, the flag name will appear above the flag image with it’s colour filling the 
flag image. Other flags in the instance will appear below the flag image in a smaller font within the 
bounds of the notification.
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When a flag is removed the flag image in the middle of the notification has an X through it. When 
the <clear> flag is used, the text should read “All flags cleared” and no color will fill the flag image 
with the X.

This feature can be used while presenting movies in full screen and does not require the opening of 
a Code window.

1.	 Open the SportsCode Preferences and click on the Flagging icon.
2.	 Tick the Enable Flagging tick box to enable access to the feature.
3.	 Press the plus (+) button near the bottom of the panel to add a new flag.
4.	 Click on the Name cell to input a name.
5.	 Click on the Color cell to set the color.
6.	 Click on the Hotkey cell, then press a key down to set a Hotkey.
7.	 Check the boxes to select the feature you want the flagging to apply to.
	 Repeat this process to add as many flags as required.
1.	 Open a Timeline, Movie Organizer, or Sorter window.
2.	 Make a movie from some selected instances then press the Flag hotkey.     The flag will be 

inserted into the Instance as a label with a tag <flag> in front of the name. Hover over the 
Instance in the Timeline to verify insertion or use the Edit Labels window. If a Sorter was used to 
make the movie, a new row will be created with the flag name inserted in the cell along with the 
cell background changed to the color chosen in the Preferences.

3.	 A Flag may be searched for using the Find function or the Matrix or it can be “sorted by” in the 
sorter window.

4.	 There can be more than one Flag per Instance.
5.	 To clear Flags, create a Flag with the name <clear>. Press this Hotkey and all Flags in the Instance 

will be removed.
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The Labels Tree Window

The Labels Tree window controls the pop up menu that is displayed when an instance is right clicked. 
All the labels found in the instances in the timeline are shown in cells of this spreadsheet style 
window. The term “Labels Tree” is derived from the concept that groupings of labels may resemble 
the branch of a tree because labels may be grouped into categories or branches.

The pop up menu will display in the order of the rows in the Labels Tree window. Labels can be 
sorted alphabetically in ascending or descending order. The labels tree window can configure 
the pop up menu layout to extend horizontally, so labels can be structured in logical and easy to 
navigate branches. A labels tree can be saved as a file and used similarly to a code window. 

Many labels trees can be opened at one time. It is the front most label tree window that will appear 
as the pop up menu when an instance is right clicked on. This is useful when coding entirely 
different aspects of an event and can help avoid long lists of labels that make it difficult and time 
consuming to find a specific label.

A default labels tree window is created for the timeline from using a code window in code mode. If 
multiple code windows are used, all the labels from each window will be added to the default labels 
tree in the timeline.

Accessing and Creating a Labels Tree

There are many ways to access a label tree. A Labels tree can be accessed from the Timeline, 
Sorter window and Movie Organiser window. The most common way is to press the labels 
button in the timeline window. This will open a labels tree with the labels that were used for 

coding the timeline. Once opened this window can be 
edited and the changes will be saved in the timeline. The 
window can also be saved like a code window and used to 
label other timelines and the new label tree data will be 
saved in those timelines. Opening an existing labels tree is a 
good place to start when building separate label trees for 
various coding work flows.

Labels trees can be created from scratch too. Select File > 
New > Label Tree. Then add a label in a cell of each row in 
the first column of the window. When this window is the 
front most labels tree window, it will be used to create the 
pop up menu that appears when an instance is right clicked. 
Save this window by pressing COMMAND+S.

In SportsCode Elite, a labels tree can be created by right clicking on the Label mode button in 
a code window. Select export labels from the pop up menu and all the labels will be exported 
into a new label tree. The label button color will be exported too making it easier to find label 
sections in the window.
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Adding a New Label to The Labels Tree 
Press the new row button in the tool bar of the label tree window. This will create a new row under 
the currently selected row or at the bottom of the window if no cells are selected.

Deleting a Label in the Labels Tree
Right click on the row number and select delete row from the pop up menu.

Changing a Label
Click in the cell and edit the text.

Creating Branches for the Labels Tree Popup Menu

Adding columns to the labels tree will create branches for the popup menu that appears when you 
right click on an instance to edit the labels in the instance. Creating branches spreads the lists of 
labels out horizontally and groups them, so labels can be more easily navigated and found.

The root of the menu is the first column in the labels tree 
window. The second column creates a branch from the root 
and subsequent columns create sub-branches of the 
branches. The labels tree can have as many columns 
(branches) as is required. A branch ends when the last column 
and rows of that column end.

Here is how to create a simple one branch level menu.

1.	 Create a new labels tree window. File > New > Labels tree.�

2.	 Add 1 column and 9 rows by pressing the add rows and add columns button 
in the tool bar.

3.	 Add the name for the first branch in cell (1,1). Then, add labels in cells (2,1), 
(2,2), and (2,3). This creates the first branch with 3 labels as options in the 
popup menu.

4.	 Add the name for the second branch in cell (1,4). Adding text into this cell 
ends the previous branch and starts a new one. Then, add labels in the cells 
(2,4), (2,5), and (2,6). This creates the second branch with 3 labels as options in 
the popup menu.

5.	 Add the name for the third branch in cell (1,7). Then, add labels in the cells (2,7), (2,8), and (2,9). 
Adding text into this cell ends the previous branch and starts a new one. This creates the third 
branch with 3 labels as options in the popup menu.

6.	 Save the labels tree, so it can be re-opened and used again to label instances in a timeline.

7.	 Test the labels tree by opening a timeline and right clicking on an instance. If the labels tree is 
the top most label tree window, the popup menu will appear as it has been structured.
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Editing Labels Using the Labels Tree Pop Up Menu

The labels tree is a pop up menu system used to add or remove labels for an instance in the timeline, 
movie organizer, and the sorter window. The labels tree pop up menu is auto generated from the 
labels in a code window or can be created manually using the Labels Tree window. When code mode 
is activated in the code window, the labels tree pop up menu is saved into the timeline and can be 
accessed by right clicking on an instance.

Strip Instance Contents

Sometimes it is necessary to remove any labels and instance notes from single or multiple instances 
in a timeline.

1. Select the instances in the timeline. 
2. Choose Edit > Strip instance contents

Remove duplicate labels from Selected Instances

If data has been imported using one of the many imports, it can often contain duplicate labels that 
are not necessary. To clean up the duplicate labels, select the instances or all isntances and choose 
Edit > Remove duplicate labels from selected instances. Any duplicates will be stripped from the 
instances. This feature is helpful when cleaning up coded instances too, especially if label counting is 
important in the matrix or statistical window.



Part 2 - SportsCode Code

59

Importing Files

SportsCode can import a vast array of textual data. Most of the imports are sport specific and are 
very straight forward. However, if there is a problem please let Sportstec know as it is likely the third 
party data source has changed its data structure.

Imports can be accessed from the Main Menu > File > Import >  
All compatible third party imports are listed in the Other tab.

An important item to note about importing is movie and data synchronization, it is very likely that 
adjustments will have to made on the instances after the import. We recommend getting familiar 
with the Instance Adjustments and nudging features in the Edit menu.

Each import has a specific format and data structure. Only the Edit List and SportsCode XML will be 
explained in great detail as we export both of these types of files. These are also commonly used 
in third party solutions to feed data into SportsCode. There are quite a few users generating or 
converting data from external sources beyond SportsCode.

Edit List

This import is mostly used in conjunction with a spreadsheet editor like Excel. Try exporting an edit 
list from SportsCode and look at its structure.

Note that Excel might insert hidden characters, so use the export as tab delimited file if creating an 
edit list in excel. 

The file to be imported must be tab delimited file with the following columns in order and included 
as the first line:

start time 
end time 
category 
Nth instance 
#descriptors 
descriptors...

•	 The start time and end time must be in 00:00:00:00 format. These columns set the start 
and end time for the instance.

•	 The category column represents the timeline row.
•	 Nth instance is the number of the instance in the row.
•	 # descriptors indicates how labels are in the instance.
•	 descriptors... are the label names that are in the instances. The amount should match the # 

descriptors and each label should be separated by a tab.
•	 Each instance must be on a separate line. 
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START TIME END TIME CATEGORY NTH INSTANCE # DESCRIPTORS DESCRIPTORS...

00:00:00:10 00:00:01:60 single blows 1 2 straight right jab

00:00:01:80 00:00:03:30 single blows 2 1 straight right

00:00:03:50 00:00:05:00 single blows 3 1 left hook

00:00:05:68 00:00:07:18 single blows 4 1 left hook

00:00:07:38 00:00:08:88 single blows 5 1 left hook

00:00:09:08 00:00:10:58 single blows 6 1 left hook

00:00:10:78 00:00:12:28 single blows 7 1 left hook

00:00:12:48 00:00:13:98 single blows Foot view 1 1 straight right

00:00:14:18 00:00:15:68 single blows Foot view 2 1 straight right

00:00:15:88 00:00:17:38 single blows Foot view 3 1 right cross

To use this import, open a timeline and choose File > Import > Edit list... The instances will be 
imported into the front-most timeline in your working window.

XML Edit List

Similar to the traditional Excel type Edit list file, an XML edit list file can be employed. The XML file 
format offers a bi-directional method to push and pull data though SportsCode. We recommend 
using the XML import over the Edit List because it is offers more options and is easily extended. Plus, 
this is the only format that SportsCode can import live during capture.  When using the SportsCode 
capture window a time code track based from the computer’s clock will be added to the movie.

The XML file can handle labels, label groups, instance notes, row colors, row sorting and time 
synchronisation where the traditional edit list does not offer this.

Note! Our XML file breaks strict XML standards, however the format follows the nested hierarchical 
nature (1 root element, elements and sub-elements) of standard XML structure. But, does not 
include special character handling in the element’s contents. Some characters such ampersand 
should be represented as ampersand if used as content in code, label, label group, and instance note 
elements. Do not use the special XML character handling routines. We admit to a loose interruption 
to the standard and apologise for any inconveniences. It is likely in the future we will tighten this up 
like we have done in the Matrix web exports.

Here is a short example of an XML edit list to get you started. We have added indenting and styling 
to better display the nesting of the tags and make it more readable. Often XML files will not have this 
nice indentation making them a little more intimidating. Just know this is not a necessity.

You can try copying and pasting this example into TextEdit or some other text editor like Text 
Wrangler, then changing some of the content between the elements and importing it into 
SportsCode. For those not familiar with XML, remember, all open tags must also be closed,                  
i.e. </TAGNAME>. If the file is not formatted perfectly in this way, it will not import.
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<file> 
	 <SESSION_INFO> 
		  <start_time>2010-03-10 21:21:39.63 +1100</start_time> 
	 </SESSION_INFO> 
	 <SORT_INFO> 
		  <sort_type>sort order</sort_type> 
	 </SORT_INFO> 
	 <ALL_INSTANCES> 
		  <instance> 
			   <ID>1</ID> 
			   <start>4.9984074982</start> 
			   <end>10.0046128241</end> 
			   <code>Alexis Proctor</code> 
			   <label> 
				    <text>First Step</text> 
			   </label> 
			   label> 
				    <group>Speed</group> 
				    <text>Fast</text> 
			   </label> 
			   <free_text>This is a great example of a fast first step.</free_text> 
		  </instance> 
		  <instance> 
			   <ID>2</ID> 
			   <start>29.0119131044</start> 
			   <end>59.2852137351</end> 
			   <code>Alexis Proctor</code> 
			   <label> 
				    <text>First Step</text> 
			   </label> 
			   <label> 
				    <group>Speed</group> 
				    <text>Fast</text> 
			   </label> 
			   <free_text>This is another great example of a fast first step.</free_text> 
		  </instance> 
	 </ALL_INSTANCES> 
	 <ROWS> 
		  <row> 
			   <sort_order>1</sort_order> 
				    <code>Alexis Proctor</code> 
			   <R>65535</R> 
			   <G>4139</G> 
			   <B>4139</B> 
		  </row> 
	 </ROWS> 
</file>
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Reading down the above example from top to bottom, below is a description for each element 
found in the file. For interest of saving space and paper, not all descriptions will include excerpts 
from this example. Please refer to the example above for elements that embody many sub-elements.

<file> 
The XML must start with <file> and end with </file>. This is the root element. This sets the block of 
data for SportsCode to read.

<SESSION_INFO> 
This is time stamp that indicates when the coding session commenced. The time stamp is used to 
calculate the offset between a SportsCode capture session and the incoming XML data session start 
time. This offset allows for seamless time synchronisation between the two separate systems. System 
time should be synchronised on any machines in the workflow. All instances must relate back to this 
time.

There are two supported date strings: 
	 .   yyyy-MM-dd HH:mm:ss.SS Z     This is the preferred format. 
	 .   yyyy-MM-dd HH:mm:ss Z

Example: 
<SESSION_INFO> 
<start_time>2010-03-10 21:21:39.63 +1100</start_time> 
</SESSION_INFO

<SORT_INFO> 
Sorting order can be included in order for the timeline rows to be automatically sorted when 
they are imported. This is rather important for a better end user experience. So it should be highly 
considered especially when importing live XML data during captures.

The <SORT_INFO> element has a sub-element called <sort_type>. This element tells the timeline 
how it should sort the rows.

The options for sorting are:

•	 <sort_type>sort order</sort_type> - sort order indicates that a specific order must be followed 
during the import. The import routine will look in the <row> element to find a value to assign a 
priority for the sort.

•	 <sort_order>1<sort_order> - <sort_order> is set in the <row> element. Its contents should 
be represented by an integer or float: 1,2,3 or 1.1, 1.2, 1.3. The smaller the number, the higher 
priority the sort will be. The highest priority will be the first (top) row in the timeline. We 
recommend using integers, but floats can be handy if you need to insert something at a later 
date. 

•	 <sort_type>color</sort_type> - color sorts the rows automatically by color using SportsCode’s 
standard color sorting method.
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•	 <sort_type>name</sort_type> - name sorts the rows by name alphabetically

•	 <sort_type>color then name</sort_type> - color then name sorts the rows by color then name 
alphabetically

•	 <sort_type>instance count</sort_type> - instance count sorts the rows according to the 
number of instances, greatest being first row.

Example: 
<SORT_INFO> 
<sort_type>sort order</sort_type> 
</SORT_INFO>

The sorting methods are similar to those found under the Rows menu in the Main menu. Try 
opening an existing timeline and use the various sorting options to find out what will work best. We 
recommend experimenting using color and name. Color is a really good way to achieve nicely sorted 
and presentable timelines.

<ALL_INSTANCES>

This declares the parent element for all the <instance> sub-elements. This is where the real work 
begins, this element contains all the instances that appear in your timeline. See this in the short 
example at the beginning of this section of the manual. It follows the <SORT_INFO> element. 

<instance>

The <instance> element represents a single instance in the timeline and all the sub-elements 
contained within will describe the instance to be represented in the timeline until closed with </
instance>. It is a sub-element of <ALL_INSTANCES>.

Example: 
<instance> 
	 <ID>1</ID> 
	 <start>4.9984074982</start> 
	 <end>10.0046128241</end> 
	 <code>Alexis Proctor</code> 
	 <label> 
		  <text>First Step</text> 
	 </label> 
	 <label> 
		  <group>Speed</group> 
			   <text>Fast</text> 
	 </label> 
	 <free_text>This is a great example of a fast first step.</free_text> 
</instance>
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<ID> 
<ID>  is a unique identifier for the instance. Each instance must have a unique identifier, no two can 
be the same and there can only be one of these elements per <instance> element. This is a sub-
element of <instance> and its content must be represented as an integer.

Example: 
<ID>1</ID>

<start> 
This sets the start time for the instance in the timeline. It’s contents represent seconds. The contents 
can be an integer or float with precision up to 10 decimal places. This is a sub-element of <instance> 
and there can only be one of these elements per <instance> element.

Example: 
<start>4.9984074982</start>

<start> 
Like <start>, <end> sets the end time for the instance in the timeline. It’s contents represent seconds. 
The contents can be an integer or float with precision up to 10 decimal places. This is a sub-element 
of <instance>  and there can only be one of these elements per <instance> element.

<code> 
The contents of the <code> element sets the row name in the timeline where the instance will 
be created. This is a sub-element of <instance>  and there can only be one of these elements per 
<instance> element.

Example: 
<code>Alexis Proctor</code>

The next part describes the labels that will be contained in the instance. In the example, the first 
<label> element does not have a <group> sub-element , the second does. To learn more about label 
groups, see this section of the manual at page 35. We recommend using label grouping as it has 
great benefits in the Matrix and without them the Sorter loses most of sorting power.

<label> 
This element indicates that a label is contained in the instance. This is a sub-element of <instance>  
and there can be as many <label> elements as required.

<text> 
This is a sub-element of <label>. Its content is the label that will appear in the contents of the 
instance in the timeline. There can be only one <text> sub-element per <label> element. See page 
31 of this manual for more description of a label and how and where it is used in SportsCode.

Example: 
<label> 
<text>First Step</text> 
</label>
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Here is the second example with the <group> sub-element used within a <label> element.

<label> 
<group>Speed</group> 
<text>Fast</text> 
</label>

<group> 
The <group> sub-element indicates that the label described in its sibling <text> sub-element 
belongs to its contents (label group). There can be only one <group> sub-element per <instance> 
element.

<free_text> 
The <free_text> sub-element’s contents are the instances notes contained in an instance in the 
timeline. There can be only one <free_text> sub-element per <instance> element. To learn more 
about instance notes, see page 162 in this manual.

Example: 
<free_text>This is a great example of a fast first step.</free_text>

The last section of the example describes each rows color and sorting in the timeline.

<ROWS>

The <ROWS> element starts the section that tells SportsCode how to represent the code rows in the 
timeline. It is an element of the root element <file>. It contains sub-elements that indicate color for 
specific <code> sub-elements and provides sorting order information when the <sort_order> sub-
element is used.

Example: 
<ROWS> 
	 <row> 
		  <sort_order>1</sort_order> 
		  <code>Alexis Proctor</code> 
		  <R>65535</R> 
		  <G>4139</G> 
		  <B>4139</B> 
	 </row> 
</ROWS>

<row> 
The <row> sub-element represents information about a specific row’s representation in the timeline. 
There can as many <row> sub-elements as required.

<sort_order> 
As described above, the <sort_order> sub-element sets the sort priority when the <sort_type> 
sub-element contents of the <SORT_INFO> element are set to “sort order”. There can be only one 
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<sort_order> sub-element per <row> sub_element and it is a sub-element of <row>.

<code> 
The <code> sub-element’s contents tells the timeline which row it’s data is referring to. This where 
the relationship between the <instance> sub-elements and the <row> sub-elements is made. There 
can be only one <code> sub-element per <row> sub_element and it is a sub-element of <row>.

<R> 
The <R> sub-element’s contents represent the color red in 16 bit RGB. It’s contents must be an 
integer from 0 to 65535. It is a sub-element of <row> and there can only be one per <row> sub-
element.

<G> 
The <G> sub-element’s contents represent the color green in 16 bit RGB. It’s contents must be an 
integer from 0 to 65535. It is a sub-element of <row> and there can only be one per <row> sub-
element.

<B> 
The <B> sub-element’s contents represent the color blue in 16 bit RGB. It’s contents must be an 
integer from 0 to 65535. It is a sub-element of <row> and there can only be one per <row> sub-
element.

A helpful tool for finding color values on your Mac, is to use DigitalColor Meter. It can be found in the 
/Applications/Utilities folder. Set it to display RGB As Actual Value, 16-bit.

Generic CSV

The generic csv import will import most comma separated value files that meet the following 
conditions:

1.	 The first line (row) in the file is the column header / value 
description. eg. Player, Team, Mins, Secs, Frames, Action, 
Result

2.	 There are columns/values for Mins,Secs,Frames and each 
line(row) has this data. This time should be moment at which 
the instance precisely occurred, started or ended. The length 
will be determined by the lead and lag times set when 
importing. Without this data, the instance will not be created.

3.	 Import options:
•	 A global lead and lag tie can be set for all instances.
•	 Check boxes are available to choose whether the data is 
imported.
•	 The name can be changed and this will be reflected in 
the timeline as a code row name or label name.
•	 Label or code type can be selected.
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Choose File > Import > Generic CSV file, then select the file to import. A window will appear 
where each column/value can be be configured as to how it will be imported into the timeline. By 
unchecking the tick box in the import column, the row will not be imported. The column heading 
name can be changed by double clicking in this cell of the column heading column. If the name is 
changed and the row is code, then this will be the timeline row name. If the row is desginated a label, 
then this will be the label group. Each row can be imported as label or code row, click on Type cell 
in the column and set it to Label or Code. There must be at least one code selected in all the rows. 
When multiple items are code, the rows setup as labels will import into all instances for all code rows.

Champion Data AFL Basic

The Champion Data Basic and Enhanced import imports an AFL match data file supplied by the 
stats provider Champion Data. This import creates instances with labels for player involvements, 
stoppages and possessions. It is designed to be used with 4 complete quarters of AFL video. The 
entire match must be in the video in its entirety. If there are missing sections of the video, the 
instances will not match up to the footage. We suggest breaking the match up into 4 separate 
movies, then linking the resulting timelines to each video, combining the 4 timelines in order, then 
save as a standalone package.

The steps for importing the basic version are:�
1.	 Choose File > Import > Champion Data basic AFL..., 

navigate to the Champion data file.
2.	 An import window will appear where you can choose 

the quarter and length of the instances that will be 
created.

3.	 A timeline will be created to link the corresponding 
movie to.

4.	 Repeat the process for all quarters.

For better statistical representation in the matrix unselect 
Merge overlapping instances, this will create instances 
that are counted in the matrix accurately to a stat sheet. 
By default, this selected because it creates instances that 
are longer and easier to view passages of play.

To import the Enchanced version, Choose File > Import > Champion Data enhanced AFL.... Navigate 
to the XML file provided by Champion Data, select and click the open button. Four timelines will 
appear after the import is completed.

The enhanced import reads a plist that can be edited to change the way in which the data is 
interpreted and imported into the timeline. Contact Sportstec support staff to make changes to this 
file.



Part 2 - SportsCode Code

68

Champion Data AFL Enhanced *

This import is similar to the Champion Data AFL Basic above, however it uses a more detailed 
XML file that includes derived statistics. It has been extended to include label groups and rows of 
instances for chains of play from stoppages, kick ins and turnovers to goal, behind or no score. Also 
included are labels for attendance at centre bounces, opponent player labels for certain actions and 
field zone labels for event location.

•	 This import requires the user to subscribe their data service.
•	 The import consists of one file per match, the naming convention of the files is:
•	 sportscode-{match round #}-{home team}-{away team}-enhanced.xml

To use:

•	 Choose File > Import > Champion Data AFL enhanced.
•	 Select the enhanced.xml file
•	 4 timelines will appear, one for each quarter, link these timelines to corresponding movies.
•	 Use CTRL+COMMAND+Z to align the instances to the movie.

The import currently supports custom label groups, renaming of any code or label names, row colors 
according to teams and derived chains of play.

Champion Data AFL Custom

Uses a custom plist to importChampion Data XML files.

Champion Data Netball*

This import is similar to the Champion Data AFL import and requires the users of this import to 
subscribe their data service.

1.	 This import creates the following rows in the timeline:
2.	 Player involvements coded in individual rows
3.	 Centre pass receives by team with player inserted as label
4.	 Circle entries by team with player inserted as label
5.	 Goals and goal assists by team with player inserted as label
6.	 Shot attempts by team with player inserted as label
7.	 Turnovers by team with player inserted as label
8.	 The import consists of one file per match, the naming convention of the files is:
•	 	 - civ-{match round #}-{home team}-{away team}.xml
9.	 To use:
	 - Choose File > Import > Champion Data Netball
	 - Select the civ.xml file
	 - 4 timelines will appear, one for each quarter, link these timelines to corresponding 		
                        movies.
	 - Use CTRL+COMMAND+Z to align the instances to the movie.
10.	 The import currently supports custom label groups, renaming of any code or label names, row 

colors according to teams and team statistical events.
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Opta Football

The Opta Football import requires the user to subscribe their data services.
The import consists of two files per match, the naming convention of the files is:
•	 F24-{competition_id}-{season_id}-{match_id}-eventdetails.xml
•	 srml-{competition_id}-{season_id}-squads.xml
Upon importing, these two files must be in the same folder and the {competition_id} and {season_
id} must match, otherwise the import will not work.
To use:
•	 Choose File > Import > Opta Football
•	 Select the event details.xml file to be imported.
•	 Two timelines will appear with the imported data, link these two timelines to the 

corresponding movies of each half. Creating two timelines is done to help aligning the 
instances to the movie and makes using multiple angles easier. If only one movie for the whole 
match is available and link each timeline to this movie. Using the second half timeline, set the 
playhead to the beginning of the timeline and hold down CTRL+COMMAND+Z, then click 
and drag the playhead down the movie until the instances match up to the second half of the 
movie. Once the instances are aligned, save the file, select all instances in both timelines, first 
and second half and choose File > Merge timeline windows. A full timeline will be created and 
can be saved.

•	 The import can be changed to import a single timeline by editing the Opta_import.plist 
located inside the application package. Upon user feedback this can be changed or individual 
users can change this themselves.

Resulting timelines will have:
•	 Individual player rows with grouped labels describing the type of involvements.
•	 Team 
The import currently supports custom label groups, renaming of any code or label names, and row 
colors according to teams.
Multiple languages are supported if the proper XMLs are supplied.

For more information on the Opta file specifications, contact Opta.

Opta Rugby

The Opta Rugby import requires the user to subscribe to their data services. Choose File > Import 
> Opta Rugby... then select the XML file provided by Opta. The import will ask whether you wish to 
have two timelines or one single timeline. The two timelines option will create a timeline for the 
two halves of the match, the single timeline option will create one timeline for the entire match 
including half time.

If you are stacking timelines and capturing footage only during match play, then choosing two 
timelines is a great way of stacking and then combining the game for optimal file sizes.

* SportsCode Elite Only
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NBA Stats Data*

This import uses an IDS data file supplied by the scoring system in the NBA. It is rarely used any more 
as their are better alternatives now available.

The key to this import is to create a 48 minute video for the game. This means editing the video 
down to only when the official game clock is running. The time stamps that used to create the 
instances are those found in the file marked by time on the game clock. The import then does the 
calculations to adjust the game to the video time.

There are a number of imports that rely on this, so it can be tedious editing the video and matching 
up the instances. It takes a little practice to learn where to lose and make up time in the editing of 
the file, so the data matches the video. Once this procedure is mastered, the data that comes from 
the import is extremely powerful.

NBA Entertainment*

NBA Entertainment imports an XML file supplied specifically by the NBA. The movies that have to 
be used for this import to work correctly must be downloaded from the NBA. All the instances are 
originally coded using these movies, so if another movie is used the instances will not be accurate. 
This import creates rows for team possession, player stats and player minutes for each team in the 
file.

1.	 Download XML and corresponding movie files from NBA Entertainment web site.
2.	 Choose File > Import > NBA entertainment
3.	 A new timeline will be created with the rows and instances for each team and players.
4.	 Choose File > Link movie to timeline window
5.	 Select the movie that was downloaded from the NBA for this data.

SportVU Import

SportVU push a set of XML files, generated from data collected by their SportVU product, to our web 
services. The data is Username and Password protected.

You will find the import by choosing File > Import > SportVU… in the main menu. Once logged in, 
you will be presented with all the games available. Double clicking on a game card will generate a 
timeline that can be linked to video.

The game card includes scores by quarter and final score. Overtime period scores are displayed 
also, however if there are multiple overtime periods in a game, the scores for these periods will be 
summed in this column.

Games are searchable by date and / or teams in a token like fashion. Click on the spy glass in the 
search box to see some of the search options.
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By dates:

The date formatting uses the System Preference settings for your operating system.

31/3/2013

- Will retrieve all games played on March 31st 2013

1/3/2013 to 31/3/2013

- Will retrieve all games available between March 1st and March 31st 2013.

Today

- Will retrieve all games available on today’s date.

Last Week

- Will retrieve all games available in the last week.

Last Month

- Will retrieve all games available in the last month.

By teams:

Teams can be searched by their city name, city short name and team name. 2 teams can be inputted 
into the search to find games they played each other in.

BOS

- Will retrieve all games available for the Boston Celtics

Boston

- Will retrieve all games available for the Boston Celtics

Celtics

- Will retrieve all games available for the Boston Celtics

BOS LAL

- Will retrieve all games available for the Boston Celtics against the Los Angeles Lakers

Celtics Lakers

- Will retrieve all games available for the Boston Celtics against the Los Angeles Lakers

By teams and dates:

Teams and dates can be combined to find specific games, ranges are accepted.

* SportsCode Elite Only
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BOS LAL 7/2/2013

- Will retrieve all games available for the Boston Celtics against the Los Angeles Lakers on February 
7th 2013

SAS GSW 16/5/2013 to 10/5/2013

- Will retrieve all games available for the San Antonio Spurs against the Golden State Warriors 
between May 10 and May 16, 2013.

Sporting Pulse

This feature imports XML data from Sporting Pulse systems.

NHL EVS*

The NHL EVS import imports an XML file 
supplied specifically by the NHL. 10 events in 
the file will be imported where the lead and 
lag time can be set for the instance lengths. 
Plus, the player shifts are imported based on 
those that played in the game. This import 
generates instances for both teams found in the 
file. The key to this import is that it uses time 
of day, so the timeline must match the times 
found in the file. This is similar to the GPSports 
import’s reliance on the timeline timecode. Use 
the timeline timecode procedures to alter the 
timeline timecode.

Website Imports

There are five imports that use play by play data posted on websites to generate data in a timeline. 
Like the NBA Stats data import these imports rely on the official game clock to calculate where the 
instances should be created in the movie. So, creating a video file that matches the length of the 
official game time is critical. It is often difficult to tell when the official game is running or stopped, 
so practice is necessary to master creating an edited video file that will match the game clock events 
in the play by play.
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a) StatCrew Web Stats

1.	 This import is designed to be used with the StatCrew play by play report generated by the 
StatCrew scoring software. This is a very common game stat package in the United States.

2.	 Create a row of instances that mark exactly when the game clock is running. Name the row 
something that indicates what is, i.e. 40 MIN. When a movie is made for the row, it should be 
precisely 40 minutes long, 20 minutes per half.

3.	 Open a browser and navigate to a StatCrew play by play on a website. The raw data file can also 
be used if is accessible. In the United States, often the Sports Information Director can get this 
file.

4.	 Select all the play by play text beginning from the first tip to end of the game.
5.	 Press COMMAND+C to copy the text.
6.	 Select the row in the timeline with the 40 minutes of instances, 40 MIN.
7.	 Choose File > Import > Paste StatCrew web stats...

b) ESPN web stats

The ESPN website stats import works exactly the same as the StatCrew import. The only difference 
is the play by play information must be copied from the ESPN college basketball website where the 
data structure is slightly different from the StatCrew import. The steps to import and results of the 
import are the nearly the same.

Amisco Data

Amisco supplies a data file in their stats package that can be imported into SportsCode. To import 
this data follow these steps.�

8.	 Open a match timeline with movie that corresponds with 
the data file to be imported.

9.	 Open the matching Amisco data file and select all by 
pressing COMMAND+A.

10.	 Press COMMAND+C to copy the data to the clipboard.
11.	 Choose File > Import > Paste Amisco data...
12.	 Set the import options according to what data is required 

to import and set the lead and lag time for the length the 
instances.

Tab Delimited Data into selected instances

There are occasions where data does not contain time stamp 
information. By creating a tab delimited file from the data 
and coding some corresponding instances, the data can be imported as labels into the coded or 
specifically selected instances. Each line will be imported into each instance respectively.

Here is a brief example on how this might be done.

1.	 Create a tab delimited file that looks like this. Remember that each label must have a tab in 
between each other. And each line must end in a carriage return, not a line feed.
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Label 1	 Label 2	 Label 3 
Label 3	 Label 4	 Label 1 
Label 2	 Label 1	 Label 6

2.	 Code a timeline row with 3 instances.

3.	 Select the instances in the timeline.
4.	 Choose File > Import > Tab delimited data into selected instances...
5.	 Each line of the tab delimited file will be imported as labels in the corresponding instances.

Line 1 > Instance 1 
Line 2 > Instance 2 
Line 3 > Instance 3

GPSports Data
The GPSports import is a time based import using the time 
of day as timecode base. The timeline and xml produced 
by GPSports must be in synch in order for the instances to 
match up. Use the timeline timecode procedures to alter 
the timeline timecode.

1.	 Export an XML file from GPSports system.
2.	 Open timeline that corresponds with GPSport data
3.	 Choose File > Import > GPSports data...
4.	 Choose the GPSports XML data file to import.
5.	 The import settings dialog will open.

The import settings are based on creating instances using 
ranges of data found in heart rate and speed.

Heart Rate uses percentage of maximum heart rate found 
in the data file for the athlete.

Start by setting the bottom of the range, then work up the text boxes. The minimum range will 
become one greater than the maximum set for the range below it.

The actual heart ranges are displayed automatically according to percentage.

Speed uses the data found in each sample in the XML file. This is a tag in the GPSports XML file.

Start by setting the bottom of the range, then work up the text boxes. The minimum range will 
become one greater than the maximum set for the range below it.

The range names can be set by typing in the text boxes to the left of the ranges. The names will be 
used in the name of the row. This makes it easier to identify the speeds in the timeline.

* SportsCode Elite Only
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The results produce a gross timeline graph of the Speed and HR changes throughout the game.

Fairplay Rugby*

Fairplay data may be presented in either a Text Edit or XML file format.

Open the Fairplay file using the relevant program.

1.	 Press COMMAND A ,(to select all,)  then COMMAND C (to copy the entire file.)
2.	 Open SportsCode and go to File >Import >Paste Fairplay Data
3.	 Enter the preferred lead and lag times and press OK
4.	 Link the Timeline created to the movie and synchronize the two

Refer to “Relinking Movies” in the Capture Section.

Polar Heartrate data

This import works similarto the GPSports import.

Set Directory for Auto XML Import *

XML data can be automatically imported into a capturing timeline by selecting a folder where 
SportsCode will look for incoming data. The XML format must be in the SportsCode format (such 
as that used in CODA and iCODA). See the XML Edit Import description for specifics on the data 
structure, particularly the session-info section. To make the time synchronization work really 
precisely, the computer clocks of the capturing and coding computers should be synchronized using 
network time. In order to synchronize properly, the  movie must be captured using SportsCode. 

When using this import option, the file name must have the tag <import> in the beginning of 
the file name otherwise SportsCode will not insert the data in the timeline. A file name might 
be “<import>LALakers.xml”. Double underscores can be used in place of the angle brackets, so an 
alternate file name could be __import__LALakers.xml.

The import directory should be set prior to capture, but can be done at anytime during capture. The 
directory needs to be reset if the application is quitted.
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The auto XML import will not update instances that have already been imported into the timeline 
for efficiency reasons as all XML data does not have to be reloaded from the start constantly. In the 
case where the XML data has been updated for existing (past) instances, the xml must be reloaded 
entirely. To do this: Choose File > Import > Reload auto XML import. The timeline will empty and all 
XML data will be reloaded.

During capture: Hold down CTRL+COMMAND+A and click and drag the playhead to adjust the 
instances during an auto XML import. A time offset will be calculated, stored and used to import the 
XML for the remaining time that SportsCode running. This offset will be discarded once SportsCode 
has been quit, but the instances will remain in place in the movie package after it is closed.

Reload Auto XML Import *

This feature will reload the XML file into the timeline, so it can be manually updated if required.
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Capture

IMPORTANT : Refer to the Preferences Section on Page 6 of this manual for your preferred 
settings for this function. It is important that your settings are correctly configured if this 
function is to deliver optimum results.

We define capture as the process of recording a sequence of images from a video source such as 
a camera or digital convertor into a file on the internal hard disk of the computer or other storage 
device. The capture window supports various PCI capture cards, firewire, thunderbolt devices and 
USB cameras such as a webcam. Warning: The USB port in most hard disk drive or SD card cameras is 
for file transfer only, it does NOT output a video stream. So, many of these cameras cannot be used 
for live capture. 

Making the connections

When connecting any video devices for capture, try to visualize the video signal flow. Drawing the 
signal flow on paper can be very helpful. Start by identifying the source and destination connectors 
physically on the devices, then map out how they are going to connect to each other, matching 
video out to video in accordingly.

For instance, if you are sourcing the video from a satellite receiver, you are likely going to be using an 
analog to digital convertor as a bridge from the source to the capturing computer. 

Signal Flow

Satellite Video Out > Convertor Video In > Convertor Firewire Out > Computer Firewire In

So, the signal flow will start at the video out connector of the satellite box, travel to the video in 
connector on the convertor using a rca cable, then travel to the computer using a firewire cable. Set 
the convertor settings to analog input if automatic detection is not enabled.
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AV Foundation Capture

AV Foundation Capture is the default preference for Capture. AV Foundation capture is a capture 
option which allows the user to achieve compression on the fly but still free up the CPU for other 
tasks.

You will recognise the AV Foundation capture window by the Floating toolbar and the absence of a 
panel at the base of the window containing capture settings. In AV Foundation capture these 
settings are contained in the Inspector which is accessed by clicking the button in the 
floating toolbar.

Press the Capture button at the left of the toolbar to start and/or stop the capture

Press the pause button to start or stop pause

Move the volume control slider to the right to increase the speaker 
volume (output) and to the left to decrease it

There are 3 “HUD” (Heads Up Display) icons which have the following functions

The microphone icon displays the audio input levels for the capture

The dial display provides settings information prior capture and then capture status 
information during the capture

The Inspector icon opens the Inspector window to determine capture settings.

The settings information HUD is displayed in the Capture window.

General Settings

Video Source : Reflects the attached video sources. Facetime Camera will always be present and any 
other sources will be listed below it.

Video Format : Reflects the formats available for the video source selected.

Frame/sec : Reflects the output selected from the recording device or interface box.

Proportions : Nominally, “From Device” is required. In special cases ie. the use of ADVC-55 with a wide 
screen input, will require the proportion setting 16 x 9 to be selected.

Audio Source : Normally you would select “Output from Video Device”. Where an external audio 
source is required, then this should be selected.

Audio Format : Choose the compression settings that you require.

Capture Preset : This is the list of presets available in the presets pane. Will include any personal 
presets that you have defined.

Audio Channels : Select the number of channels you require.
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Movie Segments

Single Movie  :  Check this box to to capture to a single file in the movie package. When this option 
is selected a timeline is not created, so no real time analysis such as coding or timeline sharing can 
take place.

Movie Segments (30 seconds) sets this default 
duration. It is strongly recommended that you use 
a default setting of 1 minute unless timeline share 
updating is paramount. We recommend saving 
captured movie packages as standalone packages 
after capture. 

Minimum movie segments (5 seconds) -  This is 
important for timeline sharing as it is readied for 
access by the timeline share process as quickly as 
possible. When a code button has ended, it signals 
the capture window to end the current movie part 
that is being captured in order to allow access to the latest captured video part in the timeline. So, 
if the setting of a code button was ended after 5 seconds of a movie part starting and this setting is 
set to 1 minute, it will take another 55 seconds for the movie part to be ended and ready for viewing 
in the timeline. We recommend using 30 seconds for default duration and 10 seconds for minimum 
duration settings when using timeline share. Otherwise, use the default settings.
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Compression Settings

Presets
NOTE : If you choose a SportsCode preset as listed below, none of the settings are editable. If you 
choose a SportsCode preset and duplicate it, (Personal preset),  then all of the settings are editable.

High Quality 
iPhone 
iPod 
Apple TV 
iPad
Uncompressed 
WiFi 
Cellular 
Apple Pro Res 422 
Personal Presets :  As defined by the User 

Video
Codec
Frame Size
Camera Dimensions
Scaling
Bit rate
Quality
Key Frames
Profile

Audio
Codec
Linear PCM
Sample Rate
Bit Rate
Channels

Log

A chronological record of all the actions which 
take place during the capture process.
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Quicktime Capture

The capture window can be directly accessed in several ways:

 �By clicking on the Start Capture icon in the 
floating toolbar .

Through the main menu: Capture > Open capture 
window.

A keyboard shortcut: ⌘R

In the code window, by pressing the 
Capture Mode icon.

Before opening the capture window, connect the camera or video source to your computer. 

When the capture window is opened, it will search for any connected video sources. If it does not 
find an attached sources, it will default to the built-in iSight camera if available on the computer 
otherwise it will indicate none available. This is useful to know when testing connectivity between 
computer and video sources.

The cable used to connect a camera is likely to be a 9-pin to 4-pin or 6-pin to 4-pin Firewire cable. 
The 9-pin or 6-pin end of the cable connects to the computer and the 4-pin connects to the camera. 
Digital converters generally have a 6-pin connector, some have both 4-pin and 6-pin.

Setting Video and Audio Sources

The video and audio input sources can be set in the capture window below the video preview 
window.

To change the video source, click on the drop down menu next to the camera icon 
. Choose the source from the list. A camera or other device should appear in the 

menu if properly connected.

To change the audio source, click on the drop down menu next to the microphone icon 
. If a camera or other external device is used for capture, this option will be 

greyed out.
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Compression Options

The capture window has options to change the encoding method that is used while capturing 
the movie. The encoding method is referred to as a codec. Codec stands for compression 
/ decompression and is the way in which the data is stored (compressed) and presented 
(decompressed).

For many capture workflows, the native codec used by the source might not produce the optimal 
results, so a different codec might be chosen to use during capture. This is common to reduce the file 
size. For example, the DV codec produces very good quality video, but the file size is quite large. So, 
as a way of reducing the file size, capture using the H.264 or MPEG-4 codec option. While the quality 
is not as good, it is much easier to transfer and store the smaller files.

While choosing different codecs from the native ones is a great option, be aware that it requires 
more CPU to recompress the files on the fly. We recommend doing a lot of testing to guarantee that 
the options used during capture will work through the entire span of the video workflow. You might 
find that your computer is not powerful enough to handle capture, recompression and coding at 
the same time. You could also find that the chosen video codec will not work in some third party 
software involved in your workflow.

Video Codecs

There are 3 codec choices for the video component of capture apart from the device’s native video 
codec. These are designed by Apple to produce the best results possible. The video codec options 
can be accessed by clicking on the drop down menu to the right of the video source drop down.

Device Native - The capture will use the settings that are coming from the source. We recommend 
using this option in most cases as it reduces the load on the cpu and results in the highest quality 
possible. A common native codec is DV. DV files will be 13.76GB per hour.

Apple Intermediate - This is a codec designed by Apple to be an intermediate format in an HDV 
workflow. This codec produces very large and high quality video files while not requiring a lot of 
cpu work to do so. Files are roughly 20GB per hour. This is a great codec to use when you want a 
high quality master that will be used to create other videos such as for iPod or streaming over the 
internet.

H.264 - This option compresses the video into the H.264 codec, a derivative of MPEG- There are 4 
options while using this codec, the options only change the frame size thus reducing the file size. 
We recommend using the H.264 SD for standard definition video sources or H.264 HD 720 option for 
high definition video sources for most occasions. The data rate will vary according to images being 
processed.
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MPEG-4 - This option compresses into the MPEG-4 codec. Like H.264, there are 3 options, each one 
uses a different frame thus resulting in a smaller file. This has traditionally been the codec of choice 
for capturing good quality files with relatively small file sizes. Files will be roughly 2GB per hour. 
H.264 will supercede this codec in the future.

Audio Codecs

And there are 3 choices for the audio component of capture apart from the device’s native audio 
codec. Generally speaking, audio codec settings are largely ignored as when compared to video, 
mainly because the size of the audio component is insignificant to that of video. For the most part 
using the Device Native settings will be perfect. However to save a little space, using AAC High 
Quality is a good option.

Next to the audio source drop down menu are the compression options. By default, the menu 
selection is set to Device Native.

                            Device Native - This will capture using whatever the device is outputting. 
AAC High Quality - This delivers a CD quality audio track at 128kbps. 
AAC Voice Quality - This delivers a low quality audio track at 32kbps.

Apple Lossless - This delivers a very high quality audio track that is quite large in size depending 
on the audio that is being recorded. This is a good option to use if recording using external 
microphones and audio is really important to the video.

* SportsCode Elite Only
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Convert Movie Package

During capture, an extra movie package can be created. An additional compression process can be 
enabled that will compress a capturing file live using custom settings. This feature can be turned on 
at the bottom of the save dialog box when naming the capture file.

Select the “Convert movie package” tick box and set the desired compression settings. This option is 
only available when capturing using Device Native or Apple Intermediate codecs. An additional 
option to this, is to create single movie in the captured package once the export is complete. This 
will create a single file from all the movie segments inside the package. It is recommended to do this 
as it makes the package void of file references. A definite plus in terms of file portability, plus it allows 
the file to be extracted from the package and directly uploaded to Sportstec Stream or used more 
easily in some other workflow.

When capture starts, the export movie window will 
appear. Each movie part that is captured will be 
converted until all are converted. If the capture is 
stopped and their many movie parts left to convert, 
the extra compression will continue converting all 
the parts in the package until it is finished or the 
application is quitted. If the application is quitted 
while there are still movie parts left to convert it will 
start up again when the original movie package is 
opened again. Once the extra export is complete, a 
movie package with same name plus extra will be 
found in the same folder as the original capture.

An export can be paused, cancelled or deleted anytime. To pause press the pause icon in the row to 
the right of the progress bar. To cancel press the x icon to the right of the progress bar. To delete a 
row in the queue, select the row and press DELETE on the keyboard.

The export window supports multiple items in the list. It is based on a first in first out queuing 
system. So, more items can be added to the queue during capture and will be handled when the 
previous item above it in the queue is completed. To add more items to the queue during capture, 
say for instance multiple movie formats are desired, select the timeline window, then choose File > 
Export > Timeline as new codec..., select the movie format and destination and add it to the queue.
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The Capture Window Toolbar

Capture / Stop Button 
Press this button to start capture and to stop the capture. Click and holding down 
the mouse button over the arrowhead symbol will reveal a drop down menu of 
functional options.

Append Capture 
Allows you to stop a capture and then resume the capture at  another time by  appending 
the resumed capture to the initial capture reference movie file.

Pause / Resume 
The Pause/Resume button allows you to pause the capture and then resume later. 
You cannot logout of the capture or perform another task in SportsCode while the 
capture is paused.

Preferences

Takes you to the Preferences Window. Refer page 6 

Current Time Display

Displays the current elapsed time of the capture.

Basic capture

Start to learn how to capture by stepping through the basics first.

Make sure the capture source, camera or convertor is connected and turned on. Or try using the 
Built-in iSight camera.

Open the capture window by clicking on the Capture icon in the floating toolbar. This will open the 
capture window and an image should appear in the window from the camera or convertor.

Press the red capture button to start capture . This button will reveal a drop down menu if the 
click is held down while pressing the button.

Name the file and choose a destination folder. The desktop is a good place to start capturing files to 
as you will not lose them as easily. 
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Once capture has begun, a timeline window will pop up. This timeline allows live access to the 
capturing file, all the features of the timeline can be used live during capture. This timeline will 
continue to grow in length during the capture.

In the capture window, the status section in the bottom of the capture window will indicate: 
captured file length, size and data rate. It will also indicate disk information: available space and 
approximate capture length available according to remaining disk space.

At any time, the capture can be paused by clicking on the Pause button . To continue capture 
after pausing press the Resume button .

To stop the capture, press the stop button . A message will pop indicating the capture 
is complete. The capture window will disappear and the timeline and movie window will 
remain.

Quick Capture

The quick capture feature is used to initiate capture instantaneously forgoing any save 
options. By pressing CONTROL+COMMAND+R, capture will start immediately and the 
movie will be saved in the quick recording folder with a date stamp as the name. This 
feature can also be accessed in the drop down menu of the red capture button in the 
capture window toolbar. While this is a convenient feature for rapidly starting capture, it 
is mainly employed through the remote communications and iCal event captures.

Update Capture

�During capture, a new file is written approximately every 5 seconds, then from these files 
a continuous reference movie is created on the fly. This automatic update process can be 
manually made to occur by pressing the update button in the capture toolbar. Pressing 
update will start a new file. This is useful when using timeline share* or when exporting 
movies through the matrix web export*.

View Capture Ratio

�The ratio that the video is presented in the capture window can be adjusted by clicking on 
the View Ratio button in the capture toolbar.

The settings for the ratios are:

Camera. This displays the native image ratio of the source.

Window. This displays the image to fit the size of the capture window.
1.	 4x This displays the source image in a 4 by 3 ratio.
2.	 16x This displays the source image in a 16 by 9 ratio.

Full Screen Capture

�Capture can be viewed in full screen by pressing the Full Screen button in the capture 
toolbar. To exit full screen capture press the ESC key.  When presenting the capture 
window in full screen, coding cannot occur. This is for viewing purposes only.
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Communicate & Communicate Only

For use with Remote Communication coding and capture only. 
Refer to Page 97 for more detail.

Code Window functions during Capture

During capture, with a Code Window open, you may create instances in the Timeline using capture 
mode (live capture) or code mode (after capture) or add labels to an instance (after instance has 
been created). You may also add more buttons or labels to your code window or remove them. 
Thus you may toggle between capture mode, code mode ,label mode, report mode and edit mode 
without affecting the capture.

Add Capture Event to iCal
Movies can be captured using iCal events. Follow these steps to set up movie to be captured. This is 
useful when you are not going to be at your computer when the performance is happening and you 
want to setup of queue of movies to be captured consecutively.

iCal Capture

1.	 Choose Capture > Add capture event to iCal from the main menu bar to open the iCal Capture 
window.

2.	 In the iCal Capture window, choose a date for the event by clicking on the graphical calendar.

3.	 Set the start and end time using the appropriate controls. As a convenience, set the start time 
and use the slider to set the end time. If a longer end time is required, increase the end time 
manually.
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1.	 Input a name in the File name text box to be used for the captured file.

2.	 Press the Add to iCal button in the toolbar.

iCal will launch and a new calendar will be created called SportsCode if one does not already exist. 
An event will be added to the calendar using the settings from the iCal Capture window.

The event has a specific naming convention that must used.

<capture>”MOVIE NAME”

The movie file name will become the text inside the quotes. For instance, if the file name in the iCal 
Capture window was “World Champs”, the iCal event will be named, <capture>”World Champs”. 
The resulting captured file name will be World Champs.SCpkg. If this naming convention is not 
used, SportsCode will not capture properly. If you want to rename the event, change only the name 
between the quotes in the iCal event.

The event will trigger SportsCode to open 1 minute prior to the start of the event. Then using the 
start and end times set in the event of the SportsCode calendar, the capture will start and end.

Note: Simultaneous events cannot be captured at the same time. Also, if using MobileMe synching and mulitple capture 
computers, be careful not to sync the same calendars to all the machines.

Synchronizing Sound and Video

When capturing  or downloading video from the internet you may occasionally find inaccurate 
sound and video synchronization in captured movies.

Most Common Problems that Occur are:

3.	 The sound is offset by the same amount throughout the movie file. 

4.	 When capturing a long movie, the sound and video synchronization can be good at the start of 
the video, but the further one goes, the more the sound and video synchronization becomes 
a problem. In this case the scale of the video and sound is different and is a known problem in 
Quicktime. 

When Do Synchronization Problems Occur?

The problem of the gradual drift is most likely to occur when the pause/resume button in the 
capture window is not used for extended periods of capture. These buttons start a new video file 
each time they are used, so they can re-synchronize the video and sound. This is less common as 
the capture window breaks the files up in 5 second chunks. But, video might be acquired from 
other sources that exhibit the problem. Using the procedures below may not be very useful in 
this situation, since there are variable length sections of video and sound and synchronization in 
one area may lead to slight miss alignment in others. Fortunately, the contracting and expanding 
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procedures work best for movies created when the pause/resume button are not used because any 
drift is constant across a single movie file.

In the main menu bar select Edit > Equalize track times. This can only be done after the movie 
capture. However, it is not as accurate as equalizing during capture if your movie is made from more 
than one file. You can choose to make the equalization permanent if your movie is attached to a 
timeline window. This procedure stretches or contracts the length of the sound track to equal the 
length of the video track. This feature is also useful for resetting the tracks when you have nudged, 
expanded, or contracted the sound track and lost a synchronization point altogether.

A. Synchronization of audio that is offset the same amount throughout a movie.
5.	 Move the timeline cursor to a section in the movie, near the start of the movie that can be used 

to evaluate the synchronization.
6.	 Zoom in the timeline, turn on movie looping and play the timeline movie. 
7.	 If the sound is slightly ahead of the video, select Edit > Nudge sound track left 

(CONTROL+OPTION+COMMAND+L). This nudges the sound track one frame to the left. Hold 
down the keys to repeat the nudge continuously.

8.	 If the sound is slightly behind the video, select Edit > Nudge sound track right 
(CONTROL+OPTION+COMMAND+R). This nudges the sound track one frame to the right. Hold 
down the keys to repeat the nudge continuously.

9.	 When you use these features the video and sound will pause, move in the direction specified 
and resume play. If the video is attached to a timeline then SportsCode will try to update the 
movie resource, so the change is permanent. 

10.	 Save timeline.

B. Synchronization of audio that is gradually drifting throughout a movie.
1.	 Move the timeline cursor to a point near the end of the movie. 
2.	 Zoom in the timeline, turn on movie looping and play the timeline movie. 
3.	 If the sound is slightly behind the video, select Edit > Contract sound track 

(OPTION+COMMAND+L).
4.	 If the sound is slightly ahead the video, select Edit > 

Expand sound track (OPTION+COMMAND+R).
5.	 When you use these features the video and sound will pause, 

move in the direction specified and resume play. If the video is attached to a timeline then 
SportsCode will try to update the movie resource, so the change is permanent. 

6.	 Save timeline.

Note: The anchor point for contracting and expanding the sound track is the beginning of the sound track at the start of 
the movie. Contracting and expanding acts on the whole length of sound track.

Reset the sound and video tracks by choosing Edit > Equalize track times. 
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Delete a Movie

Movie files are generally quite large, so space on your hard drive must be managed and organized 
especially if you do not have any external storage.

1.	 Drag the movie package to the trash can in the dock.

2.	 Make sure Finder is the active by clicking on the desktop. 

3.	 Select Finder from the main menu bar and choose Empty Trash.

4.	 The Finder shortcut to trash a file is COMMAND+DELETE. To empty the trash, the shortcut is 
SHIFT+COMMAND+DELETE.

When you delete a movie file, we recommend saving the timeline file, so you can link it back to the 
movie. Timelines are very small data files, often no more than 20KB. It is a common practice to export 
the video to a dvd or tape for archiving purposes, then recapture the video and match the coded 
information back to movie. To do this, create a folder, call it Timelines, then open a movie, click on 
the timeline window and select File > Save as. Save the file in the Timelines folder. Now, you have 
your timeline data saved and it can be matched back up to the video at a later date.

Linking Movies

If you want to re-capture a movie and link it to a saved timeline, you need to re-establish the link 
between the two files.

Link a Re-Captured or another Movie to a Timeline:
1.	 Open a Timeline file.
2.	 From the Main Menu select : File>Link movie to timeline window
3.	 Use the open dialogue box to locate the movie. 

This links the selected movie with the codes.Save the Timeline once the link has been established.
If you open an unlinked timeline, Gamebreaker will immediately open the “Link Movie to Timeline 
Window” dialog box.
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Align Instances after Re-Capturing a Movie – Nudge Right Or Left 

When you have re-captured a movie and re-linked it to a timeline, you may find the instances in the 
timeline don’t line up with the relevant parts of the movie.

To correct this:

1.	 Press SHIFT+COMMAND+L to nudge the instances to the left. This moves all the instances one 
frame to the left. Hold the keys down to repeat the nudge continuously. The operation will 
accelerate the longer the keys are held down.

2.	 Press SHIFT+COMMAND+R to nudge the instances to the right. This moves all instances one 
frame to the right. Hold the keys down to repeat the nudge continuously.The operation will 
accelerate the longer the keys are held down.

Using the mouse to slide and move instances in the timeline.

When importing data from external sources, it is almost always necessary to push the instances 
around to align them to the movie. There are 4 convenient mouse driven features to accomplish this.

1.	 Set the playhead at the start point of an instance, hold down CTRL+COMMAND+Z, then click 
and drag the playhead to point in the video where the instance should start. All the instances 
in the timeline will move also. In most cases, this should synchronize all instances in the 
timeline.

2.	 Sometimes it is necessary to remove gaps between sections of instances in the timeline. This 
is common if all the movies captured were paused at breaks in the action and the coded data 
was time was not paused. To removed the gaps, set the playhead to the start time of the first 
instance after the gap, hold down CTRL+COMMAND+X and drag the playhead to the left until 
the instance aligns with the movie.

3.	 Similar to CTRL+COMMAND+X, the playhead can be set at the last instance’s end time 
preceding the gap, then choose Edit > Remove unused instance time to right of playhead 
(OPTION+SHIFT+COMMMAND+L)

4.	 If a mistake is made using “Remove unused instance time to right of playhead”, the instances 
can be nudged back by holding down OPTION+SHIFT+COMMMAND+R. All the instances to the 
right of playhead will nudged to the right, creating a gap.
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Adjust Placement of Selected Instances

Instance adjustments can add or subtract time to any selected instances in a timeline. 

In the main menu bar, choose Edit > Instance adjustments.

1.	 Mark In will add or subtract time from the beginning of an instance.
2.	 Mark Out will add or subtract time from the ending of instance.
3.	 Nudge clips will move the selected instances. Use a minus sign in front of the number to nudge 

clips to the left.
4.	 Merge overlapping instances will create a single instance for instances that overlap.

Click on the adjust button once to make the adjustments that are ticked. The adjust button can be 
clicked on as many times as required to make the necessary adjustments. It will continuously apply 
the adjustments.

Timeline Sharing *

During capture, SportsCode Elite creates a second timeline file, so coded instances can be viewed by 
other computers over a network. This file can be found inside the movie package and can be opened 
by any SportsCode application. SportsCode Elite creates this second file to guarantee that your 
active coding timeline is not corrupted or changed.

During capture, the timeline share will automatically update every 5 to 10 seconds with the most 
recent coded information. To manually update, click on the update button in the capture window. 
This writes out the .TLshare file, so that other users on the network will get the latest information.

Before diving off into timeline sharing we strongly recommend consulting the IT department 
or Sportstec. The networking side of things can be quite tricky as every network is setup a little 
differently and might have some quirks that could present some real problems. 

This feature shares the video file over the network. Playing video over a network is very intense 
because of the large amount of data involved in the movie files. A robust network is extremely 
important. We recommend using gigabit ethernet switch when connecting the computers for this 
reason.

For purposes of this manual, a simple network between two computers running Mac OS X 15 will 
be outlined. Again, contact the IT department or Sportstec if more explanation is required or help is 
needed.

* SportsCode Elite Only
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Setting Up a Basic Network

Each computer will be assigned a static IP address in the networking panel of the system 
preferences.

1.	 Navigate to the Network preferences panel:

•	 Click on the apple in the upper left hand corner of the screen.
•	 Choose System Preferences... from the menu.
•	 Click on the Network icon in the System Preferences panel.
•	 Click on “Ethernet” in the list of the network preferences panel.
•	 Click the “Advanced” button

2.	 Configure the capture/coding computer ethernet port to a static ip address.

a.	 Configure = Manually
b.	 IP Address = 10.0.1.1
c.	 Subnet Mask = 255.255.255.0
Press the Apply button.

3. Configure the viewing computer ethernet port to a static ip address.

a.	 Configure = Manually
b.	 IP Address = 10.0.1.2
c.	 Subnet Mask = 255.255.255.0
Press the Apply button.

Network Locations

A handy Mac OS feature is network locations. Locations can be switched quickly to configure the 
system from one network environment to another.

1.	 Open network preferences panel in System Preferences.
2.	 Click on the Location menu in the top of the panel and choose Edit Locations...
3.	 Add a new location and give it a name suitable for the network environment.

The newly created location will have all the settings that are currently set in network preferences 
panel. If any changes are made, the changes will be saved for this location.

To quickly switch locations, click on the apple in the upper left corner, choose Location and 
select the proper network environment.
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Setting Up The Share

Now that the networking is setup, file sharing must be turned on on the capture/coding computer 
in order to gain access to the timeline share file.		

1.	 Navigate to the Sharing preference panel:
a.	 Click on the apple in the upper left hand corner of the screen.
b.	 Choose System Preferences... from the menu.
c.	 �Click on the Sharing icon in the System Preferences panel.

2.	 Turn on File Sharing by ticking the box in the list.

3.	 Add a folder to share where the file will be captured by clicking on the plus button at the 
bottom of the Shared Folders list. To make the process most convenient, choose the ~/Desktop 
as the share point. This is an easy location to remember and manage 

                                                   There are options to setup user privileges and other permissions. To keep 
it simple take note of the user that is listed by default and do not add any 
others. The current user that is logged should be listed with Read & Write 
privileges. The user name and password for this user must be known and 
will be used to log in from the viewing computer.

Connecting To The Shared Folder

With the network settings and sharing in place, connect the two computers via an ethernet cable.

To check connectivity, open the Network preferences panel and look for a green light next to 
Ethernet.

On the viewing computer connect to the capture/coding computer shared folder.

1.	 Open Finder and press COMMAND+K.

2.	 In the Connect to Server window type in the IP address of the capture/coding computer, 
10.0.1.1.

3.	 The login screen will pop up, login using the user name and password for that of the         
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capture/coding computer.

4.	 Choose the ~/Desktop folder in the list and click OK. This will mount the folder and it can be 
accessed in Finder to open the timeline share.

Opening The Timeline Share

The timeline share can be opened by double clicking on the movie package that is being captured 
on the capture/coding computer. Alternatively, the .TLshare file is found inside the package. To 
access the package contents, right click on the package and choose Show package contents from 
the contextual menu. This will open the package and the timeline share file can be double clicked or 
dragged onto the SportsCode icon in the Dock.

The timeline share file does not show up in the package until the first instance is coded. It is  
recommended that an instance is coded to test the timeline share before a live event.

Once the timeline share file is open on the viewing computer, it will update automatically. The 
update on the viewing computer occurs approximately every 5 to 10 seconds depending on coding 
activity or network conditions.

The timeline share feature requires a lot of resources to run smoothly. We recommend any 
computers used in conjunction with this feature be dedicated to this alone. Other applications 
should not be running.
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The Communication Window

IMPORTANT : Refer to the Preferences Section on Page 12 of this manual for your preferred 
settings for this function. It is important that your settings are correctly configured if this 
function is to deliver optimum results.

The communication window is where clients can be added, suspended, removed and edited. Errors 
and logs can be accessed for trouble shooting or basic monitoring. Capture can be started, paused, 
resumed, and ended. The preference panel can be opened here too.

All available and connected Clients and Servers are shown in this window. The number of connected 
Clients and Servers are shown in the list on the left edge of this window.

Open the communication window by choosing File > Communication window.
NOTE: If remote communications are required to be sent over the Internet, IT consultation will be a must. This will require 
a high level of network experience and is a very involved setup. Please contact Sportstec to get more information on 
setting up remote communications over the Internet.

Remote Communications

A flexible network feature, SportsCode Elite remote communications are designed to provide one 
or more computers the power to control and share information on multiple computers during the 
capture and coding process. It can start, pause, resume, and end capture on client computers over 
a local area network or even over the Internet. Along with capture control commands, it can mirror 
code window button pushes on one computer to another computer, so coded information can be 
shared in near real time.

Like the timeline share feature, remote communications requires networking configuration. While 
the communications feature is not nearly as intense on the network, we recommend running this 
feature over a gigabit Ethernet network. This will insure that the best possible network environment 
is in place. Wireless networks can be employed, but suffer from drop out and range problems 
especially in highly populated areas where there are a lot of mobile communication networks and 
active devices. For purposes of explaining this feature, we will assume the same Ethernet network 
configuration is in place and connected as described in the setting up the network aspect of the 
timeline share section of this manual. (Page 87 )

Only SportsCode Elite or SportsCode Elite Review can send commands acting as a server. All other 
SportsCode versions can only execute commands acting as clients.
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Server And Client

The key to setting up this feature is understanding the roles of the server and client as we define 
them. 

A Server is computer that sends commands to a client. 
A Client is a computer that executes the commands sent by a server. 
A computer can be both a Server and a Client to other computers. This is often the case when 
mirroring code button pushes between two capture/coding computers.

Connecting To Clients For Remote Communication
Clients can be added and connected in two ways.

Automatic Connection

Click on the Clients button in the list on the left of the Communication window. Clients with remote 
communications enabled and servers with automatic connection to clients enabled will appear 
automatically in the main list of the communications window. If the default password for auto 
connect option is set, it will connect automatically too. The Bonjour icon will appear if connected 
automatically. If this is not set, then double click on the computer name and set the password in the 
window. Tick the Initiate recording on client computer if capture needs to be started on the client. A 
red button  will appear next to the computer name when initiate capture is configured. When the 
client is connected, the status column will report connected other wise it will report password 
required or unable to connect to IP or Port.

Manual Connection

Manually adding clients is used when no clients are readily available on the local area network or the 
client is being to connected to over the Internet via a public IP address or VLAN. This allows for all 
client configuration to take place before connecting to any network.
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Add the clients manually by clicking on the Add button in the window.

Add the IP address or URL for the client, set the password, then press the Test button to check 
whether the client is ready to 
communicate. A timeout duration can be 
set to better synchronize communication. 
A longer timeout duration may need to be 
set if connecting over the Internet or there 
is heavy traffic over a slow network. When 
the password is set and the test checks out 
OK, press OK. If the test does not report 
back a positive result, the client can still 
be added. The client will be added in the 
list of clients. When a client is added in this 
fashion, the computer name will not appear in the list. Remember to set the initiate capture option if 
required.

Capturing Using Remote Communications

Once the clients and servers are connected in the Communication window, capture 
commands can be initiated through the Capture window or the Communication window. 
Open the Capture window to view or set up the necessary buttons in the Capture toolbar.

There are two capture remote communication buttons in the Capture window, Communicate 
and Communicate Only. These buttons are not a part of the default of the toolbar set and must 
be added by customizing the capture window toolbar, (see the capture window section on 
customizing the toolbar to add these buttons to the capture window.)

The Communicate capture button will initiate a quickstart capture locally (server) and remotely 
on the connected clients with the initiate recording option checked. All the 
capture functions in the local capture window: stop, pause and resume will 
work both on the local (server) capture and the remote (client) captures.

The Communicate Only capture button will only send capture commands to the clients and 
will not initiate the local capture. The captured files will be found in the 
preferred quickstart capture folder. They will be named using a date stamp 
according to the system date. To set the Quickstart capture folder choose 
Capture > Quickstart set folder from the main menu bar along the top of the 
screen.
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Remote Communications Coding

The most powerful and simple feature of remote communications is the ability to send button push 
commands from a server’s code window to a client’s code window. This means that multiple people 
can be coding on different computers, all feeding information to each other’s timeline or into a 
single timeline over a network. Using the Internet, capture and coding processes can literally be 
done across the globe.

The button push commands are sent from server computers to client computers automatically when 
code mode is activated in a code window. There are no configuration settings in the preferences for 
this feature of remote communications. The only things that are required are a connection to a client 
and the identical code windows on each computer.
There are a few items to note.

1.	  �Use identical code windows on each server and client. Remote button pushing is when a 
server code window sends the push command to the matching client code window. The client 
computer locates the button to be pushed down and pushes it down. If the same code window 
is not open on the client computer, no buttons will be pushed down, so no codes will be 
created in the timeline of the client computer. 

2.	  �Multiple windows can be open at one time. It is a good practice to break down a single large 
code window into multiple smaller ones. This can make the coding process focused and 
accurate for the people coding. 

3.	  �Do not set the same hotkeys for multiple windows. When multiple code windows are open, 
the hotkeys may push down the wrong buttons if the same ones are set in the buttons of the 
windows.

4.	  �Capturing does have to occur locally on a server computer. Connect to a capturing client with 
the same code window open, open the same code window on the server and  activate code 
mode. The button pushes will start on the client even though the server is not capturing.

Imagine 20 or more people could be viewing the same event, coding on separate computers in 
different geographical location while all the data is being pushed into one capturing client. The 
possibilities for this feature are endless...
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Mirror Codes

The Mirror Codes feature is designed to copy a movie package that is being captured to another 
computer or from another computer as the capturing process is taking place. This saves time 
copying the movie package after completing capture since all the movie package contents are 
being synchronized until the capture is complete. As each movie part is captured and added to 
the package, mirror codes will copy this to the chosen destination package. The synchronization of 
files include: the timeline data file as it is being coded, all movie parts, and the timeline share files. If 
SportsCode Elite is being used to capture, the mirroring package can be opened as a timeline share 
file.

Packages can be mirrored over a network or to local external drives. We recommend using an 
ethernet network and to initiate the mirroring from the desired destination computer, thus pulling 
the file from the capture computer. This helps reduce load on the capture computer and should take 
care of any permissions problems. See the Setting Up the Network part in Timeline Sharing  section 
of this manual for networking help.

Once the network is all setup and the destination computer can reach the capturing file over the 
network, start capturing on the capture computer, saving the package in the shared network folder. 

On the destination computer, Choose Capture > Mirror codes to start mirroring. A finder window will 
appear, this is the target selection dialog box, choose the capturing package as the target and click 
on the Choose package button.

The next dialog box to appear is the destination folder location and file name. Input a filename and 
select a folder location to save the package in and then click on Start copy button.  The Mirror codes 
status window will open showing the progress of copy / synchronization process.

Once capture is ended, the Mirror codes process will also complete after double checking all the 
file contents to make sure that the process has completed properly. A message box will pop up 
indicating the process has completed and the process can be stopped.

If Append capture is being used, do not quit the mirroring process when the capture complete 
message pops up. Simply, click OK and let Mirror codes sit idle, once the Append capture process is 
started, Mirror codes will pick up where it left off and continue to copy - sychronize the packages.
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Movie Playback

You will use these controls more than any other in SportsCode.  It is crucial that you become very 
familiar with how they perform and what they do. Once the Movie has been captured, playing the 
movie is easy, you can go to any part of the movie whenever you like with a click of the mouse. Just 
drag the Timeline playhead and you’ll be there instantly, no need to fast forward or rewind.

The SportsCode Movie Controller

The movie controller is a “floating” toolbar which will appear whenever a movie is set up ready to 
play and by default will disappear when the cursor is removed from the window or has been inactive 
for 1.5 secs. It will reappear once the cursor is returned to the window The floating movie controller 
may be moved to wherever you find it most convenient. You are able to access the Drawing Tools, 
the Overlay Text fuction and the List of Chapters in the movie directly from the floating movie 
controller.

Loop Mode

Sets the playback mode for play once (Off) or repeat (On).

Movie Chapters List

Open this list to view a list of the chapter markers in the movie and 
where they are.

Playback Rate Control

This control sets the playback speed for all 
movies. Double click on the icon to reset it to the 
default speed of 1x.

Frame Fwd / Frame Rew
Hover the cursor over the bars close to and to the right of the Play/Pause 
symbol on the wheel. Click to frame forward.

Hover the cursor over the bars close to and to the left of the Play/Pause 
symbol on the wheel. Click to frame rewind.
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Fast Fwd / Fast Rew
Hover the cursor over the bars at the extreme right of the Play/Pause 
symbol on the wheel. Click to fast forward.

Hover the cursor over the bars at the extreme left of the Play/Pause symbol 
on the wheel. Click to fast rewind.

Play / Pause Button
Click the Play button to play.

Click the Pause button to pause.

Speaker Volume Controller

Move the volume control slider to vary the movie sound volume. Move to 
the left to decrease volume and move to the right to increase volume.

Overlay Text

Click this button to open “Overlay Text” to display the labels in each of the instances 
comprising the movie.

Drawing Toolbar

Clicking this button will either Show or Hide the Drawing Tools.

Play any Movie

There are three ways to play a movie:

1.	 Click the Play button on the floating movie controller
2.	 Press the SPACE bar on the keyboard
3.	 Press the UP key on the keyboard

Pause any Movie 

There are three ways to pause a movie:

1.	 Click the Pause button on the floating movie controller
2.	 Press the SPACE bar on the keyboard
3.	 Press the DOWN key on the keyboard
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Go to a Specific Part of the Movie.

There are three ways to go to a specific part of the movie:

 
Drag the 
playhead in the 
Timeline to the 
required point in 
the movie.

 
Use the Fast Rewind or Fast 
Forward Buttons on the 
movie player control.

 
Press and hold the 
COMMAND key then press 
the RIGHT or LEFT ARROW 
keys to move the playhead 
though the movie.

321

Presenting Movies In Full Screen

Any movie can be presented in full screen.  There are three ways to present a movie in full screen:

1.	 Press the COMMAND+M keys on the keyboard
2.	 Click the Full Screen icon in the top right corner of the Movie window
3.	 Go to the Windows menu and select “Present Movie”

To stop presenting a movie in full screen

1.	 Press COMMAND + M key on the keyboard.
2.	 Press the ESC key

Movie Playback Keyboard Control

Once a movie is created or linked to a timeline, you can use many key combinations to play it at 
different speeds.
•	 SPACE BAR plays and pauses the movie
•	 RIGHT ARROW moves the movie forwards frame by frame. Hold it down for continuous slow 

motion movement forward.
•	 LEFT ARROW moves the movie backwards by frame. Hold it down for a smooth rewind action.
Also use the COMMAND, OPTION, SHIFT or FN keys in conjunction with the arrows to vary the rate of 
step forward/backwards. Refer to the Keyboard Shortcuts section on page 23.

Open a Timeline with any Sportstec XML

Drag and drop any Sportstec XML to the SportsCode icon in the dock to automatically open a 
SportsCode Timeline.
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Creating Instance Movies

You can create an instance movie in the timeline from:
•	 A single instance.
•	 All instances in a single row chronologically.
•	 Selected instances across multiple rows chronologically (Merge rows).
•	 Sequential rows in order of row number and the selected rows (Sequential rows).
•	 Selection order in a single row or across multiple rows (Selection order).

Create a movie from a Single Instance 

Double click on the instance in the timeline or select an instance and press the Make movie 
button in the timeline tool bar.

Create a movie from all Instances in a Single Row

1.	 Select the row of instances by clicking on the row number. 
2.	 Click on the Make movie button in the timeline tool bar. All instances in the row will play in 

chronological order. Alternatively, after selecting the instances, press OPTION+COMMAND+M on 
the keyboard to create the instance movie.

To make it even easier, double click on the row number and an instance movie will be created from 
all the instances in the row.

Drag & Drop Instance Movie Creation

You may create an instance movie from selected instances or parts of instances by dragging & 
dropping. Double click on the instance in the timeline  to select and open it which will be the 
beginning of the movie. Click on another instance to select it, then click, drag & drop it on top of the 
first instance selected. The 2 instances will be combined into one instance movie.

By default, an instance when selected, will select the entire instance. You may choose to select 
only a part of the instance by pressing & holding the SHIFT keywhile dragging the instance movie 
playhead. This will select only that part of the instance movie. Then drag & drop the movie as 
described above.

To save the movie created refer to the explanation on “Saving Instance Movies” on page 118 of this 
manual.
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Merge Rows, Sequential Rows, and Selection Order

There are 3 different ways to play instances across multiple rows by changing the make movie 
method in the timeline. By default, Merge rows is selected. To change, click on the Settings icon at 
the right of the Timeline toolbar.

Merge Rows

Merge row creates instance movies in chronological order of the timeline. When multiple instances 
are selected in different rows, the merge rows feature will merge the instances and create chapter 
markers where instances overlap.

1.	 Hold down COMMAND to select multiple rows. Select the row of instances by clicking on the 
row number.

2.	 Click on the Make movie button on the timeline tool bar. The instances will play in chronological 
order, alternatively use the shortcut, OPTION+COMMAND+M.

Sequential Rows

Sequential rows creates instance movies in row order of the timeline for all selected instances. When 
multiple instances are selected in different rows, the sequential rows feature will start from the 
lowest row number and proceed to the highest row number. All instances in each row will be played 
in chronological order.

1.	 Organize the timeline rows by dragging on the row number.
2.	 Select the Sequential rows feature in the timeline.
3.	 Hold down the COMMAND key and click on the row number to select multiple rows.
4.	 Click on the Make movie button on the timeline tool bar. The instances will play according to 

their row order.

Selection Order

Selection order creates instance movies in the order that instances are selected in the timeline.

1.	 �Select the Selection order feature in the timeline.
2.	 �Hold down the COMMAND key and click on the instances in the order you want them to play in 

the instance movie. As each instance is selected, it is labeled with a number [1], [2], [3]...
3.	 �Click on the Make movie button on the timeline tool bar. The instances will play according to 

their selected order.
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Presenting Instance Movies In Full Screen

Any timeline movie or instance movie can be presented in full screen.

There are three ways to present a movie in full screen:

 
Select Windows from the 
main menu bar and choose 
Present movie.

 
In the floating tool bar, click 
on Full Screen button.  

This will present the movie 
full screen.

 
To play the movie in full 
screen presentation mode, 
select the movie window, 
and press the COMMAND+M 
keys on the keyboard.

321

Stop Presenting a Movie in Full Screen

To stop presenting a movie in full screen press the ESC key on the keyboard.

Loop Instance Playback

Looping an instance repeats it continuously
1.	 In the floating movie controller, select the Loop button. 
2.	 Play the movie.

NOTE: When the looping feature is turned on, the timeline movie will loop also. If the timeline is zoomed in, it will loop 
within the zoomed range.

Adjust the Movie Volume

1.	 In the floating movie controller, click on the Volume control. Drag the control button to the 
desired volume.

2.	 Use the Function keys on the keyboard to increase or decrease volume.

Resize Movie Window

1.	  �Select the movie window.
2.	  �Choose Reduce movie size or Increase movie size from the Windows menu in the main menu 

bar, or use the shortcut keys, SHIFT+COMMAND+, or SHIFT+COMMAND+. .

Note: A timeline movie has 2 resize icons in the bottom left of the window. These can be clicked to change the movie size 
also. If CONTROL is held down when these are clicked, the timeline and movie will arrange automatically.
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Displaying the Movies on an External Monitor

When movies are not DV format, the only way to export full screen video to a recorder, burner, 
or projector/tv monitor is to use the video out port of the Apple computer. Plug in the external 
device using the DVI, Mini-DVI, or Video Out port on the computer. You may need to use a 
convertor cable to match the input of the external devices. With the hardware connected, 
follow these steps to enable the video to be exported.

1.Open the Display preferences in the System Preferences of the computer. Click on the blue 
apple in the upper left corner of the screen, choose System Preferences from the menu.

2.Click on the Displays icon in System Preferences.

3.In the Display preferences, click on the detect display button. This will export the desktop to 
the external device. The image will appear on the external device.

4.There are two ways to export using the display settings. The first is mirroring the desktop, 
so that what is on the main screen of the computer is presented. There is a check box in the 
display preferences that will turn mirroring off or on. The second is extended mode where 
a secondary monitor is available to use as another screen for video export. The secondary 
display position can be moved in relation to the primary screen in the display preferences.

5.If mirroring is enabled, the exact image on the computer will be displayed on the secondary 
monitor. This is a common way to set this up as users tend to lose the mouse on the secondary 
monitor and find it difficult to manage two monitors especially when they are not side by side. 
If extending the desktop to a secondary monitor is used, an instance movie when presented in 
full screen will be exported in full screen to that monitor. 

Using Instance Movies Chapter Markers

When an instance movie is created from multiple instances in a timeline, each instance in the 
instance movie is marked by a chapter marker. There are two ways to jump through the chapter 
markers.

1.	  �In the instance movie, press the TAB key to move forward to the next chapter marker. SHIFT+TAB 
moves backwards to the previous chapter 
marker.

2.	  �Click on the movie chapters list icon in the 
floating movie controller. A drop down list 
of chapter markings will appear. Click on 
the instance you want to view.

NOTE: A similar feature is in the timeline. Select a 
row of instances, press CONTROL+TAB to jump to the 
beginning of each instance. SHIFT+CONTROL+TAB will 
move to the previous instances.
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Instance Movie Timer

In every instance movie window, the time can be reset to zero at the playhead location, so time in 
the movie can be measured from any point.

1. Open an instance movie and move the playhead to some point 
of interest in the movie past the starting point.

2. Click on the time in the upper left corner. This will reset the time 
to zero and the font color will change to blue.

3. Drag the playhead or play the movie to measure a period of time 
past this new zero point. The time that presented in blue is the 
elapsed time from the new zero origin point.

4. Drag the playhead prior to the new time origin point and the 
font color will change to red indicating negative time or the 
playhead is located before the new origin.
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Viewing Labels In An Instance

Labels within an instance can be viewed in two ways :

1.	 Hover the mouse cursor over the instance in the timeline, the labels will appear in the strip 
above the playhead bar.

2.	 Open the Edit labels window by selecting “Instance labels”... from the Edit menu in the main 
menu bar. Click on an instance and the labels will appear in the Edit labels window.

Manipulating Movies

Closing Movie Windows

The most basic movie operation aside from opening a movie is closing one. To close a movie 
window, press the red button in its window bar. However, a more convenient way to close movies 
is to use the shortcut, COMMAND+I. This shortcut closes all open instance movies instantly. When 
analysing instances from the timeline, a lot of instance movies can be open at one time; clicking on 
the red button to close them all can take awhile. Using this shortcut, makes this a lot quicker. This 
function can be found under the Windows menu, Close all instance movies.

Movie Window Sizes and Proportions

One of the more basic manipulations of a movie is to change the size. SportsCode changes 
the size based on halves of the original movie size. The change a movie window size, press  
“COMMAND+SHIFT+ > “ on the keyboard to increase and “COMMAND+SHIFT+< “to decrease. The 
same function can be found under the Windows menu.

To reset the movie window to its native size, choose Windows > Natural movie size menu item.

Movie proportions can be changed by using the: Movie proportions 16x9, Movie proportions 4x3 
and Movie proportions - native. Using these features will either stretch or shrink the movie window 
according to the movies aspect ratio. It is usually very obvious when these settings should be used. If 
a movie’s aspect ratio is 16x9 and the movie window is set to 4x3, objects in the movie will appear to 
be thinner that they naturally might appear to the human eye in real life. If the movie’s aspect ratio is 
4x3 and the movie window is set to 16x9, objects will appear wider than they might actually appear 
in real life.
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Overlay Two Instance Movies 

Using the overlay feature you can take two 
instances and put them on top of each other 
to analyze the differences in the movies.

1.	 Create two separate instance movies.
2.	 Choose Overlay instance movies 

from the Windows menu in the 
main menu bar or press the shortcut 
OPTION+COMMAND+Y.

Align Two Overlaid Instance Movies

1.	 Create the overlaid movies as above.
2.	 Press the SHIFT+OPTION keys, click in the 

movie frame and drag the top movie to 
align the area of interest with that of the second (lower) movie.

3.	 When you play the movie the top and lower movies will stay in this aligned position.

Change Transparency Level of Movie Windows

Choose Reduce transparency or Increase transparency from the Windows menu in the main menu 
bar. Use the shortcut keys CONTROL+OPTION+9 or CONTROL+OPTION+0, by pressing these 
repeatedly you can vary levels.

Flip an Instance Movie

1.	 Create an instance movie.
2.	 Choose Flip movie horizontally from the Windows menu in the main menu bar. The movie frame 

will be flipped horizontally, so a left handed player appears as a right handed player would.
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Stacking Instance Movies

Two or more Instance movies can be stacked in various configurations in one movie window. The 
only limiting factors to how many movies can be stacked are the computer’s processing speed 
and screen size. Each camera angle in the stack movie can be moved around the stack. The stack 
configuration can be changed; 1x2, 2x2, 4x1, etc. Any camera angle in the stack can be zoomed but 
in doing so the other movies in the stack are hidden from view.

1.	 Open a Timeline with some coded Instances. Find three similar Instances to view and make 3 
separate Instance movies from each one.

2.	 Set the playhead on each movie to a point at which all three movies will be in sync. This might 
be one second prior to a particular motion or play.

3.	 With all the sync points set in each instance movie, press COMMAND+Y or choose “Stack 
Instance Movies” from the Windows menu in the Main Menu bar.

4.	 A stacked movie will open up with all three Instances in a 3x1 configuration.
5.	 To change the stack movie configuration, press CONTROL+COMMAND and click in the stack 

movie window. Select 1x3 or 3x1 from the pop up menu.
6.	 To move a camera angle location in the configuration, press down COMMAND and click and 

drag the angle to another location in the window.
7.	 To show or hide different angles of the stack, use the clapper icons. By clicking on a clapper icon 

it will hide the angle. If the clapper has an X through it, then it is already hidden, click on it again 
to show it.

To make viewing angles in the stack easier and avoiding constant rewinding of the movies, there are 
some playback features built in.

For an instance movie with chapter markers.
1.	 If the movie is playing and it is zoomed, the movie jumps back to the previous chapter marker.
2.	 If the movie is stopped and it is zoomed, the movie only changes views and does not jump.

For an instance movie without chapter markers or a timeline movie.
1.	 If the movie is playing and it is zoomed, the movie jumps back 10 seconds by default. This time 

can be adjusted in the movies preference panel.
2.	 If the movie is stopped and it is zoomed, the movie only changes views and does not jump.

NOTE: If you wish to use this feature, we recommend using the most powerful computer that is available. When stacking 
2 or more HD movies together, plan on using highly spec’d machine. Playing multiple movies simultaneously is very cpu 
and hard disk use intensive.
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Stacking Timeline Movies

Multiple timelines can be stacked to create a single timeline and linked stack movie. After capturing 
and coding multiple synchronous camera angles of an event, each timeline can be merged into a 
single stacked timeline.

Stacking timelines merges all the coded instances in the timelines that are being stacked. If the same 
rows exist in each timeline, the instances and rows will be merged into one in the new timeline.

Stacking timelines requires synchronous video. So, it is important that all captures are continuous 
through the whole event. Pausing and resuming capture will cause the movies to be out of sync. 
We recommend starting capture 1-2 minutes prior to the start of the event. It is also a good idea to 
capture audio.

Audio is a great way to find the synchronization point of a movie. If all cameras are not pointed at the 
same thing when the event starts, audio can provide solid clues to find a worthy sync point.

Stacking timelines is basically the same process as stacking instance movies.

1.	  �Close all windows except for the timeline and movie windows that are going to be stacked.

2.	  �Find the sync point in each timeline and position the playhead on each timeline to that point. 
It is a good idea to move the playhead back a couple of seconds by pressing OPTION+LEFT 
ARROW on each timeline after setting the sync point. This will give a little extra movie time prior 
to the first event that might need to be coded.

3.	  �Choose File > Stack timeline movies.

4.	  �Name the file and save it. Remember to check what type of package is being created when 
you save. Standalone, reference and compressed are all options. We recommend creating a 
reference package first, so the results can be checked quickly. Do not delete the original movies 
until you have saved it as a stand alone package.

When saving standalone packages, check the file size, stacked timelines can create some very large 
files.

Show / Hide Stacked Movie View Angles

Once you have chosen movies stacked in your preferred configuration, you may choose to hide or 
show selected views.

The baseline of the stack viewer will contain clapperboard and speaker icons (1 per stack view). Click 
on an icon to hide it (an X will be superimposed over the icon to indicate that it has been hidden) 
and click on the “X” of an icon to show that stack view
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Stack Switch Hotkeys

Stack Switch Hotkeys can be configured so the zooming can be done by pressing keys on the 
keyboard.

1.	 Access the Preferences for Stack Switch Hotkeys in the Movies panel of the SportsCode 
Preference. Choose SportsCode > Preferences, then press the Movies Icon In The Toolbar

2.	 Tick the Stack Switch hotkeys “Enabled” tick box to turn the feature on, then set the Hotkeys for 
the switching.

There are 12 possible views available for zooming using Hotkeys.
•	 Click in the empty buttons to the right of the Movie numbers. Then press a key on the keyboard 

to set the Hotkey.

When a stack movie is open and a Stack Switch Hotkey is pressed the view will zoom. To unzoom 

back to the stack view, press the Hotkey again. This can also be done by clicking on the grid icon in 
the top of the movie. The movie views are numbered from left to right, top down in the grid. 

Changing Stack movie view locations in the grid

Hold down COMMAND while clicking and dragging on the view. Drop the view in the approximate 
location of the grid to relocate.
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Changing Stack movie grid layout.

Hold down CTRL+COMMAND and click on the Stack movie. Choose the grid layout from the popup 
menu. If using a right click mouse, hold down COMMAND, then right click on the stack movie and 
choose the grid layout from the popup menu.

Stack movie Playback Preferences.

Refer to the Movie Preference Window section on page 7.

For an Instance movie without Chapter Markers or a Timeline movie.

Note: In the case of an Instance movie, this will be a movie made of a single instance only.

If the movie is playing and it is zoomed in or out, the playhead will jump back by the number of 
seconds which have been specified in the “Lead time for stack switch in timeline movie” panel 
•	 If the movie is stopped and it is zoomed in or out, the movie only changes view and the 

playhead does not jump back 10 seconds.

For an Instance movie with Chapter Markers in a Stacked Movie View.
•	 If the movie is playing and it is  selected. It will expand the view (zoom in) if the view is of all the 

movies in the stack. It will contract the view (zoom out), if the view is of an expanded view in the 
stack.  If the “Jump to start of marker after instance movie stack switch” is ticked, the movie 
time will jump to the previous chapter marker at that beginning of the chapter for both of the 
view options described above.

•	 If the movie is stopped and it is selected, (for both an expanded or contracted view), the movie 
only changes view and does not jump to a chapter marker.

Making a Movie from a Folder of Movies

SportsCode captures in a series of movie segments, each segment contains a number in the 
file name: 00001, 00002, 00003, etc. This sequential numbering scheme is also used by tapeless 
video cameras. So, to make generating a single movie from a series of sequentially named 
movie files easy, the Make movie from a folder of movies can be used.

Place all the movie files in the same folder, the choose File > Make movie from a folder of 
movies and select the folder. A reference movie will be created with all the segments together 
in sequence according to the number in their file name. Save the movie as a standalone or 
convert it to another format.

This feature is handy if a movie package has been corrupted or when capture has ended 
unexpeditely. The movie parts can be quickly put back together to create a continuous movie.
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Editing Instance Movies

Instance movies can be edited using delete, cut, copy and paste or drag & drop features. By selecting 
a segment of an instance movie, the segment can be deleted or copied and pasted into another 
instance movie. NOTE: Editing instance movies does not edit the timeline.

Delete a Segment in an Instance Movie.

1.	 Select a segment in the instance by holding SHIFT and clicking your cursor in the instance 
movie timeline at the base of the movie viewer. A RED selected portion will be drawn from 
the point of clicking to the end of the instance. Then click and drag either end of the RED 
portion to fine tune your selected portion. Press COMMAND + X. 

Copy, Cut and Paste Instance Movie Segments

When an instance movie is created from a timeline, the entire length of the movie is selected by 
default. If you move the playhead in the instance movie, you will lose the selection. To reselect the 
whole instance, move the playhead to the beginning, hold down SHIFT, and drag the playhead the 
entire length of the instance movie.

1.	 Open two instance movies from a timeline.
2.	 In the second instance movie, press CONTROL+COMMAND+C. This will copy the selection in 

the instance movie. If the playhead was not moved, it will copy the entire length of the instance 
movie. If it was moved, it will only copy the frame that is currently being displayed.

3.	 In the first instance movie, move the playhead to the end and press  CONTROL+COMMAND+V. 
This will paste the second instance movie segment at the end of the first instance movie.

4.	 Repeat this process to continue adding segments to the end of the instance movie.
Note: Segments can be pasted into any part of an instance movie. Position the playhead where you want the segment to 
be inserted and when you copy and paste, it will be inserted at that point. You may also action the above from the Edit 
Menu in the Main Menu Bar.

Drag and Drop Instance Movie Segments

Open two instance movies from a timeline.

In the instance movie you wish to copy the segment to, position the playhead at the start point of 
where you wish to drop the selected segment.

In the instance movie you wish to copy the segment from, position the playhead at the point you 
wish to start and then hold down the SHIFT key and drag the playhead to the end point of your 
segment selection. Your selected segment will be coloured red in the time elapsed bar at the base of 
the window.

Hold down the OPTION key,  click on the movie then drag the movie onto the movie you wish to add 
the segment to and drop it. The selected segment will be inserted at the point you dropped it.
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Combining Instance Movies

A simple way to combine instances in a specific order is to use the Combine instance movie feature. 
This feature creates a new instance movie from all open instance movies in the order that they are 
layered on the screen.

1.	 Open 2 or more instance movies in reverse order for which you want them combined. Create 
the second instance first, then the first one. This will layer them correctly without having to click 
on the movie windows to layer them.

2.	 Choose Windows > Combine instance movies in main menu bar. A third movie window will 
open that will have both instances in the movie in the order that they were layered on the 
screen.

NOTE: To add another instance to the beginning or end of the new combined movie, close the first 2 instance movies 
used to create the newly combined one. Do not close the newly combined instance movie. Open another instance from 
the timeline, layer it in front or behind the open combined instance movie, then choose Combine instance movies. If the 
new instance was in front of the combined one, it will be added to the beginning, if it was behind, it will be added to the 
end. Repeat this process to assemble a full length movie for presentation.

Saving Instance Movies

Any instance movie can be saved as a file for presentation, archive, or distribution purposes. So, after 
editing a movie, you can save your work.�

1.	 Click on the movie that you want to save so 
that it is the front most window. When saving, 
the front most window will be selected by the 
software as the window to save.

2.	 Choose Save from the File menu in the 
main menu bar. Alternatively, you can press 
COMMAND+S.

3.	 Select the target save location and name the file.
4.	 Set the required movie format from the bottom of the save window.

5.	 Click the Save button.

SportsCode stand-alone or MoviePlayer stand alone movie formats create files that contain 
all the necessary data to view the movie independent of the original movie file. Since stand alone 
movies contain all the necessary data to be played on its own, they tend to be large files. Stand 
alone files are required when you wish to share the movie with other people on their computers.

SportsCode or MoviePlayer reference to original movie formats create reference files that point 
to original movies. Reference movies are very small in size and save very fast as they do not contain 
any raw video data and thus do not duplicate video data. However, the file must have access to it’s 
original raw movies from which it was created. If you delete the original movie, a reference movie 
will not play. Use reference movies to quickly assemble an edit, then save it as a stand alone when 
you are done.
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Removing Extra Movie Tracks

There are many types of tracks inside a movie file besides video and audio. SportsCode uses 
text tracks to display transcription text in the movie window. There are situations where this 
data needs to be removed from the movie. To do this, open the movie and choose Edit > 
Remove tracks except video and audio. All tracks not video or audio will be removed from the 
movie. Save the movie after completing this operation. This cannot be undone, be careful if 
the data is important such as subtitles.

Removing extra tracks can help some third party applications open SportsCode movies files 
and the vice versa is true for SportsCode. So, if the movie has text appearing in unexpected 
places, use the feature to clean up the movie tracks.

Multiplying Audio

If the sound track for a movie is too low or high, it is possible to increase or decrease the 
track’s volume. Open the movie that needs the sound track changed, then choose Edit > 
Multiply audio. A dialog will open where the percentage increase or decrease change can be 
set. Setting a value above 100% will increase the volume, values below 100% will reduce the 
volume. Press OK to commit the new setting and save the movie.

Drag & Drop Reference Movie Creation

By clicking and dragging on a timeline, instance, or edit instance movie window, a reference 
movie can be created. The name of the reference movie is now “Movie YYYY-MM-DD HH-MM-
SS.HH.mov”. This naming makes it very handy for sorting especially if items are put in a folder 
and things are added at a later date. IMPORTANT NOTE: If the movies are to be used in iMovie 
or other post production applications, you must hold down OPTION when doing the drag and 
drop. This strips extra movie tracks that SportsCode uses for time, coded data for overlay and 
instance notes plus drawings.
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Working with Code Rows

Move a Row

Click and drag from the row number in the timeline.

Select Multiple Rows

1.	 Press COMMAND and click on the row numbers you want to select.
2.	 To select a range of rows, select the top row of the desired range, then select the bottom row 

while holding down SHIFT.

Duplicate a Row

1.	  �Press CONTROL and click (RIGHT CLICK) on the row number you want to 
duplicate.

2.	  Select Duplicate selected rows from the drop down menu.

Delete a Row

1.	 Press CONTROL and click (RIGHT CLICK) on the row number  you want to delete.
2.	  Select Delete selected rows from the drop down menu.

Edit Code Row Names

1.	 Press CONTROL and click (RIGHT CLICK) on the row number  you want to edit.
2.	 Select Edit row from the drop down menu. This opens the row properties strip.
3.	 Type in the new name in the text area. 

Change Code Row Colors

1.	 Press CONTROL and click (RIGHT CLICK) on the row number you want to edit, or for multiple 
rows, press Command + Click on each row to highlight them, then press Control + Click (RIGHT 
CLICK) on one of those rows.

2.	 Select Edit row from the drop down menu.
3.	 Click on the color chip to the left of the row name.
4.	 Drag into the color palette and choose a new color..

Change Multiple Row Colors At The Same Time
Timeline row color can be changed for multiple rows by 
selecting a group of rows and selecting a colour from the colour palette.

1.	 Command + Click on several different rows to highlight them
2.	 Control + Click on one of those rows
3.	 Click on the color palette and select a color
4.	 All selected rows change to that color
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Add a New Blank Row to a Timeline

� Choose Rows > Add row from the main menu bar. The new row will 
be created below the selected row in the timeline. Alternatively, you 
can press the New row icon in the timeline tool bar or press 
COMMAND+N.

Create a New Row from Selected Instances using New Merged Row

� Select the instances that you wish to include in a new row, press COMMAND and select the 
instances one by one or click and drag in the timeline to select a group of instances. You 
can also select rows of instances too. With the instances selected, click on the New merged 
row icon in the timeline tool bar. Hold down the option key and click ‘New merged row’ to 

create a row with instances without merging.  If there are too many instances overlapping in a 
collection of instances, then merging may still occur for this collection. Generally, where 2 instances 
overlap the instance end and instance beginning points will be midway between the beginning and 
end points of the overlap.

Create a Combination of Rows

1.	  �Choose Rows > Create new row from the main 
menu bar. This opens the Add row window 
where you can select 2 rows to create a new one 
using different time intersection options.

2.	  �Name the new row and select where in the 
timeline to insert it.

3.	  �Click the Combine rows radio button to form 
new row.

4.	  �In row A, choose the first row you want to use.
5.	  �Choose the operation that will apply to the 

combination of rows. The type of operation is 
illustrated in the box at the left of the window.

6.	 In row B, choose the second row you want to use and click the Create row button.

AND, OR, or NOT can be used as operators. AND 
will create instances where A and B overlap. OR will 
create instances from both rows combining where 
overlaps occur. NOT creates instances where A does 
not exist.

Create New Row Hints

1.	  For fast alternating possession sports, code one team’s possessions, then use the NOT 
operator, to create the other team’s possession row.

2.	  When you want to use more than two rows, create a new row from the first 2 rows, then 
create another row from that row using it as row A and the third row as row B. Repeat this 
again and again to drill down further.
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Code Button Colors and Sorting

A great way to make organizing the timeline a quick job is to consider your button colors and 
how they will affect sorting. Use colors with the X coordinates from 1-30 and same Y coordinates 
for similar code buttons categories. Then, use descending Y coordinates from 1-20 for grouping 
different categories. The code window will look like a rainbow, but you can quickly sort the 
timeline using the Sort rows by color feature. So, player action buttons might range from (1,16) 
to (30,16) and team action buttons might range from (1,7) to (30,7). In this example, the player 
actions will sort to the top of the timeline and the team actions will sort below them.

Sorting Code Rows

Rows can be sorted in a variety of ways, manual dragging up and down being the most common. 
However, using name and color can automate the process and make organizing the timeline a lot 
quicker.

Sort Rows by Name

Choose Rows > Sort rows by name from the main menu bar. All rows 
will sort by alphabetical order.

Sort Rows by Color

Choose Rows > Sort rows by color from the main menu bar. Colors are sorted in order of the palette 
from left to right descending from lighter to darker. The color palette has 600 colors and each color 
has an (X,Y) coordinate. White in the upper left most corner (1,20) and the darkest red in the lower 
right most corner (30,1) define the sorting pattern from left to right, top to bottom.

Sort Rows by Color then by Name

Choose Rows > Sort rows by color then by name from the main menu bar. All rows will sort by color 
and then within each color sort by name.

Sort Rows by Number of Instances

Choose Rows > Sort rows by number of instances from the main menu bar. All rows will sort 
according to how many instances are in each row. The row with the most amount of instances will 
move to the first row. The row with the second most amount of instances will move to the second 
row and so on.

Sort Rows in Reverse Order

Choose Rows > Sort rows in reverse order from the main menu bar. All rows will arrange in reverse 
order from top to bottom to bottom to top.



Part 4 - SportsCode Review/Analysis

123

Editing Instances in the Timeline
Manually Creating a New Instance

1.	 Highlight a row by clicking on the code row name or row number. ( If there are no code rows, 
you will need to create a new row. See the section on page 121  “Add a New Blank Row to 
a Timeline” )

2.	 Position the playhead at the point in the timeline where you want the instance to start or end.
3.	 Press down OPTION+COMMAND and drag the playhead in the timeline to the required end or 

starting point.

Note: Using a 2 button mouse, you can hold down OPTION+COMMAND+RIGHT CLICK and drag in any row 
to create an instance. Pressing CONTROL and clicking activates the right mouse click. So, you can press 
CONTROL+OPTION+COMMAND and click & drag in any row to create an instance too.

Adjust the Length of an Instance 

Click and Drag

Press OPTION+COMMAND, position the mouse cursor over the beginning or 
ending of an instance. When the cursor changes to arrows pointing  to the 
left & right, click and drag the instance to the required length.

1

Instance Edit
1.	  Select an instance in the timeline.
2.	  Choose Edit > Instance edit from the main menu bar or press 

CONTROL+E. A movie window will open with left & right arrows 
in each of its upper corners.

3.	  Press the arrows in the direction required to lengthen or 
shorten the clip. The upper left arrows will adjust the start of 
the instance and the upper right arrows will adjust the end. The 
Trim feature can be used by pressing CTRL+T ,see below.

4.	 CTRL+I will set the start time for the selected instance according 
to the location of the playhead in the edit instance movie window.

5.	 CTRL+O will set the end time for the selected instance according to the location of the 
playhead in the edit instance movie window.

6.	 CTRL+T will set either the start time or the end time according to the location of the 
playhead. If the playhead is before the midpoint of the clip, pressing CTRL+T will set the start 
time. If the playhead is after the midpoint of the clip, pressing CTRL+T will set the end time.

7.	 SHIFT+CTRL+I will subtract 0.5 seconds from the start time of the instance. (Subtracting 
makes the start time earlier, thus making the instance longer)

8.	 SHIFT+CTRL+O will add 0.5 seconds to the end time of the instance, making the instance longer.
9.	 SHIFT+CTRL+T will subtract 0.5 seconds from the start time if the playhead is closer to the 

start of the instance. If the playhead is closer to the end time, 0.5 seconds will be added to 
the end time.

2
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Trim

The trim feature can be used to quickly adjust start and end times for a row of existing instances. 
It is a sequential process: trim start > end > start > end > start and so on. The process starts by 
setting the first point, if the playhead is set before the midpoint of the instance, it will begin by 
adjusting the start time to the playhead location. When it is set beyond the midpoint it will adjust 
the end time. Once the adjustment is made, it will jump to the end time of the selected instance 
or the start of the next instance.

1.	  �Highlight the instance and position the playhead to the required start time of the instance, 
not beyond the midpoint or the end point will be trimmed.

2.	  �Press CONTROL+T, the start time will be adjusted and the playhead will jump to the end 
time of the instance.

3.	  �Position the playhead to where the adjustment of the end point should be made and  press 
CONTROL +T. The playhead will jump to the next instance in the row.

4.	  �Position the playhead for the new start time and press CONTROL+T. The playhead will jump 
to the end of the instance. Repeat, until all adjustments are made.

3

Instance Adjustments

1.	  �Select an instance or range of instances by clicking 
and dragging over the instances in the timeline.

2.	  �Select Edit > Instance adjustments... from the main 
menu bar.

3.	  �Input the time in seconds for the amount to be adjusted. 
4.	  �Select whether the time will be added or subtracted from 

the instance marks.
5.	  �Check the mark in or mark out check boxes to apply the adjustments to one or both.
6.	  �Click the adjust button.

Note: If you make a mistake, simply make the opposite adjustment. If you added 3 seconds to the mark in time of an 
instance, change the add to a subtract and adjust it back. Adjustments can be made up to hundredths of seconds, so 
this can make some very finite adjustments to an instance, hardly possible with a mouse.

4

Delete an Instance

Highlight the instance by clicking on it, then press the DELETE key.

Copy an Instance from One Row to Another

1.	  Press OPTION and click & drag on the instance you want to copy.
2.	  Drag it to the new row.
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Move  an Instance from One Row to Another

1.	  Press OPTION and click & drag on the instance you want to copy.
2.	  Drag it to the new row.
Delete the original instance by selecting it and pressing the DELETE key.

Instance Splitting

An instance in the timeline can split at the playhead intersection by dragging the playhead to the 
point that the instance should be split into two, then choosing Edit > Instance split

Create a New Timeline from Selected Instances

Select instances, then click the “New Timeline” icon in the toolbar, this creates a timeline with only 
the selected instances. The user can then save this timeline back into the original package. Next time 
the package is opened the user will get a dialogue box asking which timeline they want to open

This is a great way to minimise the amount coding that different users see, particularly useful with 
OPTA/Champion imports with lots of rows of information

Combining Timelines

Two or more timelines can be combined back to back, so analysis over multiple movies can be 
performed very quickly. The combine timeline process creates a reference package. A reference 
package takes up very little space, but remember do not delete the original movies until the project 
is finished or saved as a stand alone package. �

1.	 Choose Combine timeline movies from the 
File menu in the main menu bar.

2.	 Locate the timelines you want to combine.
3.	 Select and add each one in the order you 

want them to appear into the new timeline.
4.	 With all the timelines added, press the 

Combine button.
5.	 Name the file and save.
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Merging Timelines

There are cases where multiple users have coded the same movie and they must be merged 
together to either compare the results of the coding or combine the results of the coding into one 
timeline. To do this, use the merge timeline window feature. The key to using this feature is the 
coding should be done using the same video of an event or possibly another video angle of the 
same event. This way the codes will synchronize with the video correctly.

Here are steps to merge 2 timelines, however many timelines can be merged at once also.

1.	 Open 2 timelines that are linked to the same movie or copy of the same movie.

2.	 Select the rows to be merged in each timeline. Individual instances can also be selected, if there 
are instances that should not be included in the merged timeline.

3.	 Choose File > Merge timeline windows
4.	 A new timeline will appear with the merged rows of instances. This timeline will not be linked 

to a movie.

5.	 Choose File > Link movie to timeline window... and select the movie that the original timelines 
were linked to. The timeline should be saved either next to movie package that it is linked to or 
be saved inside the movie package.

Databasing Instances

Databasing provides an easy method to group specific coded instances into one timeline. 
SportsCode creates stand alone databases that hold all the code information and video data for each 
instance that is exported to it. Databases are a great way to keep only the information that you code. 
A neat way to use databases is to create one for each player, as a season progresses, highlights can 
be exported into their personal database. By the end of the season, each player has a highlight reel 
already made and ready for a dvd.

1.	 �Create a new empty database by choosing Database from the File > New menu in the main 
menu bar.

2.	 �Name the database and save it.
3.	 �Open a timeline with the instances you want to export. Select all the instances to be 

exported, then press the database button in the timeline tool bar. 

4.	 �Target the database to export to, and hit the Export to button.
5.	 �Open a second timeline, select instances, and export them into the same database. These 

instances will append to the database. Continue this process until complete.
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The Find Window

The Find Window provides the capacity to search for metadata in any open window, a folder on 
the hard drive containing SportsCode files or across a network to a shared location. When used 
effectively the Find Window will save countless amounts of time particularly in transcription and 
statistical scripting plus improve the analysis process when creating video based reports across 
extensive longitudinal data.

Find can be accessed by clicking on the Find button in the timeline toolbar or choosing Edit > Find 
in the main menu bar. 

Quick Label Searches

The most basic type of search is the Quick label search, just type in the label to be searched for and 
hit RETURN on the keyboard. This quick label search is conducted on all open timelines. The results 
of this search are displayed as a number in the yellow button to the right of the text that you have 
just typed in. Clicking on the yellow button will make a movie of the found instances. This is the 
quickest way of searching for a particular label.
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Advanced Search

There are 3 search modes in the Find window: Instances, Text, and Find and Replace. These modes 
apply to specfic file types. Instances mode is designed to search for codes, labels, and transcription 
text in timelines, sorter windows or movie organisers.  Text mode is designed to search through 
transcription and statistical windows. And Find and Replace works across all file types.

The Find window will open in Instances mode by default. This will likely be the most common mode 
used. Instances and Text modes work very similar in the way in which the search criteria is setup. 
Find and Replace work with direct text input while allowing specific windows to run against to be 
toggled on or off.

The following sub-sections will cover using the Find window in Instances mode. Following sub-
sections will specifically describe the alternate features in the other modes.

Where to search

The Find window can be targeted to search in specific windows or groups of windows. The search 
area target by default is the front window. This means the timeline, sorter window or movie 
organiser that is the top window, no other windows will be searched. Using the all open windows, 
will target  all open windows and return anything found in these windows. The front timeline and all 
open timelines options will only search in timeline windows specfically.

When selecting all timelines in folder, the target folder that contains the timelines must be set. Click 
on the following drop down option to choose the folder 

The ability to search across particular folders is incredibly powerful for analysis as it makes 
conducting longitudinal queries very easy.
Note: When searching across all timelines in a folder, the timelines are then opened behind the Find 
window based upon your search results. This search option can take a long time if there are hundreds of 
timelines to search.
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Establishing Search Criteria

Once the search target has been determined the next step is establish the search criteria
Establishing searching criteria for a label is created using the following steps:

1. Select Any, All or None from the drop down menu. If “Any” is chosen, each  row with criteria set will 
return the found instances. When “All” is chosen, only instances that meet all rows of criteria 
combined will be returned. “None” will return any instances that do not match the criteria.

2. The first choice in setting the criteria is the data type. The data types that can be searched are 
Text Notes, Labels or Codes. In the first drop down menu select Label to start to establish the initial 
criteria.

3. Establish the operator of the search criteria by selecting from the following drop down menu. As it 
relates to labels, these options mean:

Is will return labels that contain the exact characters inputted in the search string.

Is not will return labels that do not contain the exact characters inputted in the search string.
Contains will return the labels that have the search string in their names.
Does not contain will return labels that do not have the search string in their names.
Begins with will return labels that have the search string in the beginning of their name.
Ends with will return labels that have the search string in the ending of their name.  

4. Input a search string. This is usually the label name or part of the label name. A string is made up 
of any amount of characters including puncuation and other character types.

5. Establish the last element in the search criteria row by selecting from the following drop down 
menu. “grouping” refers to a group of labels as defined in the Labels Tree. ( Refer to page 56) 

Note: Grouping only applies to labels. Further criteria can be 
subtracted, added, or nested by using the  buttons, respectively, to 
the right of the criteria row. 
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6.The last item to set is in the Search Options section below the rows of the criteria. These options 
apply to all search strings that was inputted in the rows of criteria.

Ignore case will ignore capitalization. So, Bob will be considered the same as bob.

Ignore white space will ignore spaces between characters. So, Bob Jumped will be same as 
BobJumped.

Use wildcards, this is a method of pattern seaching. If there were a certain amount of label names 
that started with B, an asterisk could be used to find these by using B* as the search string.

Trim whitespace will ignore spaces after names. This is helpful if names were inputted strangely.

Only search selected categories will search only selected code rows in a timeline.

7. With the criteria in place, press the Search button  in the Find window toolbar. If any 
instances are found, the results will be displayed in the lower portion of the window with a count of 
the found instances at the very bottom of the window. Click on the disclosure triangle to reveal all 
the found instances.

Making Movies From Found Instances

After a successful search, the results can be made into movies by selecting the Make Movie icon  or 
by double clicking in the search results list that is displayed. 

Databasing Found Instances
Searches results can be databased by selecting the instances in the results and clicking on the 
database icon found in the toolbar.

Send Instances directly to the Movie Organiser or Sorter Window
Click on the relevant icon button in the toolbar to send found Instances directly to the Movie 
Organiser or Sorter Window.
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Text Mode

Using text mode is very similar in its way of building up the search criteria to that of instances mode. 
However, text mode is designed to be used with transcription, statistical windows and label trees, so 
there are a few different options.

The first difference is the search target, only the front window or all open windows can be searched. 
This mode will not search a folder of files like instance mode.

The second difference is the data type options; Cell text, Cell script and Column title. These are the 
only types of data that can be searched for in this mode. Cell text will look for text that is contained 
a cell; this could be transcription or statistical output. Cell script will search the script that is attached 
to the cell. And Column title will search only in a given column name.

The last difference and most powerful aspect of text mode are the search options.

Like the instance mode; Ignore case, Ignore whitespace, Trim whitespace and Use wildcards are 
available. These are the heavy lifters for searching transcriptions particularly wildcards. Use the 
asterisk following or preceding a search string to find rows that might contain the data being hunted.

But, the real power of the text mode is the Generate results feature. By clicking the Generate results 
button, a window with the results will be generated. This work great for pulling out specific rows into 
a new window. To help keep transcription in context, rows before and after can be set to be included 
in the generate window. The proceeding and/or following rows will be included in the new window. 
It is often important in transcription analysis to find out what said before or after an utterance to 
better understand its meaning.

When simply finding text in a transcription window, any found text will be highlighted in the 
window using the color chosen in the color well, default is red. Options to Bold or Underline are also 
available.

To clean up the found text items, click on the Clear now button. All highlighted text will become 
unhighlighted. The Auto clear option can be ticked which will clean up previously found strings of 
text. Or, auto clear can be unticked and using the color well, multiple strings can be found and 
highlighted in different colors.
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Find And Replace

The find and replace mode works as most find and replace features work in any word processing 
software. A string of text is chosen to find, then another is chosen to replace the found text. This 
window can help to replace misspelled text, change button names in the code window or change 
scripts in the statistical window. It covers all windows.

When making replacments to text, it is very important to be careful. Make sure to validate what is 
being replaced before it is replaced. We recommend following this usage pattern: Add the string to 
be searched for in the Find text input box, click on the search button in the toolbar and check the 
results in the bottom of the window, then click on the replace button.
Note: Sometimes a replacement is made and it is impossible to go back. For instance, if “this” is changed 
to “that”, it cannot be changed back because all the existing “that”’s this will be changed to “this”’s.

The find and replacement strings can be swapped around by clicking on the  button. Again, 
be careful doing this as a lot more items could be changed than were originally intended.

It is very easy to replace something in the wrong window, so it is also suggested to choose the exact 
window and data type in the search options. Untick or tick the specific items.
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Recent and Saved Searches

While searching timelines and other windows, every time a search is done, the criteria is saved in the 
Searches column on the left of the window. Any search can be easily referenced by clicking on the 
date-time row in Recent Searches section.

Note: If the list is not in view, click on the disclosure triangle to the left of the Recent Searches text.

When the date-time row is clicked on, the criteria will be loaded and the search can be done again. 
This does not load previously found data, only the criteria used in the search. This can be saved by 
clicking on the save button at the end of the Search mode selection row, the criteria will then be 
saved in the Saved Searches list. The saved search will be given a default name of Saved Search. To 
rename the search, double click on the name and input the new name.

Search criteria can be saved directly to be used again in the future. This is especially helpful when 
creating complicated searches. By clicking on the save button at the end of the Search mode 
selection row, the criteria will be saved in the Saved Searches list. Just as stated above, the saved 
search will be given a default name of Saved Search. To rename the search, double click on the name 
and input the new name.

A saved search is saved in the “in the search mode” context. So, when a “find and replace” search is 
saved, and when it is selected in the Saved Searches list, the mode will be switched to find and 
replace. The mode is represented by the saved or recent icon;  icon is Instance mode,  icon is 
Text mode and  icon is Find and Replace mode.
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Code Matrix

IMPORTANT : Refer to the Preferences Section on Page 15 of this manual for your preferred 
settings for this function. It is important that your settings are correctly configured if this 
function is to deliver optimum results.

The code matrix is a two dimensional grid representation of code rows and labels in a timeline. The 
rows in a matrix are generated from the rows in a timeline. The columns are the labels that are coded 
in the instances of the rows. The cells of the matrix display the instances that have the label coded 
in them. The intersection cells count the number of instances that have the labels coded in them. By 
default, the matrix is an instance counter, not a label counter.

Using The Code Matrix

1.	 �Click on the Matrix button in a timeline or code window. A Matrix of the Timeline will 
open.

2.	  �Double click on the row name to create a movie for all instances in the row.

3.	  �Double click on the column name to create a movie for all instances with the label.

4.	  �Double click on a cell to make a movie of the intersection of the instance and label.

�The cumulative totals of columns and rows can also be highlighted and viewed. These totals 
represent the total instances in the timeline from which the matrix was generated. Double click on 
these totals to make a movie.

NOTE: When a row name, label, cell or total is clicked on, the instances are selected in the timeline. The matrix can be 
used to select instances to paste into a movie organizer or sorter window.
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The Code Matrix Toolbar

Adding Columns and Rows

After removing a column or row, you may want to add it again. 

Removing Columns and Rows

Any row or column can be removed from the matrix view by selecting it and pressing the 
remove button.

Swapping Axis

The matrix view can be swapped, so the columns and rows switch axis. By default labels 
are displayed in the columns and timeline rows in the rows of the matrix.  By clicking 
on the Swap Axis button in the matrix tool bar, the labels will become the rows of the 
matrix and the timeline rows will become the columns.

Sorting Columns and Rows

Click on the Sort button to sort columns and rows by labels, groups or rows.

Movie

Click on this button to make a movie of selected instances .... either by highlighting a 
column or row or by selecting specific instances.

Export

Export the Matrix as an Excel document or a tab-delimited text file.

Share

Export the Matrix for the web.
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Print The Code Matrix

Click the icon to print the matrix. Add a title to the matrix by editing the text box to the 
right of the print button.

Timeline

This displays the name(s) of all Timelines which are open. Click on a 
Timeline name to link it to the open Matrix template

New Timeline

Select instances, then click the “New Timeline” icon in the toolbar, this creates a new 
timeline with only the selected instances.

Load
 

Load a saved matrix from the default Matrix folder or from a  folder into the current Matrix 
window, then select a Timeline from the open Timelines list.

Organiser

Click this button to send your instance selection direct from the Matrix to the 
frontmost Movie Organiser window open

Sorter

Click this button to send your instance selection direct from the Matrix to the frontmost 
Sorter window open.

Dynamic Code Matrix Hot Tips

Use the dynamic code matrix to compare two time ranges in a timeline. For example the first 10 
minutes versus the last 10 minutes of play.

1.	  �Set the dynamic matrix ranges to the first 10 minutes of play.
2.	  �The data in the dynamic matrix can be copied and pasted into an Excel spreadsheet. See 

the Copy The Code Matrix as Table explanation.
3.	  �Set the ranges for the last 10 minutes of play and repeat the above procedure.

NOTE: To highlight the associated Instances within the timeline, hold down OPTION and click on the matrix. The 
Instances that fall in the time range in the matrix will now be selected in the timeline.
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Database

Click this button to send your instance selection direct from the Matrix to your 
nominated Database file.

Customize a Matrix

The code matrix can be easily customized to display specific in depth analysis. Rows and columns 
can be deleted or added, labels can be put together using boolean operators: and, or, or not. After 
customizing and saving a code matrix it will be linked to the Timeline it was created from. It can be 
opened at another time to use to analyze another timeline or it may be selected directly and recalled 
from the  Matrix icon in the toolbar of the Timeline it was created from.
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Matrix Settings

The matrix has 3 settings. These settings are accessed by clicking on the Settings button in 
the matrix tool bar.

Title

The Title text setting is used when the matrix is printed. This will be the title on the printed 
document.

Count labels inside of instances

By default, the matrix displays a count of the instances that contain a label or combination of labels. 
It does not count the amount of labels found in the instances. For example, if an instance contains 
2 duplicate labels, the matrix will return a count of one. Occasionally for statistical reasons, it is 
interesting to count the amount of duplicate labels contained within an instance. Counting the 
labels contained within an instance is done by ticking the “Count labels inside of instances”. This will 
count duplicate labels. So, using the example above, the matrix will now report a count of two.

Add new labels and rows matrix

By ticking this option, the matrix will dynamically add new rows and columns on the fly during the 
coding process. This is an important feature during live coding/capture as the matrix can be used to 
quickly provide counts and video. This process is also important for using the matrix web exports. 
The web export picks up the changes in the matrix and exports the movies automatically. If this is 
not ticked, new instances will not be exported.

Keep existing labels and rows

Choosing this option will keep the matrix codes and labels static. If “Add new labels and code to 
matrix” is selected, the new labels and codes will be added to the existing rows and columns.



Part 4 - SportsCode Review/Analysis

140

Replace rows from selected Timeline

When this option is selected and a new timeline is loaded in the matrix, the new timeline’s code rows 
will replace the existing ones. This is similar to the matrix organizer behavior in previous versions.

Replace Labels and Code from selected Timeline

This option will empty the matrix completely and use the newly loaded timeline data. A very rarely 
used option, but there if needed.



Part 4 - SportsCode Review/Analysis

141

Dynamic Code Matrix

The Code Matrix can be set to display data within specified time ranges.

Drag the markers in the bottom of matrix window to the required time range. Set the left marker to 
the starting time, then drag the right marker to set the end time. 

The Matrix will now display only the data found within the specified time range.
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Organizing the Matrix

The code matrix can be easily customized to display specific in depth analysis. Rows and columns 
can be deleted or added, labels can be put together using boolean operators: and, or, or not. After 
customizing a code matrix, it can be saved and opened at another time to use on another timeline.

Organizing Rows and Columns

Move rows or columns by clicking on the name and dragging to a new location. Standard cut, copy 
and paste functions can be used, so you can select a column, press COMMAND+X to cut, select the 
column to paste after, then press COMMAND+V to paste.

Swapping Axis

The matrix view can be swapped, so the columns and rows switch axis. By default labels 
are displayed in the columns and timeline rows in the rows of the matrix.  By clicking on 
the Swap Axis button in the matrix tool bar, the labels will become the rows of the matrix 
and the timeline rows will become the columns.

Sorting Columns and Rows

Columns and rows can be sorted by ascending and descending names. Click on the 
Sort button in the matrix toolbar and select to sort by labels, groups or rows. Choosing 
ascending will sort alphabetically A to Z, descending will sort Z to A. Since rows have 
color, they can be sorted by color ascending and descending as well. See the Sort Code 
Rows section of this manual for an explanation of how the color sorting works.

Removing Columns and Rows

Any row or column can be removed from the matrix view by selecting it and pressing the 
remove button on the matrix toolbar or pressing the DELETE key on the keyboard. The 
row or column can also be removed be right clicking on the name of the row or column 
and selecting remove from the drop down menu.

Adding Columns and Rows

After removing a column or row, you may want to add it again. Add a  label by doing 
the following:

•	 Deselect all columns and rows by clicking in a cell or in an empty area around 
the matrix.

•	 Click on the Add button in the matrix toolbar, this will reveal a menu to select 
the label or row to add.

•	 Select the column or row to add. It will be added at the end of the columns or 
rows.

Note: If a column is selected when you are adding, a combination will result, see the “Combining Labels” section on    
page 141
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Duplicating Columns

Columns can be duplicated by holding down OPTION and clicking and dragging on the column 
name, then drop into desired position. Another way to duplicate is to right click on the column and 
choose duplicate from the menu. Also, you can copy and paste to duplicate. Duplicating columns is 
most often used when creating label combination columns.

Combining Labels

One of the most powerful features of the 
matrix is labels can be combined using boolean 
operators: AND, OR, and NOT to count different 
combinations of labels that may exist within an 
instance.

There are many ways to combine labels together. 
When labels are combined the label name 
will display  at the beginning of the label 
combination. The default boolean operator is 
AND when a label combination is made.

Changing the Boolean Operator
The default operator is AND while this is the most commonly used 
operator. There are times you will want to change this especially 
when trying to exclude certain labels. The operator can be changed 
by clicking on the operator between two labels in the combination 
bar below the toolbar. In most occasions the operator will be AND. 

After clicking on the operator to expose the menu, select AND, OR, or NOT.

AND will count those instances that contain the combination of labels.

OR will count those instances that contain either of the labels in the combination.

NOT will count those instances that contain the first label and not the following label.

Note: A good approach to using this feature is to duplicate a label several times, then add a different label to each 
duplicate to check for existence of the combination. This demonstrates the real analysis powers of the matrix and is what 
it was designed to do.
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Saving a Code Matrix

Organizing the matrix and making various label combinations to produce the desired outcome is 
the key to using the matrix to the fullest. Once this work is done, it important to save it, so it can 
used to analyze against other timelines. Choose File>Save or press COMMAND+S to save the code 
matrix. By default it will be saved to a system “Matrix” folder, but you may choose to create another 
folder to store the file. This file can opened later and used to analyze the data in another timeline.

A saved Matrix will be linked to the Timeline to which it was linked at the time it is saved and may be 
retrieved directly from that Timeline toolbar by selecting it from the Matrix icon selection menu.

Loading a saved Code Matrix

A saved matrix can be used to analyze against different timelines other than the original 
one used to create it, this is especially handy when doing comparative or longitudinal 
analysis. Click the “Load” icon and select the saved matrix you wish to load, then click on 
the Timeline display in the matrix toolbar and select the timeline you wish to link your 
saved matrix to from the list.

Note: If the saved matrix does not contain new labels in the new timeline they will not 
automatically show up. If you want to add new labels to a saved matrix. Open a new 
matrix by clicking on the matrix icon in the timeline toolbar, then copy and paste the new 
labels into the saved matrix. If you are planning on using the matrix to do longitudinal 
analysis, do not change your code window without updating a saved matrix.

Resetting The Code Matrix

After organizing the matrix by deleting columns and rows and making new combinations, you may 
want to revert to the original matrix. To start from scratch, simply open another matrix by clicking 
on the matrix button in the timeline toolbar, all possible rows and columns will be loaded from the 
timeline into the matrix.

Copy The Code Matrix As A Picture 

Using the snapshot feature in Mac OS X, you can take a picture of any image that is displayed. Press 
SHIFT+CONTROL+COMMAND+4, drag the mouse cursor from of the upper left corner of the matrix 
window to the bottom right corner, then let go. A shutter sound will be heard indicating that the 
picture has been copied to the clipboard. Press COMMAND+V to paste the picture. A snapshot of the 
matrix can be pasted into a Word document or any other text editor that accepts images.

Select the label 
you want to 
combine with 

another label. Press the 
Add icon in the toolbar 
and select the label 
from the menu. 

Select the label you 
want to combine with 
another label. Click on 
the “Add “ button and 
choose a label from 
Add > Label or Group 
menu.

1 2

Select the label you want to combine 
with another label. Drag the label you 
want to combine with the selected 
label to the combination bar. The 
combination bar is located immediately 
below the toolbar. 

3
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Copy The Code Matrix As A Table

A selection of cells or the whole matrix can be copied and pasted or dragged and dropped into an 
open spreadsheet or text editor. Select the rows and columns or cells by holding down COMMAND 
or select the whole matrix by pressing COMMAND+A. To copy and paste, press COMMAND+C to 
copy the cells, then press COMMAND+V in the target document. To drag and drop, you must select 
the row and/or column name to drag from then drop in the open spreadsheet or text document.

Create a New Code Row In The Timeline from a Label 

1.	  �Select a column in the matrix by clicking on the label column header.
2.	  �A new row can be created from the matrix by pressing CTRL while clicking on the selected label 

column header. Select Make Timeline row from selected cells. This will create a new row in the 
timeline with a row name of the label.

Code Matrix Exports

Besides copying the matrix as a table and pasting into another document, the matrix can 
export an Excel document, a tab-delimited text file and 3 different web exports. Click on 
the Export button in the matrix toolbar to access the various exports.

Exporting A Code Matrix To Microsoft Excel

The matrix can be exported as an Excel ready document. The export generates a table for the full 
matrix. Click on the Export button in the toolbar and select Excel from the menu. Name the file and 
save.

Exporting A Code Matrix As A Tab-delimited text file

To make using the matrix data available to more third party applications, the matrix can be exported 
as a tab-delimited text file. This is a common format and easily imported by other applications. Click 
on the Export button in the toolbar, select Text from the menu, name the file and save.
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Sharing a Code Matrix to the Web *
IMPORTANT : Refer to the Preferences Section on Page 15 of this manual for your preferred 
settings for this function. It is important that your settings are correctly configured if this 
function is to deliver optimum results.

The matrix can be shared via the web in 3 ways: Web page, iPhone page, and XML file. 

Each of these exports the matrix counts and the video 
post capture or live during coding and capture. The 
Web and iPhone exports are designed specifically for 
immediate web deployment when the header and 

footer option is enabled. They can be exported directly to a live 
web server and accessed over an intranet or the internet. These 
two exports are simple web representations of the coded data, but 
can be customized with a little knowledge of HTML and CSS web 
development languages.

If you are looking for a higher level of web site development or integration, then the XML file will be 
the best option. The XML file export generates a file with all the necessary tags that fully describe 
the matrix table in a standard XML format. Plus it can automatically export the associate movies with 
logical names. The XML file includes row and column names and locations, row colors, all cell values 
and movie path and names. For purposes of this manual, the XML export will not be covered in great 
detail. For more information, contact a Sportstec representative to learn more about how to best 
use this option. Using this option requires strong web development skills to make it work properly, 
however it is the most powerful and flexible of the web exports.

Matrix Web Page Share

The web share option creates an HTML document that represents the matrix as seen in the 
matrix window. All matrix organization will be represented in the web export including any label 
combinations. There are situations where only the data needs to be exported, so the web page 
can be exported with or without movies. Be aware that exporting movies can be a long process 
depending on the movie compression options. This is especially true when exporting the matrix 
totals columns.
1.	 Share a Web Page by clicking on the Share button in the matrix toolbar and choosing Web Page.  

The settings dialog will open:
2.	 Set the name of the HTML document by inserting the name in the Save As text box.
3.	 Choose a destination folder in the Where drop down menu. If the desired location is not in the 

menu, click on the expose more locations button next to the Save As text box . The default 
folder is the   /Sites folder located in the active user’s home folder. This is a convenient location 

* SportsCode Elite Only
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to save web export files into because the Mac OS X Web Sharing feature uses this folder from 
which to serve web pages. Below the hard disk space indicator bar is the URL of the exported 
site. 

Take note of this link or click on it to open it in Safari. If it is clicked on the site will not be found until it is exported, so 
leave Safari open, then refresh the Safari after it is exported. The page will be available after the export and it can be 
bookmarked.

•	 The next setting is the “Use selected cells only”. This option is available when specific rows, 
columns or cells are selected when the export is initiated. Untick this option if you wish to 
export the whole matrix. If it is ticked, it will only export the selected rows, columns or cells.

•	 “Include HTML header and footer” should be ticked in most occasions. When it is selected, basic 
HTML declarations and simple CSS language is included. Items such as cell borders and colors 
are configured. Leaving this option unselected creates a document that is designed to be 
integrated into an existing web site design. This allows for specific coloring and layout options 
to automatically be inserted into the web page.

•	 Movies can be exported by ticking the “Include movies” option. This option turns on the “Export 
movie to “_Movies” folder” and the Export format options also. When this option is selected and 
the “Export movie to “_Movies” folder” is not selected, it will export standalone movies unless 

“Export movies as references” is selected. This is a great option for creating a quick preview of 
how the web page will operate or useful on a local area network.

•	 If you want to make the web page export portable, so that it can be moved to a proper web 
server, it is important to select the “Export movie to “_Movies” folder” option. This will create 
standalone movies for every cell in the matrix and save them in folder called by the name set in 
the Save As text box with “_Movies” appended to the end. The “HTMLNAME_Movies” folder will 
be saved in the same location as the HTML document.

•	 “Export movies as references” will export each cell’s movie as a reference to one standalone 
movie. This makes the export process much faster and works well for local area network web 
serving. It is not recommended for serving matrices over the internet.

•	 The last option is the movie format. This sets the movie format that will be exported. There are 
16 default options plus the Quicktime Movie option which makes the options virtually unlimited. 
The movie format options will depend on the desired distribution strategy. We recommend 
experimenting with several formats starting with the iPhone format. The iPhone format is a 
great choice as it offers a really interesting distribution strategy. Since it is a portable device and 
a mobile phone, people are very accustomed to carrying it and are familiar with how to use 
most of its features. For purposes of this manual, we will not cover the movie export options. 
Contact a Sportstec representative to learn more about potential workflows.
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Matrix iPhone Page Export

The iPhone Page export is very similar to the Web Page export. To avoid 
repetition, review steps 1 through 4 in the earlier described Matrix Web 
Page Export section to learn about setting the name, destination, cell 
selection and header and footer options.

The iPhone Page export is designed to be displayed on the iPhone. While 
the mechanics of the export are nearly the same, there are some special 
settings and features to make its use most efficient and effective.

The following steps will outline the specific settings that differ from the Web Page export.

Export an iPhone Page by clicking on the Share button in the matrix toolbar and choosing Web Page 
> iPhone Page. The settings dialog will open:
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As noted previously, some options will not be covered in order to avoid repetition.

•	 After setting the name, location, cell selection and HTML header and footer option, it is 
important to set the iPhone specific options.

•	 By selecting the “Do not show 0 items cells”option, the export will not create rows in the HTML 
document that have a zero count. This reduces the length of the page, thus reducing the 
amount of scrolling to find data.

•	 “Create row and column totals movies”, this option should be used when exporting an iPhone 
page live during coding and capture. When it is selected, movies linked to the total columns will 
be created. If there are a large amount of instances or there are multiple rows of instances that 
cover the majority of the timeline, this option could export the entire length of the movie many 
times over especially when s overlap. This option should also not be selected when exporting 
live. When exporting live, there is the potential that the totals column could be continually 
exporting if the coding process is rapid.

•	 “Create cell totals movies”, this option generates a movie for the total number of instances in the 
cell. This option greatly slows down the export and should not be used during a live export if the 
cell total increases at a rapid pace.

•	 During a live export, the key option to have selected is “Create the last few individual movie 
instances”. This option will configure the export mechanism to export the last X amount of 
instances that have been coded. This is specifically designed for live situations. As individual 
instances are coded, they will be exported into the web page continually until the limit is 
reached. When the limit is reached the first one exported will be replaced by the following one 
and the last one will move to the second to last one to make room for the newest instance. 
The mechanism can be thought of as a conveyor belt. It is designed for live review, in our 
questioning of users, it is only the last 5 or so instances that are important to have immediate 
access to. This option has a limit of 99 instances due to the iPhone screen configuration.

•	 The settings for the export format are basically limited to those that are compatible to play on 
the iPhone or iPod. We added Source Movie and Quicktime Movie options to make the export 
more flexible for certain workflows. We recommend testing the various format export options to 
make sure the settings satisfy your workflow. As mentioned previously, it is best to start with the 
iPhone export, then experiment from there. Using customized settings may increase the length 
of the export, thus slowing down the whole process.
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Matrix XML File Export

The XML File export is specifically designed for advanced website integration. Overall the mechanics 
of this export work exactly the same as the iPhone Page, however the xml file should not be 
confused with a ready to view web page, the file requires further processing. The XML file can be 
used in a multitude of ways, it can dynamically feed data into a live website, it can also be read by 
Excel spreadsheets or database applications such as Filemaker.

The one notable option that differs from the iPhone web page is that it can export all instances not 
being limited by the conveyor belt concept described in the Matrix iPhone Page Export section. 
Setting the “How many instances” option to zero will export all instances indexed starting at 1, the 
first instance, to the last instance. 
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Movie Organizer

The Movie Organizer is a presentation creation tool designed to organize and edit instances. 
Instances can be dragged around to change the order or they can be trimmed using the instance 
edit window. A movie organizer can be saved and reopened for future presentation or editing. A 
movie organizer window can be opened in three ways. The first is to choose File > New > Movie 
Organizer. The second is to select an instance or multiple instances and press the Organizer 
button in the timeline tool bar. The third is to select an instance or multiple instances and press 
COMMAND+OPTION+V . This will open a new movie organizer if one is not already open. If an 
organizer is open, then the instances will be pasted in the open movie organizer window.

Paste Instances Into The Organizer

1.	 Click, drag and drop selected instances into the movie organizer.
2.	   Select an instance or multiple instances, click on the organizer button in the tool bar or press 

COMMAND+OPTION+V.
3.	   To place an entire row into the movie organizer, select the row by clicking on the row name, 

press COMMAND+OPTION+V. Hold down COMMAND and click on multiple row names to 
select multiple rows of instances.

Playing Instances In The Movie Organizer

•	 All Instances can be played by clicking on the Movie Button in the toolbar.
•	 All Instances associated with a row can be played by double clicking on the row name.
•	 An individual instance can be played by double clicking on it in the movie organizer window.

Adjust Playback Speed

Playback speed can be set by selecting the instance or group of instances, then clicking on the 
“Speed” icon in the Movie Organiser tool bar, (see illustration above.)  Alternatively, hold down 
SHIFT+CTRL and click on the instance to access the playback speed menu.

Make Movie Options In The Movie Organizer

�By selecting Titles, the row name will appear as a title frame before 
the corresponding instances for the row are played. The number 
of instances are displayed diagonally with thumbnails in the title.

By selecting Static text, each instance’s associated text descriptors 
will be displayed in a static title before each instance. A static 
movie will play for the default duration of text movies set in the 
SportsCode preferences.

By selecting Instance notes, a text track will be displayed at the 
bottom of the instance movie with the instance notes showing in 
the text track.
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By selecting Overlay text, the row name, instance number, and 
labels will displayed over the movie in real time. Various 
preferences for the overlay text can be customized in the Overlay 
text preference panel. Overlay text is not exported into a 
standalone movie. Overlay text can only be viewed in SportsCode 

software.

Changing Row Name In Movie Organizer

Row characteristics such as row name and color can be edited by right clicking on the row name in 
the movie organizer and selecting edit row from the popup menu. Changing the row name for a title 
row will change the text in the title that is created.

Editing Instances And Movies In The Movie Organizer

•	 To move an instance to another row, click and drag instance to desired location.

•	 To create a new row click on the new row button in the movie organizer tool bar.

•	 To include or exclude rows from operations, select or deselect the tick box.

•	 To edit the in or the out point of an instance, select the instance and press the CONTROL+E keys. 
This will open the instance edit window. Make changes by pressing the arrows in the upper 
corners of the instance edit window.

•	 To delete any instance, highlight the instance and press the DELETE key.

•	 To drag and drop instances between movie organizer windows, select multiple instances in a 
movie organizer, hold down COMMAND+OPTION, click and drag from the selected instances 
and drop into another movie organizer window.

•	 This is a very useful drawing workflow feature. Send an instance to the movie organiser, 
selecting instance edit, find a point to split the instance, then from the Edit menu select “Split 
instance edit + new drawing row”. Draw on the clip using the drawing window, then click the 
organiser button in the drawing window to send your drawing clip to the movie organiser. 
When you then make a movie from the organiser the clip will play, pause for the drawing, then 
continue to play.

Paste A Picture From The Clipboard Into The Movie Organizer 

1.	 Click on new picture button in the movie organizer tool bar, this will create a new picture row in 
your Movie Organizer.

2.	 In the new row click on the white box and paste in your picture.
3.	 Drag the picture row to the row above the clips you want it to show before.

Note: When a picture is pasted into the movie organizer it is scaled to the full movie size. Drag the bottom of any picture 
to resize the row. Pressing SHIFT+COMMAND and dragging the bottom of any picture will simultaneously alter the size of 
all picture rows.



Part 4 - SportsCode Review/Analysis

153

Changing Labels

The label tree pop menu can be accessed by right clicking on an instance. The label tree pop menu 
is created from all the labels found in the movie organizer window. If new labels need to be added, 
open a new label tree window, add the labels to the new window, then right click on the instances 
to add the new label or any timeline label tree or previously saved label tree window can be opened 
and used.

Adding Notes

Instance notes can be added to individual instances. Select the instance and press the Notes button 
in the movie organizer tool bar. Type the text into the notes window. Close the window to save the 
note or select another instance to add notes to.

Save A Movie Organizer

Choose File > Save, File > Save as..., or press COMMAND+S. The Movie Organizer will be 
saved as a file with this icon.

Database Instances from a Movie Organizer

Select the instances you want to export to a database and click on the database button in 
the movie organizer tool bar.
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Instance Sequencer

The instance sequencer presents a list of the instances within a row of a movie organizer. The order 
of instances can be arranged by dragging the rows up or down. Instance labels and duration can also 
be edited.

Open the instance sequencer for a row by double clicking on the yellow sequencer icon to the left of 
the row name in the movie organizer.

Play and Edit Instances in the Instance Sequencer

Double clicking on a row will open the edit instance window, the instance can be viewed or edited. 
To play or edit another row, single click on the row and the edit instance window will update the 
changes in the last row and move to the new selection. Close the edit instance window by clicking 
on the red button in upper left corner of the window.

Delete Instances from the Instance Sequencer

Select a row and press the DELETE key.

Editing Labels in the Instance Sequencer

The labels tree popup menu can be accessed by right clicking on a row. The labels in the pop menu 
that are displayed will only be those labels from the movie organizer row. Open a saved label tree to 
add new ones or open the timeline and press the labels button.
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Sorter Window *

The sorter window is a spreadsheet-style organizing and analysis tool, a powerful combination of 
the movie organizer, instance sequencer and statistical window. In the sorter window, instances can 
be trimmed, labels can be edited, and instance notes added. Rows can be automatically sorted by 
movie time references, alpha-numerically, or frequency of occurrence according to grouped labels. 
And final presentations can be arranged with picture rows created from the drawing window.

Like the movie organizer, rows are created in the sorter window by pasting instances from 
a timeline. Select instances in a timeline and press the sorter button in the timeline tool 
bar. A new sorter window will open automatically if one is not open. If a sorter window is 
open, the instances will be pasted below the last row in the window.

An individual row can be moved vertically up or down to change the order by clicking and dragging 
from the row number. Multiple rows can be selected by holding down COMMAND or SHIFT, then 
moved as a group by clicking and dragging with these keys pressed down.

During the analysis process, a higher level of detail can be added in the sorter window. Any changes 
made to an instance in the sorter window can be synchronized with the original timeline.

* SportsCode Elite Only
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Sorter Window Toolbar

Print sends the sorter window to a printer or .pdf file.

Column inserts a new column after the selected one or creates a 
new one as the last column.

Row inserts a new row after the selected one or creates a new one as 
the last row.

Bold, Italic, Color, and Size change the appearance of the selected 
text.

Movie creates an instance movie for all rows in the sorter window.

Edit movie opens the edit instance movie window. This is used to 
trim the start and end points for the row.

Synchronize sends time, label, and instance note changes for 
selected rows in the sorter to the original instances in the timeline.

Nest sort, when checked before sorting a column, subsequent 
column sorts will be sorted keeping the previous sort in tact.

Position re-arranges sorter, timeline, edit instance movie windows 
to help window layout. Position button has 4 positions for the edit 
instance movie and sorter window. Press the Position 4 times.

Database send selected rows to a database.
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Sorter Window Column Settings Bar

Clicking on the icons in the column settings bar of the sorter window will turn on and off the settings 
for locking content, searching, and text overlay.

Unlocked Column Cells in column can be edited.

Locked Column Cells in column cannot be edited.

Searchable Column Cells in column will be searched with CTRL+F.

Unsearchable Column Cells in column will not be searched with CTRL+F.

Time Reference Column

Picture Column

Code Column Text overlay will be displayed.

Code Column Text overlay will not be displayed.

Label Column Text overlay will be displayed.

Label Column Text overlay will not be displayed.

Grouped Label Column Text overlay will be displayed.

Grouped Label Column Text overlay will not be displayed.

Instance Note Column Instance note text track will be displayed.

Instance Note Column Instance note text track will not be displayed.

Sorter Window Column Type Setting

A column type is set by right clicking on the column setting bar above a column. There are  8 column 
types.

Time Reference Column

Time reference column displays the start time, duration, and 
timeline origin for the instance in the row. The column header 
can be changed to display the total duration for all time reference 
rows in the sorter window. Right click on the column header 
name and select “Display as total duration”
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Picture Column

An image can be pasted into this column and it will be presented as a title 
in a made movie. A picture can be created in the drawing window and 
pasted using the paste to sorter button in the drawing window.

Code Column

The name of the code row from which the row was pasted is displayed in this 
column. The text in this column can be edited for overlay text purposes, but the 
code row name cannot be synchronized back to the original timeline.

Instance Number Column

The instance number from the original timeline row is displayed in this column. 
This column can be helpful for sorting purposes in the sorter window or 
referencing instances in the original timeline.

Instance Note Column

The instance note column displays any instance notes that have been entered into 
the instance. Notes can be edited or added in this column. This is an easy way to 
add instance notes, copy and paste can be used to add the same notes to multiple 
instances quickly.

Label Column

The label column displays any ungrouped labels that have been coded in the 
instance using label buttons. If label buttons have not been designated in groups 
the column header will read “No group”. Each label will be displayed on a separate 
line. To add new labels, enter each label on a new line.

Group Label Column

The group label column displays grouped labels that have been coded in the 
instance. The column header name represents the group name and the grouped 
labels will fall separately under the associated group columns. This column type is 
best for nested sorting.

Default Column

The default column is generally not used in the sorter window. But, can be used as 
a general note column or column separator.
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Exporting Instances to a Sorter Window

Any group of selected instances or single instance can be exported to a sorter window. Select the 
instances in the timeline, then press the sorter button in the timeline tool bar. If a sorter window is 
open the instances will be pasted below that last row of the window. If a sorter window is not open 
a new one will be created automatically with the instances. When multiple instances are exported at 
once, they will be pasted in the window chronologically. If the selection is across multiple rows, each 
row will be pasted in their respective sections in the sorter.

Creating an Instance Movie in the Sorter

 Double clicking a the row number or time reference cell for a row will make a single instance 
movie. To make a movie from multiple rows, select the rows using COMMAND or SHIFT and 
press the movie button in the sorter tool bar while holding down SHIFT.

When the make movie button is pressed down regardless of any row selections, an instance movie 
with all rows included will be created. If an instance movie is created from the sorter, clicking in a row 
in the sorter shifts the movie controller in this movie to the start time of the movie reference for the 
row clicked in the sorter.

Viewing and Editing Instances

The edit instance movie can be used to view and trim instance rows in the sorter window. 
Click in a cell and press on the edit movie button in the sorter window tool bar to open the 
instance edit movie window. The start and end time of the instance can be edited using the 
arrow buttons in the corners of the edit instance movie. To change the instance being 
displayed in the movie window, click in any cell of a different row. The edit instance movie 
will update as the cells are clicked in different rows. Turn on movie looping mode to make 
the make the movie play continuously, saving a few keystrokes or mouse clicks. 

Pressing the back arrow at the start of the edit instance window shifts the edit instance to the 
previous row in the sorter. This is a wrapping type of behaviour. Refer also to “Adjusting the Length 
of an Instance” , option 2  page ref. 123

‘Split Instance Edit’ & ‘Split Instance Edit plus New Drawing Row’

Send an instance to the Sorter, selecting instance edit, find a point to split the instance, then from 
the Edit menu select “Split instance edit + new drawing row”. Draw on the clip using the drawing 
window, then click the Sorter button in the drawing window to send your drawing clip to the Sorter. 
When you then make a movie from the Sorter the clip will play, pause for the drawing, then continue 
to play.

Editing Labels with the Label Tree Popup

Labels and instance notes can be edited, added, or removed in a cell. Click in the cell change the 
text, input new text, or delete the text. When adding labels, care must be taken that the label is 
inputted correctly in the cell. If a label is misspelled or the capitalization is wrong, two different 
labels will be created that mean the same thing. To help this problem, the label tree popup 
menu can be accessed in any cell by holding down OPTION and clicking in a cell. The label tree 
popup menu will appear and the labels can be added or removed. Using the label tree is the best 
way to make sure that labels are consistently inputted in the sorter window.
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Using the Keyboard to Move the Cursor

To move around in the sorter window with the keyboard, begin by selecting a cell with the mouse. 
Press the TAB key to move to the next cell to the right of the active cell. When the last cell in the row 
is reached it will wrap to the next row down in the first cell. Pressing SHIFT+TAB will move in the 
reverse direction. Alternatively, hold down CTRL and use the arrow keys to move up, down, right, 
and left around the cells. When text is being edited, then tabbing to next row, the selection point is 
set to the end of the text in the same cell and column column. If the Edit Instance Movie window is 
open and TAB is used, the cursor will move up or down the same column. 

Using the Keyboard to Control the Edit Movie Window

Since the sorter window is more about inputting text using the keyboard, there are 3 shortcuts to 
control the edit movie window. These shortcuts are available to help reduce the amount of time for 
using the mouse and these are designed to behave like the shuttle control on VTR.

If the sorter is the key window, the arrows control the movie functions. If the edit instance movies is 
open, the mouse must be used to position the cursor.

CTRL+L plays the movie forward. Pressing this shortcut multiple times sequentially will play the 
video faster and faster incrementally. When movie looping is turned off and the playhead reaches 
the end of the movie, pressing CTRL+L will start the movie playing from the beginning again.

CTRL+K pauses the movie.

CTRL+J plays the movie backward. Pressing this shortcut multiple times sequentially will play the 
video faster and faster backwards incrementally.

CTRL+I will set the start time for the selected instance according to the location of the playhead in 
the edit instance movie window.

CTRL+O will set the end time for the selected instance according to the location of the playhead in 
the edit instance movie window.

CTRL+T will set either the start time or the end time according to the location of the playhead. If the 
playhead is before the midpoint of the clip, pressing CTRL+T will set the start time. If the playhead is 
after the midpoint of the clip, pressing CTRL+T will set the end time.

SHIFT+CTRL+I will subtract 0.5 seconds from the start time of the instance. (Subtracting makes the 
start time earlier, thus making the instance longer)

SHIFT+CTRL+O will add 0.5 seconds to the end time of the instance, making the instance longer.

SHIFT+CTRL+T will subtract 0.5 seconds from the start time if the playhead is closer to the start of 
the instance. If the playhead is closer to the end time, 0.5 seconds will be added to the end time.
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Sorting Rows

Columns in the sorter window can be automatically sorted in 5 different ways. To access the sorting 
options, right click on the column header name cells

1.	  �Sort Ascending sorts the rows in alphabetical order from A-Z according to the data found in the 
column. Numbers will be sorted from lowest to the greatest number.

2.	  �Sort Descending sorts the rows in reverse alphabetical order from Z-A according to the data 
found in the column. Numbers will be sorted from the greatest to the lowest number.

3.	  �Sort Frequency Ascending sorts the least frequent found text or number in the column and 
groups those at the top, the next least frequent found text or number is placed below this 
grouping. This pattern is followed through out the column of data.

4.	  �Sort Frequency Descending sorts the most frequent found text or number in the column and 
groups those at the top, the next most frequent found text or number is placed below this 
grouping. This pattern is followed through out the column of data.

5.	 Sort All Rows by Movie Time sorts the rows according to the instance start time. This sorting 
option only works when clicking on the time reference column header.

Synchronizing Changes Back to the Timeline

After making changes to the duration of instances, the labels, and instance notes in the 
rows of a sorter window. The changes can be synchronized back to the original timeline. 
Select the specific rows in the sorter to be synchronized, then press the synchronize 

button in the sorter tool bar. To synchronize all the rows, press COMMAND+A to select all the rows, 
then press the synchronize button. When synchronizing data back into timelines, the original 
timelines must be open.

NOTE: The purpose of requiring the timelines to be open is to insure that accidental synchronization does not occur. 
Changes made through synchronization cannot be undone once the timeline is saved. By default, the auto save timeline 
data preference is turned on.  
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Overlay Text Display Options in the Sorter *

Each column of data in the sorter window can be turned off for overlay text display. When the 
column type icon has cross through it, the data will not be shown as overlay text.

This is used to limit what is presented in the movie and attention can be brought to specific data. The 
examples below show how turning off columns displays less data.

No columns turned off.

Row name column turned off.

Row name and Field Zone columns turned off.

Row name, Field Zone and Phase Play Start columns turned off.

* SportsCode Elite Only
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Sorter Window Templates *

Heavy users of the sorter window will have specific column arrangements, to make this process 
easier, a sorter window template can be created. Open the template and paste the instances into it.

1.	 Create a sorter template using these steps:

2.	 Export one instance into a sorter window.

3.	 Arrange columns to desired template appearance and remove any unnecessary columns.

4.	 Change the window type by clicking on the window type selector. This is the cell with 
the icon in it, 2 rows above the row number indicator for row 1. (Right below the print 
button) 

5.	 Select Sorter template from the list. The icon in the upper left will change.

6.	 Delete the instance from row 1.

7.	 Save and close the template.

8.	 Open the template, switch it to sorter type window, choose some instances and press the sorter 
button in the timeline.

9.	 All the instances will be exported into this template using only the columns found in the 
window.

10.	 Save the sorter window.

* SportsCode Elite Only
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Instance Notes

Notes can be added directly to an instance either during coding or in the timeline. Instance notes 
are designed to add information that speaks to those viewing the movie or as a method to record 
special information regarding the instance. The instance note will appear in the text track at the 
bottom of an instance movie when “Notes” is checked in the Code Button Inspector Behaviour Panel 
or when the Note icon is selected in the Timeline toolbar..

Adding a note to an Instance in the Timeline

1.	  �Select the instance in the timeline to add text to in the 
timeline.

2.	  � Open the Edit Instance Note window by pressing on 
the Note button in the timeline tool bar.

3.	  �Add the text in the Edit Instance Note window. When all the 
text is added, click on the red button to close the window and 
save the note.

The Edit Instance Note window can be left open to easily add notes to an instance. Select any 
instance and the Edit Instance Note window will change to that instance. The text will be saved in 
the instance when the next instance is selected after adding the text. This makes adding notes a 
quick job and saves on mouse clicks. The Edit Instance Note window will also operate in full screen.

Viewing instance notes in a movie

Enable instance notes in the timeline by checking the 
instance notes check box in the Settings panel on the 
Timeline toolbar.

When a movie is made from instances in the timeline, 
a text track will appear at the bottom of the movie 
window.

Setting the amount of lines of notes displayed

Click on the lines drop down menu in the Settings Panel in the timeline tool bar. Select the number 
of lines of text that will appear in the movie at the bottom of movies. If there is a lot of text that is 
required to display, set this to match the lines required to display the text. Otherwise, the instance 
note text will scroll the length of the movie.
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SportsCode Drawing Window
IMPORTANT : Refer to the Preferences Section on Page 17 of this manual for your preferred 
settings for this function. It is important that your settings are correctly configured if this 
function is to deliver optimum results.

This window is created by choosing File > New > Drawing Window or by selecting the Drawing 
Window icon from the Movie Window. The drawing window will open as a “whiteboard” in the case 
of the first option, and in the movie window in the second option.The drawing tools can be used in a 
Drawing Window, Timeline and Instance Movies.

When the window appears, the floating drawing toolbar appears in its last location or if never 
opened it will be on left edge of the window. This floating toolbar disappears after 2 seconds when 
the window is not the front-most window or when the mouse is not hovering over the window or a 
movie window.

The Floating Drawing Toolbar

The floating toolbar contains the  mode button an Inspector button and tools for creating drawing 
objects. The Toolbar “floats” in that when displayed, it can be moved to anywhere in your screen as 

well as being hidden. Each drawing tool button in the control has 3 states: Not Selected, 
Selected, and Locked. Only one tool can be active at any one time.

    Not Selected is when the tool icon is coloured grey.

    Selected shows the tool graphic in blue with a grey background. Once clicked on, the 
tool can be used once then the control returns to the selector tool.

    Locked state requires 2 clicks on the button and the tool will remain active until 
another tool is selected. This allows for continuous drawing using the same tool. (The 
selector tool is always locked when selected.))

Drawing Tools

Select the tool you wish to use by clicking on it once. The tool selected will be lit 
with a blue background. To activate the tool click on the movie zone and drag the 
cursor.  Activate the Inspector for that tool to change the properties from the default. 
SportsCode stores any amended Inspector properties as a new default setting.  A 
tool is deactivated as soon as you discontinue dragging the cursor. SportsCode will 
automatically return to the Selection tool (cursor) when the tool is deactivated.

Telestration Mode

Any drawing object placed in the window when this mode is active will not 
be saved and will disappear as soon as the window frame is advanced.

The Selection Tool
Use the Selection tool to move the position of drawing objects, to vary the size, or to select 
1 or more drawing objects in the view.
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The Inspector Button

The Inspector tool assigns Behaviour and Appearance properties to Objects.

The Straight Line Tool
The Straight Line tool allows you to draw a straight line. You may reposition a straight line 
drawn, and reposition either end of the line by using the Selection tool.

The Freehand Tool
The Freehand tool provides you with the ability to draw freehand objects. Objects drawn 
with this tool will be fixed as to what was drawn once the tool has been deactivated. You 
may manipulate the position and overall dimensions by using the Selection tool.

The Shape Tools
The Shape tool allows you to draw up to 3 varying shapes. Use the Inspector function to 
choose the shape of the default and to vary the shape of an existing Shape object.

The rectangle tool draws a four sided rectangle shape where opposite sides are parallel 
and the corners are square.

The ellipse tool draws an ellipse. When SHIFT is held down a circle can be drawn.

The rounded rectangle tool draws a four sided rectangle shape where opposite sides are 
parallel and the corners are round. There is a handle in upper left corner of the shape to change the 
roundness of the corners.

The Text Tool
 �The text tool creates a text box where text can be inputted.  The large button below the 
text “Text Attributes” opens the standard font inspector to allow the user to change the 
font size, etc. There are also 4 standard text alignment features (Align left, Align Middle, 
Align Right and Justify).  Type the text in the text box. You may change the dimensions of 
the Textbox by using the Selection Tool to drag a corner to your required size 

	            To edit the text, double click on the text using the selection tool.
Angle Measurement Tool

The Angle Measurement tool acts initially as a freehand tool to allow you to draw 2 lines 
and then display the internal and external angles between the 2 lines from their point of 
intersection. Use the Selection tool to reposition the extremity points of each line and also 
the intersection point.

Line Measurement Tool

By using known distances in a frame of video, you can accurately measure other distances 
relative to a known distance.  You can use the known distance to set the relative scale of 
the measuring tool. By default the line drawn will be divided into 4 equal sections. For 
greater accuracy it is recommended that you select landmark points in the horizontal 

plane (x-axis) and in vertical plane (the y-axis) as close as possible in the view you wish to measure.  
Double click on the measurement displayed and replace it with your known measurement for 
the distance between the 2 points. (NOTE: If you wish to include a unit measure eg. Metre or ft 
etc. you must place a space between your numeral(s) and the alphameric text.)  This will set your 
measurement scale.  Using the Selection tool, reposition the extremity points of the measure to 
where you want to measure the distance from and to. The measure will display the distance as 
determined by the scale you had set.



Part 4 - SportsCode Review/Analysis

167

Drawing Window Menu Bar 

Make Movie

Select this button to make a movie of your drawing window to insert into the Matrix or 
Movie Organiser.

Organizer

Select this button to open the Movie Organiser.

Sorter

Select this button to open the Sorter.

Clip Duration

Specify the duration (3 seconds by default) of the drawing window.

Show or Hide the  Drawing Toolbar

Click this button in the Menu Bar to display or hide the Toolbar.

Drawing Inspector

Open the Inspector for the drawing object highlighted.

Settings

The window’s canvas (white area below the menu bar) is created using, (by default) the 
dimensions of the front-most movie. This may be varied by selecting the Settings icon. This 
ensures that when the drawing is made into a movie that its dimensions match those of the 

movie for which it will be likely combined, or it will match the movie dimensions when sent to the 
Movie Organizer or Sorter windows. 
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Inspector with Drawing Tools

The Inspector tool assigns Behaviour and Appearance properties to Objects

Click on the drawing object to highlight it , then select  the Inspector button in the menu bar. The 
Inspector Panel will open.

For all drawing tools, you are able to specify for what duration the highlighted object will be visible. 
This is effected in the “Appearance Time” section at the base of the Inspector Panel.

For the Line Tool, the Freehand Tool and the Shape Tools you are able to vary the following  
attributes 

•	 Shape
•	 Fill
•	 Stroke type
•	 Stroke width
•	 Stroke color
•	 Geometry

For the Line Tool and Freehand Tool you are also able to choose a shape for the end(s) of the line.

For the Text Tool, the Angle Tool and the Ruler Tool, you are able to choose from the following Text 
Attributes :
•	 Fonts
•	 Text color
•	 Text geometry / bias

For the Angle Tool and the Ruler Tool you are also able to vary the Stroke Attributes listed above. 

Insert Drawing Objects in to Instance Movies 

Send an instance to the Movie Organiser or Sorter, select instance edit, find a point to split the 
instance, then from the Edit menu select “Split instance edit + new drawing row”. Draw on the clip 
using the Drawing Window, then click the Organiser or Sorter button in the drawing menu bar to 
send your drawing clip to the Movie Organiser or Sorter. When you then make a movie from the 
Organiser or Sorter the clip will play, pause for the drawing, then continue to play.

Export the Movie incuding Drawings

When you have a movie clip on which you have included drawing objects, choose -

	 File > Export > Movies > Convert Movie

In the Save panel ensure you check the “Include drawings” box
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Create a Movie incorporating the Drawing Window

To create movies incorporating pictures of your analysis use the drawing window. The drawing 
window is able to create movies that can be combined with other instances.

1. Open up an instance by double clicking on it. Stop the instance movie at the point where you 
want to make a coaching note with drawing and text. (We shall call this the “original instance 
window”)

2. Select “Edit> Copy movie frame to drawing” from the Main Menu bar. The still frame from the 
“original instance window” will open in a drawing window.

3. Draw on the drawing window using tools. The arrow 
icon on the drawing toolbar will take you back to a cursor 
in order to move things around or make other selections.

Hint: to make text stand out, put a square or rectangle on 
the page first and then write in an opposite colour on top.

4. Select the duration length you want this frame to be 
and click the make movie icon.

5. When the movie pops up, hold down the SHIFT key 
and drag the red cursor in the base line all the way along. 
The darkened background indicates the whole movie is 
selected.

6. Hold down the OPTION key then click and drag the movie back into the “original instance 
window”.  This is called drag and drop editing.

The drawing window movie will be inserted into the “original instance window” at the point of the 
playhead.

Creating Title Movies

The drawing window is great for creating title movies that you can paste in front of an instance 
movie. This lets the viewing audience know what is coming up and helps keep them focused on 
the subject of the presentation.

Create a folder called Titles. Open a drawing window, paste your logo in the window, set the 
background color, add some drawing objects and color them to match your scheme. Add some 
large bold text in the middle of the window and save the drawing in the Titles folder.

Edit the bold text to match the subject of the instance movie, this might be the row name. Then, 
create the movie and save it in the Titles folder with the name of the bold text. Repeat this 
process for all the categories of instance movies you will be presenting. Since it is very common 
that you will need to use these titles over and over, they are now created and saved in the Titles 
folder for future use.
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Create a Key Frame Output

It is sometimes necessary to find the middle frame of an instance for timing purposes and analysis 
of an action. If you want to analyze these key frames and use them in another application, or print 
them for a profile folder, first locate the instances which contain the key frames of interest. Then 
choose Key frames from the Analysis menu in the main menu bar.

The Key frames will be copied to the Output Window. You can now drag a box around the picture 
and copy it to the clipboard, from there you can paste it into another application or print it.
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Instance Monitor 

The Instance monitor allows you to see the contents of an instance at a glance in a filmstrip style. You 
can select the number of frames to display as well as the frame size in relation to the original movie.

Use the Instance Monitor

1.	  �Choose Instance Monitor from the Analysis > Measurement menu in the main menu bar.

2.	  �This will open the monitor with grey frames because it is not linked to an instance. To display 
the required frames of an instance, click on the instance that you want to view, and select the 
size and the number of frames you wish to display.

3.	 To view instances in a row, select the row of interest so all instances are highlighted, position the 
playhead where you want to start viewing, press CONTROL+TAB key to move from instance to 
instance. You can move in reverse by pressing SHIFT+CONTROL+TAB.

Mac OS X Snapshot Features

Here are some shortcuts built in Mac OS X for creating snapshots of the screen or specific 
windows. 
SHIFT+COMMAND+3 will save a picture of the screen to the desktop. 
SHIFT+CONTROL+COMMAND+3 will turn the mouse cursor into cross hairs where you can click 
and drag a selector on the image you want to take a snapshot of. It saves the image as picture on 
the desktop. 
SHIFT+COMMAND+4 will save a picture of the screen to memory, so it can be pasted into 
another open window. 
SHIFT+CONTROL+COMMAND+4 will turn the mouse cursor into cross hairs where you can click 
and drag a selector on the image you want to take a snapshot of. It saves the image to memory, 
so it can be pasted into another open window.
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Using a Remote Control

The Apple Remote and the Commando Pro USB remote control can be used in various ways. These 
peripheral products are great tools for the locker room or boardroom presentations of coded video.

Each of these remotes can be customized in the software preferences.

Each button on the remote can be assigned a movie, drawing tool, or code button hot key function. 
Click on the button type drop down and select from Code, Movie, or Drawing button.

Code buttons can be assigned to match hot keys in a code window. When the code window is open 
and in code mode, the button can be pressed on the remote and it will push that button in the code 
window.�

Movie buttons are the various playback features of the software that can be 
performed in a movie window using the keyboard shortcuts.

Drawing buttons will enable different drawing tools in the drawing tool bar. 
This is very handy when presenting in full screen.

NOTE: The Commando Remote must be plugged in prior to launching the software and should not be unplugged until 
after the software is quit.
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Statistical Window

The statistical window is a spreadsheet style window with the ability to perform complex 
calculations based around instances in a timeline. A Statistics window must be built “from the 
ground up” 

Mathematical and logical expressions can be built into scripts in each cell. The scripts are built into 
each cell individually. Each cell can hold text, show data, change background color, or text color 
according to actions from the scripts.

The statistical window scripts can be executed manually by pressing the execute button in the 
window or executed automatically upon a change in the timeline or the click of a button in the code 
window.

The statistical window can drive output from a script to a button in the code window. Scripts can be 
written to change button colors and push buttons up or down according to customized calculations.

The statistical window is extremely flexible, rows and columns can be moved, added, and deleted to 
present the output in hundreds of ways and scripts may be copied and pasted to other cells and the 
formulae replicated.

Create A Statistical Window

Choose File > New > Statistical window from the main menu bar.

The Statistics Window Toolbar

Print

Prints the window contents

Column

A new column will be created to the right of the column where the cursor is located. If 
the cursor is not in a cell, then the column will be created to the right of the last column 
in the window.
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Row

A new row will be created immediately below the row where the cursor is located. If the 
cursor is not in a cell, then the row will be created below the last row in the window.

Text Properties

For manipulating the text in the heading columns and rows.

Execute

Searches the Timeline open and executes the statistical commands in every cell in the 
window that has a statistical script.

UnLocked and Searchable Column Cells

Allows cells in the column to be edited.
Allows cells in the column to be searched with CNTRL+F

Locked and Unsearchable  in Column Cells

Prevents cells in the column from being edited
Prevents cells in the column from being searched with CTRL+F

Moving Around A Statistical Window

Moving from cell to cell can be done in two ways.

1. Pressing the TAB key will move the cursor from one cell to the next cell on the right. Pressing 
SHIFT+TAB will move the cursor from one cell to the next cell on the left.

2. Holding down the CTRL key and pressing the arrow keys will move the cursor in the direction of 
the arrow key that is pressed

Moving A Column

Click and drag on the column information header where the column number is located, move the 
column to the new location.

Moving A Row

Click and drag on the row number, move the row to the new location.
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Deleting A Column

To delete a column, press CTRL and click on the column information 
header. Select Delete column from the popup menu.

Deleting A Row

To delete a row, press CTRL and click on the row number. Select Delete row 
from the popup menu.

Sorting Rows By Column

Rows can be sorted by column by pressing CTRL and clicking 
on the column header name cell. This is useful when sorting 
rows alphabetically or numerically. Sorting options are 
explained further in the Sorter window section of this manual.

The Edit Script Window

The edit script window is a very basic text editor with copy and 
paste functionality.�

The window consists of two parts: the title of the cell and the 
script for the cell.

The title of the cell can be set so it can be referenced in another 
cell’s script.

The script for the cell is set in the area below the title.

Add a Script

To add a script to a cell, press CTRL and click on a cell. Choose Edit script from the popup menu. This 
will open the script editor window.

After a script is added to a cell, the upper 
left corner of the cell will have a green 
triangle in it.

The scripting language and commands are quite difficult 
to master, but extremely powerful. Each command is 
documented in the “Help” menu where there is a full 
webpage devoted to it, or go to :

http://statistics.sportstec.com/documentation

http://statistics.sportstec.com/documentation
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Copy and Paste Rows and Columns with Scripts

Hold down OPTION and click and drag on the row number. This will create a duplicate row  or 
column with all the scripts included. This is quite a time saver when creating rows or columns 
that will have the same data in them like player statistics.

Use Cell References

Use a cell as a data place holder for script referencing. Setup a column where the player names 
are inputted, then reference this column by its name or coordinates in a script. This makes 
changing data very easy because it can be changed in the cell, not the script.

In the script, create a variable that reads the reference cell’s data. 
$playername = cell(“Player”,$row) 
show count “Handball” where row = $player

This variable will look to the player column in the same row and 
use this data in the script. By typing A.McGrath into the Player 
column cell, the script finds how many Handballs there were in the 
A.McGrath timeline row.

Copy to Excel

Data being displayed in the cells of a statistical window can be copied into Excel or any other 
spreadsheet program. Hold down COMMAND and click in the cell, then press COMMAND+C 
to copy the data to the clipboard. COMMAND+V will paste the data in the other application. A 
group of cells can be selected by holding down COMMAND, click in top left cell, then click in 
the bottom right cell of the group of cells to be copied.
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Converting Movies

Any movie can be converted to another format using the convert movies feature in this software. If 
SportsCode can view the file, it can be converted in some way to another format using this system.

The common formats for captured movies is DV, HDV, Apple Intermediate. These formats create very 
large files, approximately 15GB - 20GB of hard disc storage per hour of video. These files will fill up an 
internal hard disk very quickly. To save space, we recommend converting the files into an alternate 
format. Follow these instructions for a simple and fast method of converting any movie to a H.264 
format that is suitable for coding, editing, analysis, and presentation.

NOTE: Converting is commonly referred to as compressing since the purpose in most cases is to reduce (compress) the size 
of the file. Converting the movie creates a stand alone movie.

1.	 Open an instance movie from a timeline that 
has video linked to it.

2.	 Choose File > Export > Movies > Convert 
movie... in the main menu bar. This opens the 
Save exported file as... window where you can 
set-up all the options for the conversion.

3.	 Choose Movie to Quicktime Movie from the 
Export drop down menu in the window. Then, 
press the Options button to configure the 
specific movie conversion settings. The Movie 
Settings window will open and the Video, 
Audio, and Internet settings can be changed.

4.	 In the Video area of the Movie Settings 
window, click on the Settings button. The 
Standard Video Compressor Settings window 
will open. In this window, configure the 
following: 
Compression Type = H.264	  
Frame Rate = Current	  
Key Frames = Every 5 
Frame Reordering = Selected 
Data Rate = Restrict to 3600 
Encoding = Faster encode (Single-pass)

NOTE: Frame rate will be the same as the original. Every 5 
frames will be a key frame which converts a file that can be 
easily edited. 

Click OK to save the settings.
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Next, configure the Audio settings. 

5.	 In the Audio area of the Movie Settings window, 
click on the Settings button. This will open the 
Sound Settings window.

6.	 Set the Format to MPEG-4 Audio, the Channels to 
Mono the Rate to 44,100khz.

NOTE: These audio settings will create less than CD quality audio 
track in the converted movie. If audio is not important, uncheck this 
option in the Movie Settings window and no audio will be exported. 
This will make the resulting file smaller, but when  compared to 
video tracks, audio tracks are extremely small in size. So, in the long 
run, not choosing to use audio saves negligible hard disk space.

7.	 The last area in the Movie Settings window are 
the internet streaming options. If you are going to 
use the movie to stream from a file server on the 
internet, then you should select the appropriate 
settings as defined by the host of the server. 
For this example, uncheck Prepare for Internet 
Streaming options. For general use these settings 
should be turned off.

8.	 With the Video and Audio check boxes checked 
and the Prepare for Internet Streaming unchecked 
click the OK button in the Movie Settings window.

9.	 �In the Save exported file as window, type in a name 
and target location to export the file.

10.	 Click OK to start the conversion process.

In the save dialog, there is an option “Include overlay 
text”, selecting this option will “burn” the overlay text 
information into the movie. There is also an option 
“Place export inside a movie package”, if the selected 
movie is a timeline movie, this option will create a new 
package once the conversion is complete.

After the conversion is complete, these settings will be 
saved as the default settings. So, in most cases, they do 
not need to be set up again.

Permanent custom options in the movie format drop 
down menu can be configured for individual users. Contact Sportstec for help doing do this.
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This movie conversion example is very basic and does not fully explore all the options that are 
available. This is a very complex topic and for the purposes of this manual, we will not offer an 
explanation for every compressor and its various options.

Using the settings described, you will likely find varying results over time. Some movies will be 
smaller in file size even though they are similar in length. Other times you will see quality differences 
in two similar movies. Because each movie is different in shot, composition and length, you will 
have varying results when translated by the compressor’s algorithm automatic settings. But using 
automatic settings is a good way to start understanding how to convert movies.

Here are a few tips to experiment and find what will work for you best for your particular purpose.

1.	  �Use a short instance to experiment with different settings. Waiting for long conversions is 
tedious and you will not always get the desired results.

2.	  �Set the frame size of the instance movie first. SportsCode will use the instance movies window 
size for the conversion size. The frame size has a great impact on the conversion time. So, 
experiment with various sizes.

3.	  �If file size is most important, try setting manual data rates. This will guarantee the file size 
and forces the conversion to use the same amount of data per frame. Start with 6400 kbps. 
Automatic settings will find the best data rate which can vary greatly from movie to movie.

4.	  �Try using different compressors. Use H.264 or MPEG-4 to convert a small clip and compare the 
results. Some compressors are better for different types of video. H.264 and MPEG-4 are popular 
compressors, so sharing these formats will be compatible with any system running Quicktime 
7.0 or greater.

5.	  �Adjusting the key frame intervals can make a big difference when video quality and size are 
concerned. Try setting the keyframes to 25 instead of all or 1 frame. Key frame settings greater 
than one every frame creates movies that will not be suitable for coding, editing, and slow 
motion analysis. Spreading out the key frame intervals, is recommended when the video will be 
distributed for playback only via internet or email.

6.	  �Video acquisition is probably the most important aspect to converting movies. If the video is 
poor quality to begin with, converting it will not make it better. Try to get the best copy of the 
video possible or get proper training on how to use your camera. Fast panning or zooming can 
cause conversion results to look very pixilated. To achieve the best results, avoid quick camera 
motions.

Drag and Drop Reference Movies 
A quick and easy way to create reference movies for batch converting is to drag from the video in 
the movie window and drop onto the desktop. This will create a reference movie on the desktop 
with a time and date stamp included in the name. As you drag and drop, rename the movies, so 
you don’t forget what video is in each one. Remember to select the segment of the movie in the 
instance movie timeline for which you want to create a movie clipping.
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Convert Movie Package

A movie package can be easily converted to another format using this feature. The feature creates a 
copy of the package with the timeline file included, converts all the movie parts in package into the 
new format, creates a new reference movie for the timeline based on the newly formatted files and 
links this movie to the timeline.

To use this feature, choose File > Export > Movies > Convert movie package... and set the desired 
compression settings and location for the new pacakge. An additional option to this, is to have the 
process create a single movie once the export is complete. This will create a single file from all the 
movie parts inside the package. It is recommended to do this as it makes the package void of file 
references. A definite plus in terms of file portability, plus it allows the file to be extracted from the 
package and directly uploaded to Sportstec Stream or used more easily in some other workflow. 
 
When the options are set and the Save button is pressed, the export movie window will appear. 
Each movie part in the package will be converted until all are converted. The extra compression will 
continue converting all the parts in the package until it is finished or the application is quitted. If the 
application is quitted while there are still movie parts left to convert it will start up again when the 
original movie package is opened again. Once the extra export is complete, a movie package with 
same name plus extra will be found in the same folder as the original capture.

An export can be paused, cancelled or deleted anytime. To pause press the pause icon in the row to 
the right of the progress bar. To cancel press the x icon to the right of the progress bar. To delete a 
row in the queue, select the row and press DELETE on the keyboard.

The export window supports multiple items in the list. It is based on a first in first out queuing 
system. To add more items to the queue during capture, say for converting multiple packages over 
night, open a timeline package, select the timeline window, then choose File > Export > Timeline as 
new codec..., select the movie format and destination and add it to the queue. All items in the queue 
will be handled when the previous item above it in the queue is completed. This is especially useful 
for archiving and hard disk space saving purposes.
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Exporting Data Files

Timeline data can be easily exported and used in other applications such as Excel and Final Cut Pro.

Export an Edit List

An edit list generates a complete list of events in play order. It creates a tab delimited file that is 
easy to manipulate in a spreadsheet editor like Excel. Using the edit list data, graphs, functions and 
macros can create some very informative reports.

The export is simple to perform. Open a timeline and choose File > Export > Edit list... The file that is 
exported will likely have an excel icon and can be opened by Excel immediately. Since this is a tab 
delimited file, it can also be opened by many simple text editors or can be used as a data source for 
other workflows. 

The export will appear like this in Excel. 

For more information, see the Import section of this manual. There is a more in depth explanation of 
the data structure of the file. Also, see the Export Preferences section, this file type can be exported 
during capture and coding.

Export an XML Edit List 

Like the Edit List, the XML edit list generates a list of events in play order, but in an XML structure. 
The XML edit list is generally used for transferring timeline information from timeline to timeline. 
However, since it is common file structure, it can be used in hundreds of ways.

To export an XML edit list, open a timeline with coded data and choose File > Export > XML Edit list...
The file will contain all the descriptions of the instances including: start and end times, row names 
and colors, label groupings, labels, and instance notes. A file will look this in a simple test editor.

<file> 
<ALL_INSTANCES> 
<instance> 
<ID>1</ID> 
<start>279.5398520953</start> 
<end>616.7625308135</end> 
<code>Alexis Proctor</code> 
<label> 
<text>Great Work</text> 
</label> 
<label> 
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<group>Effort</group> 
<text>Solid</text> 
</label> 
<free_text>Excellent example of good footwork.</free_text> 
</instance> 
</ALL_INSTANCES> 
<ROWS> 
<row> 
<code>Alexis Proctor</code> 
<R>64083</R> 
<G>65535</G> 
<B>23454</B> 
</row> 
</ROWS> 
</file>

For more information, see the Import section of this manual. There is a more in depth explanation of 
the data structure of the file. Also, see the Export Preferences section, this file type can be exported 
during capture and coding.

Export an Instance Frequency Report

While one of the most basic exports, the instance frequency is a very effective gauge for finding 
percentages and overall lengths of coded instance rows. It also shows instance count and calculates 
mean time. The export can be quickly viewed in an Output window or saved to an Excel file. The 
following is a good example on how to use this export.

1. Import some GPSports data into a timeline. (See GPSports Import on page 63 for more information 
on this import process)

2. Select the range of speed rows for the athlete.

3. Choose File > Export > Instance Frequency...

4. Set the Summary statistics panel to use Selected rows and to send output to Output window.
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5. The results show a quick summary of the athletes speed rows from the timeline. This export while 
very simple is really quite powerful if the instances are accurately coded.

Export Final Cut XML

The Final Cut XML export creates a XML file with instance information that can be imported into 
Final Cut Pro 6.0 or greater.

To use this export, select some instances in a timeline, choose File > Export > Final Cut XML... There 
are two export type options in the save dialog at the bottom: Clips & Markers.

The Clips option will export each instance as a clip in the project bin. So, each instance will be row in 
the clip bin and treated individually.

Markers is the other option. The instance movie start and end times will be imported into Final 
Cut as Markers to the timeline movie. Instance information such as labels is included in the marker 
making it convenient to see data about the marker. See the Final Cut documentation for more 
information.

Both formats of the file that is created will have all the clip information including row, instance 
number and transcription information. The row name and instance number will appear as the name 
of the clip or marker in Final Cut. The timeline file name will appear in the master comment 1 section 
of the bin and the transcription notes will appear in the clip comment section of the bin.

Note: The XML file references the movie data which is likely a reference movie, moving the source movies 
will disconnect the media and the clips will have to be relinked in Final Cut. There are some situations 
that can cause Final Cut troubles when resolving the movie references that are based on other movie 
references and so on. It is best to try not have a lot of movie references built on top of each other. The 
closer the source movie is in the data referenced in the XML file, the better the chances everything will 
work consistently.
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Frequency Reports

This feature allows you to view:

•	 the number of times each Timeline code was used in the performance.
•	 how much time those actions took. 
•	 the percentage of the total performance time those actions took. 
•	 the mean time for each action.

1.	 Choose Frequency from the Analysis menu 
in the main menu bar.�

2.	 In the Summary statistics window, select 
either All rows or Selected rows. If you 
want to analyze selected codes, make 
sure you have preselected the rows in the 
timeline before you start.

3.	 Select the destination for the information 
in Send output radio buttons, to the 
Output Window or to an Excel File.

4.	 Click OK.

Export a CSV Timecode Log

This export generates a CSV file that contains the time of day start and end times plus code name, 
labels and instance notes for the selected instances in a timeline.

Export a Code Report for Sportstec Player

Code Reports may be exported in 2 ways, as Code Window Reports exported from the Code Window 
(SportsCode Elite only) and as reports exported from the Timeline (SportsCode Elite & Pro and 
SportsCode Gamebreaker Plus).

Code Window Reports are derived from scripting routines triggered by coding activity in the Code 
Window. 

You create a file of instances from the Timeline in the same manner as you create Instance 
Movies. You can select entire Rows or select instances in Rows, (Refer to the section on 
page 107), but instead of clicking on the Make Movie icon, you click the Report icon.

Give your Report package a name 
and nominate your preferred storage 
location. You also need to ensure that 
you output your package in a format 
which is able to be viewed by the iPad. 
Any H.264 format will suffice, but you 
will see in the dropdown menu that we 

have provided a number of preset formats for the Sportstec Player app as well. 
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There is also an option to choose the background colour for the report. Code Row colours will colour 
the instances you have chosen, so you may choose a background colour to ensure your code report 
is easy to read. The movie will be exported as a .codereport package. 

When the Code Report is viewed by Sportstec Player, the Report View screen will display the 
package contents in 2 ways :

1.	 If the Code Report was created from a Code Window, the Report View screen layout will mirror 
the Code Window that created it.

2.	 If the Code Report was created from a Timeline, the Report View will display the Row Names 
with a number representing the number of Instances/Events that have been selected from this 
Row. 

Sportstec Player is an App for the iPad which plays movies which have been exported from 
SportsCode as .codereport files. Sportstec Player puts the power of SportsCode vision directly in the 
palm of your players - enabling your athletes to review their clips, playbooks and statistics anytime, 
anywhere!

Used in combination with Sportstec’s Command Centre, Sportstec Player amplifies your analysis and 
enhances the learning of both individuals and teams. The perfect tool for the Analyst that wants to 
share important statistics, clips, moments and learnings and quickly distribute SportsCode content 
to multiple devices.

The portability of the iPad solution enables this to be done simply and allows athletes to learn and 
engage at their own pace.

Direct Movie Exports

Beyond the standard convert movie export, there are 5 direct movie export features found in the 
File > Export > Movies menu. To export a movie using one of these options, create an instance movie 
and select the export from the menu. The export will automatically take place. Each of these direct 
exports do not have any customizable options.

Convert iPhone movie into iTunes

This export converts the instance movie to an iPod ready format and sends it to the iTunes library. 
Depending on the iTunes preferences, it could be added to the library or be copied into the library.

Selected instances in each Timeline row as an iPod movie to iTunes

Upon export, each row will be exported as an individual movie with the selected instances in time 
sequence, selection order cannot be used. The movie name will be the row name. Once the export is 
complete the movies are sent to the iTunes library.

A trick to using this feature, is to duplicate rows and change their names, the movie will take the 
name of row and will appear nicely organized in iTunes. Another clever way of using this feature is to 
make new timeline rows from label columns in the matrix.
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Convert Apple TV Movie to Desktop

If you use an Apple TV device, this export will create an Apple TV ready file that can be synchronized 
to the device. When chosen, the file will be automatically exported to the desktop. This export also 
produces very high quality video.

Convert Selected Instances by Row to iPhone Movie into iTunes

This feature exports selected instances from a timeline and imports them into iTunes. The movie 
names are: CODE_ID#_ LABELS.mov. The file name can be no longer than 255, so some labels will be 
cut off.

Selected Timeline instances

This feature exports the selected timeline instances with options to save them as standalone or 
reference movie. There are also options for creating single movies per instance or single movies per 
row.

Text Window

The text window is a simple text editor. It is commonly used as a notepad or paste board. A clever 
way to use the window is as a paste board. Movie frames can be copied from an instance movie and 
pasted in this window where they can be collected, then later pasted into another application like 
Word. The text window can be saved just like any other text document


